My Account
× My Account Forum Buy Now

Last Epoch Forums

Mouse Buttons do not work Ingame

Hello, my account’s name is Rassen, for whatever reason my mouse buttons: mouse1 and mouse2 stop working somewhat 30 minutes into the game whenever I start, they work just fine inside the game’s menu and outside in the desktop, with this issue i cannot move using mouse1 having to rebind it to a keyboard key, or use any skill with mouse2, Whenever i restart the game (fully closing it) it works just fine until that 30 minuteish threshold is reached, then it stops working again, I’ve reset all functions in the option screen to default and it does not fix it, also I’ve played the game in the past and only now this is happening.

Welcome to the first…

Honestly dont recall anyone having mouse button problems - usually its controller button binding issues…

Please include:

  • Your player.log - games debug file - may have some further information
  • Your le_graphicsmanager.ini - games setting file
  • the output of a dxdiag report - system info and diagnostics (assuming Windows)

Useful files - Last Epoch Support Hub

If you are using Steam, please run the Game File Verification process to make sure your LE install is actually ok and doesnt have something messed up.

Questions:

  1. Are you using any mouse/keyboard software or any macro software?

  2. 30 minute consistency seems odd - i.e. I would have expected a mouse problem to be random/intermittent not with a consistent timeperiod… Do you have anything else running while you are testing LE? Any scheduled events? Is Windows Update doing something and failing?

  3. I am assuming you have already tested the mouse physcially? Maybe even swapped to an entirely different device just as a quick test?

  4. Are you using a controller? Do you have one plugged in but dont use it? Or have you attempted to use one recently? Sometimes button/keybinds can get wonky if you try and use controllers AND keyboard/mouse at the same time…

le_graphicsmanager.ini (494 Bytes)
Player.log (74.6 KB)
DxDiag.txt (84.9 KB)
No i am not using any macro software unless LGHUB counts as one;
Only discord or the browser, 30 minutes was a bit harsh but it did not feel like i played for over or close to an hour for it to occur;
I did not switch to another mouse since it works perfectly fine in the game’s menu/desktop/other games, however when I tried to reassign the walk function to mouse1 it did allow me to remove it but it did not allow me to select mouse1 again;
No i am not using a controller at all, neither have I connected one in the past;

Ok… A few things here:

You are running Windows 11 Insider Preview build - I have no idea how that could affect the game or anything else on your machine. I would definitely not recommend this to the avergage user purely because, from experience, there are any number of issues that could be happening on a preview build that would be fixed on a release build. This is especially true of any applications that interface hardware/drivers - like LGHub, GPU drivers, device drivers (i.e. mouse drivers)… You are essentially running beta software (LE) on a beta operating system.

I would definitely View Reliability History on your system to see what information is being logged on your system that could impact on the problem.

LGHUB software is buggy at best, crap at worst. I have had it cause no end of problems on multiple different systems - everything from causing double click and ghost click problems on logitech devices to simply losing logitech headset pairing and endless other issues like corrupting settings for logitech keyboards etc. I would DEFINTELY recommend checking for a latest version or simply not running LGHUB while trying to test LE. Note that you must be using a Win11 version - the older LGHUB software will have problems.

From the player.log:

  • There isnt any specific abnormal debug message about input devices or controllers so I dont see anything useful that could indicate what is happening
  • You are getting a few odd FMOD errors - this is part of the sound component on the Unity game engine… Could be corrupted or missing files or some other sound related issue. This error repeats enough times in the log that it could be causing unneccessary processing which may affect something else in the game too.
  • There are a few other messages that I dont recognise from normal logs but they are not specific to input… might be UI related but I cannot tell - not a Unity dev.

Le_graphicsmanager - settings.
These are likely ok based on your system details. Personally I wouldnt run the fps at 144 purely for stability reasons - if your average FPS (F11 shows fps in game) isnt getting to 144 then there is no point in setting it that high /matching your monitor… All that would do is overwork your GPU and in LEs beta state right now, you are likely to experience freezes or bigger FPS spikes in busy game moments… reducing the cap, leaves your GPU with some headroom usually. If you are not experiencing side effects, then its entirely up to you… imho games like this dont need first person shooter framerates where every millisecond counts… I doubt this would have an impact on the mouse issue tho.

Dxdiag Diagnostic (end of the file)

  • There are lots of WaasMedicFailure2 errors - this is the subsystem that Windows uses when it realises that Windows Update is corrupted and not working properly… This is likely somehting to do with the preview build you are running - Unfortunatley when windows itself starts thinking its corrupted, there is no way to know exactly what could be going wrong on your system… Normally there are ways to fix this like running Windows Repair installations, System File Checker etc but I have no idea if this is possible with the preview release - in fact, I’d guess that if you tried to run any of the normal fixes it will likely fail or corrupt your os even further… THis is not a good sign as it could affect anything directly or even indirectly and it would be hard to find exactly what is going on.

  • There are also WinSetupDiag02 errors - again, I am assuming related to the preview release you are using… No idea if the preview release installation itself didnt mess something up.

  • You also have a GameBar (xbox) issue - overlays and things like this can cause issues with the Unity game engine so its best to disable this when testing LE.

Suggestions & Questions

  1. Did you run the Game Verification to ensure your installation of LE is ok?

  2. Are you connecting the mouse via any USB Hub device or directly to the USB on the motherboard?

  3. Are you sure all your devices drivers etc are up to date? everything from motherboard USB to individual device drivers?

  4. Have you attempted to test this issue with NO other applications running? There is always a possibility that another app could be conflicting - especially with the Unity game engine. This includes ANY and ALL overlay apps (even Steam Overlay)…

  5. Please View Reliability History on your machine and see if there is something happening that Windows is logging that could be related to the issue.

  6. Have you done some research on known issues with the preview Build of Windows11? Unlikely to be much data online especially specific to unity gaming on the preview but perhaps there is something related to input devices or even usb changes?

  7. I have no idea if the preview release of Windows 11 is potentially causing some sort of issue. Based on my experience over many decades of windows preview releases, its very possible. If that is the case then there is little anyone could do to help you.

Yes I’ve runned Game Verification, I do believe it’s windows 11’s problem, since updating to it there’s been number of odd issues throughout other games that did not happen before, I’ll eventually change it back but thank for your help regardless!

1 Like