My Account
× My Account Forum Buy Now

Last Epoch Forums

Monitor choice option doesn't work

TL;DR Switching between monitor 0 and 1 in ingame settings clicking apply and restarting the game, does nothing. in both settings game starts on same monitor.
System: windows 10
desktop with 2 monitors. graphics card RX 5700 xt.

Full story:
I noticed that for some reason game had higher fps when Last Epoch is not active window. So i started messing with settings, chaning values in limited fps, fps while in background… nothing affected fps in the game, then i switched monitor, restarted the game. and game launched on 2nd monitor. Now i can’t change it back. game launches on same monitor with both 0/1 monitors. I tried to switch from 0 to 1 then apply then restart, I tried switch from 1 to 0 apply, no restart, then switch back to 1 apply again, then restart. same for monitor 0. Nothing affected monitor on which game launches. I found config file “le_graphicsmanager” in \AppData\LocalLow\Eleventh Hour Games\Last Epoch\ and change monitor there, nothing still, with both values game starts on same monitor. I tried to delete that whole EHG folder in locallow, uninstall the game and install again. Nothing. I can change monitor via win+shift+arrow, but it’s solution just for that session.

Hmm… Cant say I have heard this particular error before…

LE settings do tend to be a bit odd sometimes… a similar thing can happen with Sound devices - changing them back and forth and LE ends up using an older output until you go go into Windows devices and change defaults/temporarily disable things and then start the game and it “fixes” itself…

Based on that, I would suggest you check in your Radeon drivers to set the display defaults / or in Windows Display Settings (make default display) and then see if LE re-adjusts its internal defaults to match and back to normal… then you revert and see if it stays put…

There are LE settings in the registry but they are undocumented so messing around there to see if they make a difference is probably not a good idea…

yea, seems like game launches only on “secondary monitor”. made 2nd monitor as main, and game appeared on ex-main-now-secondary monitor. but this messing up everything else around the game.
Where i can find those registry settings?

Did you attempt to change the in-game display to a different setting and then revert your windows back to the correct display… i.e. “confuse” the game back into the correct monitor…

You can search for the registery keys to find them… but I have just checked and there are no default display entries… so I wouldnt mess with these settings randomnly…

yea, repeat whole process of switching monitors around with different main monitor. nothing happened. feels like that setting ingame have no effect whatsoever. only main monitor in windows changes where game launches. This is so weird, how did the game switched monitor in first place. D:
how can i find all traices of LE on PC and in steam, to do just fresh-fresh reinstall? maybe my first time i missed something and it brakes the game.

You have done most of what I would have tried…

Only other thing I can think of is to delete the le_graphicsmanager.ini file while you have changed the default monitor and then restart the game - this would force the game to reset all graphical settings to the default and it would then pick up the other display at the same time… Its similar to deleting the folder as you did before, but doing it while you are trying to “confuse” the game back…

Not sure how to remove ALL traces of the game…

Bootdrive:\Users\Username\AppData\LocalLow\Eleventh Hour Games
Contains the savegames & game configurations…

The actual game files are in the steamapps folder, whereever you have that on your
machine.

Registry keys are in
Computer\HKEY_USERS\XXXXXX\SOFTWARE\Eleventh Hour Games\Last Epoch
Computer\HKEY_CURRENT_USER\SOFTWARE\Eleventh Hour Games\Last Epoch
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Steam App 899770

So I suppose an uninstall in steam…
Remove the appdata folder
double check the steam folder to see if everything is removed
and I suppose removing the registry (dangerous so be careful - at your own risk)

oh… and make sure steam cloud saves are not active while doing this…

Bloody hell. i did it. So, i have return to monke, manually unplug 2nd monitor. booted PC and the game while having just one monitor. it did the trick… for now.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.