Major FPS drops - tried every guide

Ever since the game bacame live I have been experiencing major fps drops.
It is not possible to play without getting upset that your game slows down to 2-3 FPS every 10 seconds.

I have tried every possible guide I could find about these fps drops…
Memory leaks, reinstalling Win11, updating drivers, installing older drivers… everything.

I am using a Laptop ASUS Zephyrus M16:
i9 14gen
32 gb ram
3080 ti

I need help, I paid for a product that should work on specs like the ones above, but can not use it…

1 Like

Performance has definitely taken a hit since 1.0, they optimized some spells after 1.0 but every patch after that seems to make performance worse. 144 to 40 is not good. Shame, was playable before 1.1

Have same issue.

Clip from few min ago. FPS drops under 40
Thats on 5900x, 2080Ti, 32Gb ram at 1080p and not at ultra settings.
DxDiag.txt (128.3 KB)

I am also having the same issue.

I have tried all the setting presets (even very low) and there is a difference in my “normal” fps which is 80-100 (100hz refresh rate) depending on the games presets with vsync+gsync on … However i cant make it through more than a few packs of monsters before the system fps crash, … to clarify … the game almost feels like it freezes for 1 second then back to normal , but this happens constantly … multiple times per minute.

I have tried all combinations of gsync on/off … vsyc on/off. The game gets more fps with gsync/vsync off … but the fps stuttering are just as bad regardless. I have also run the game with my 4k monitor and the 1080 laptop screen , it makes no difference.

This is NOT packet loss or a connection issue. I’ve used my fiber at home as well as an enterprise connection at work. I have also tried wired and wireless connections. CPU/GPU/RAM … none are maxed out to where they would cause an issue.

The game is playable though, whatever is going on with the visuals it is not affecting actions in game , at least not with my cold sorc. The visual fps stuttering just makes the gameplay unenjoyable and not playable for extended periods of time.

MSI GT63 Titan 8SG laptop
GTX1080 , i7-8750 , 16gb ram, latest nvidia drivers, GSync, 3440 x 1440
(windows 11 , AV off during gameplay, Last Epoch process CPU priority: high)

Same for me and i am playing same build forge guard minions. Maybe there could be problem.
Did you try different class? I will play spellblade after forge guard and i’ll see.

So far I only played a bit as FG, so maybe will try Sorc to see if this will be better.

Same Problem fps drops in monolyths, it ruins the fun normal i have 120fps easy, sometimes it drops to 5-10 fps its horrorible.
cpu = 5900x
gpu = 3090
32gb ram
high settings
never had this problem but since 1.1 its not fun
i play glacier sorc

The issue of poor optimization has been ongoing for a long time. To this day, nothing has been done about it, and I’ve lost hope that this game will ever become playable. After the horrific FPS drops in version 1.0 (RTX 3080), I decided to give the game another chance in the 1.1 cycle and launched it on my laptop with an RTX 3060. On medium settings and FHD resolution, the game can’t even maintain 60FPS, which is a terrible result. Unfortunately, playing at 40FPS is not satisfying for me, so I just stopped playing. I also see no point in playing on ultra-low settings, as that’s not what it’s all about. I should add that I don’t have performance issues with other games on either computer, and for example, D4 runs ultra smoothly. It’s a pity, Last Epoch is a good title, but unfortunately, making this game on Unity without DLSS support was a disastrous mistake.

Bump for visibility. I am having the same issue. CRAZY fps drops in monos - like I have literally seen it drop to sub 20 fps. Seems to get worse the higher I push too. 500+ now and some maps are almost unplayable. I have tried lowering settings and nothing seems to help. For the record - this is the only game that runs poorly for me.

My specs:
7800x3D air cooled - never going above 70c
EVGA 3080 FTW3
MSI Mag B650 Tomahawk
32g 6000 DDR5
850w Gold PSU

Echoes on daily basis…
Not sure why recording stopped after changing settings but i can run up to 205 fps.
Have it set to 60 to decrease some of the lagg but doesn’t really matter.

I have ~850hrs in LE (mostly from 1.0) but am also going to have to call it quits until something gets done about the optimization. I had some minor performance issues in 1.0 but nothing like 1.1. Like others have said, some maps are unplayable due to the FPS drops. Hopefully this gets resolved before the next major release :crossed_fingers:

Specs:

  • Razer Blade (2023)
  • 13th Gen i7 (i7-13800H), overclocked @ 5.2 GHz
  • RTX 4070
  • 16GB DDR5