Mac update seems to not be working

Updated on Steam.

Log in. First thing I notice, no music. I checked settings. Restarted to see if it was a glitch. It wasn’t.

So decided to just take a look at stuff on the ground floor of EoT. It’s so friggin’ gorgeous.

But, sadly, I can’t play it right now. Mouse clicking is really glitchy. In fact, here’s a video of what happened to me after picking up a shield in my stash. I tried dropping it but it just kept duplicating over and over again. And it sticks to the cursor. Even more strangely is I exited the game completely. Restarted, no music, logged back in. The shield was still stuck to my cursor and still duplicated stuff on the ground. The stuff from the first time was gone but any duplicates I put in my Bag were still there.

This also prevents any use of the mouse at all except to close windows or open up the menu bar.

EDIT: Forgot to mention at the end of the video when I just sit there with the shield I"m actually hitting ESC repeatedly to see if it closes windows and open main menu window. Never does.

Logfiles included. There were two in the folder, just fyi. Upload said it was too big to upload so here are the google drive links:

Very strange. Sorry about that, we’ll do our best to look into this. I’d recommend that you try to repair the game if you haven’t already. The log points to something in the audio system failing to load, but the files should be there.

I did do a steam verify of the files. No change. should I uninstall and reinstall the whole thing? See if that fixes everything?

If a verify didn’t change anything a reinstall probably won’t either. We’ll look into this, apologies again.

1 Like

I juust installed the update on mac/catalina and logged into game and am immediately having this exact same problem. I bought an item from gambler and now it wont leave my hand. I can drop it but it keeps reduplicating itself. There are now hundreds of the item littering the ground.

I would simply discard the character and call it 30 hours lost, but he is wearing all my best items, and because of glitch I can’t actually move to stash to store them.

If you can’t resolve the problem, is there at least some way to allow me to move while the item is in my hand, so that I can transfer my items to stash? I was just getting so into this game, this is incredibly frustrating.

I’ve tried restarting computer, restarting steam multiple times, restrating game multiple times and verifying integrity of game files in steam. Every time I restart game the ghostly item is back in hand.

You guys are rock stars. No need to apologise at all. You repeatedly demonstrate thoughtful and concise work. It is greatly appreciated.

Same issues :frowning:

Just to confirm - is this still happening for people on the new 0.7.9c?

Yup. It’s still the same. And I also checked it’s doing it to all of my characters. .

Yes, the item is still stuck in my hand after today’s patch.

Unfortunately it appears that all MAC users are experiencing the same issues. The game is unplayable under the current conditions. For example let’s say you want to create a new character… the minute you destroy an advesarsary the body of said destroyed monster remains standing on the screen and if the mob drops loot it immediately becomes locked to your cursor and duplicates if you try to release it.

Any other MAC users find a solution to the issues brought about by most recent patch?

I have the same problem. I just logged in and it happens with the Arena keys. I’m also on mac.

Unfortunately I haven’t had a ton of time to look into this issue. However, I did put in a potential fix for 0.7.9d.

Please let me know if the issue persists or not after the update, and include your log file again if it does. Thanks!

1 Like

Just downloaded the patch. Fired it up and no go. It’s still there. I didn’t check every character but did a couple of the one’s I had tried it on before.

Log files. (23.0 KB)

Unfortunately not a fix.

Was wondering the same thing… will this get resolved or the death nail for MAC users?

This post has a potential fix by some talented forum users, but I can’t try it out because I have no other games with this specific file.

I managed to buy this game just yesterday, Mac ARPGs are so rare, one kind of understands why, with situations like these.

Hopefully some kind of fix is coming soon, I really want to try this game out… But yeah, from what I’ve seen, it’s quite a small team and they do look like they’re doing an astounding job, so I can’t even be mad at them haha…

Tried this and it didn’t work for me, unfortunately.

However I did get cloud working. There was a useful post over on reddit.

Followed the instructions and copied them into my PC Bootcamp version.

Got to play the game. And the good thing is when I went back to the Mac version to check it seems to have jumpstarted the Mac Steam client to start the cloud and it appears to be synching.

I can’t test if the files are working because the issue with the stuck mouse and no sound still persists and can’t click on anything except the exit button once your mouse gets locked onto an item.

Hey everyone. Apologies for the delay here! I’ve corrected the issue on our end and we will be releasing a fix in 0.7.9e.

1 Like