Lost connection to the game server

The end game is completely unplayable due to lost connection issue. When you try to go anywhere in the game, it will always show a lost connection issue and you will be disconnected. Multiple bug reports already file for this but the issue still not being fix. Tried multiple times using new and old characters and still the issue is showing. Meaning I bought the game but I cannot play it. Also, already filed this bug via email but did not here any updates since then

Bug request (21677) and (21599)

1 Like

Hello devs, any updates on this issue?

1 Like

Devs are unlikely to reply this quickly and this bug report doesnt give them anything to work with to check a possible problem.

I would check on Discord to see if anyone trying to play on the same region servers is also having an issue…

If the game plays fine in offline mode, then its some sort of network issue that could be anything from a problem in/on the region servers you are playing on or anything on the network between you and the server (and how fast/reliable it is - e.g. I cannot play online without network problems simply because the latency is too high).

If the game doesnt play in offline mode, then server lost connections are not the problem and there is something else specific to your system that is the problem.

ahhh you mean the problem is not on their servers? I’m pretty sure its on them because other games are working on me and already tried different ISP and nothing is working. Game log already sent to them via bug report email because I already reported this so many days ago but still they are not fixing it.

Bug request (21677) and (21599)

Well, there are so many possible reasons for this and it usually needs more than a few people to confirm something is totally wrong with a server… It may be, but then everyone on a particular server region would be complaining - it has happened before. Hence my suggestion of checking discord as its more “live” there.

I have network issues, but I dont blame their servers because I know mine are caused by latency issues.

The reason I suggested to try offline mode is to see if the game itself is working ok on your system. I.e. make sure its not something local on your system… then move on to the server side…

Other games working has absolutely Zero to with with LE - that makes no difference and only confirms your physical machine is actually on and has a net connection.

Not how it works here I am afraid. This is a beta game and unless there are hundreds of people all confirming a critical bug or server issue - somehting thats easy to realise, any individual issue will take time to get resolved.

The next dev update specifically for bugs is scheduled for later this week - the dev blog note 0.9.2a mentions that it will come sometime this week. no specific time.

Here are the game log error that is showing every time I’m having this lost connection issue
The referenced script (WFX_LightCurves) on this Behaviour is missing!
The referenced script on this Behaviour (Game Object ‘Point light’) is missing!

Both of these also have:
UnityEngine.Resources:Load(String)
AbilityManager:get()
AbilityManager:EditorReset()

Can you help me if you know how to fix this error? :frowning:

Also looks like a very very common issue since then. Tried searching Lost connection in the forum and found out that over 50+ reports already filed Search results for ‘lost connection’ - Last Epoch Forums — Most of them are just report with no solution :frowning:

Player.log (123.0 KB)

That error everyone has at one time or another… afaik its just a holdover from older scripts that they havent cleaned out yet but is still logged.

I am not an EHG dev but the errors in your log that I would think are more important are:

System.IO.FileNotFoundException: Could not find file "C:\Users\##<redacted>###\AppData\LocalLow\Eleventh Hour Games\Last Epoch\Filters\Fire Lazy Massive Minions.xml"

System.NullReferenceException: Object reference not set to an instance of an object.
  at PixelCrushers.DialogueSystem.Examples.AlwaysFaceCamera.ComputeScale () [0x00000] in <00000000000000000000000000000000>:0 

System.Net.Sockets.SocketException (0x80004005): interrupted
  at System.Net.Sockets.Socket.ReceiveFrom (System.Byte[] buffer, System.Int32 offset, System.Int32 size, System.Net.Sockets.SocketFlags socketFlags, System.Net.EndPoint& remoteEP) [0x00000] in <00000000000000000000000000000000>:0

The first could point to a problem or corruption with your Loot filters - from experience, corrupted loot filters can cause a wide variety of errors because they apply every time anything drops in game. (ps. I removed your name from the reference so its not shown here in the clear)

The second seems to point to a problem with the subsystem that handles the NPC dialog - I dont recall seeing this kind of problem that often before so perhaps there is a bug here that is involved. It could also be a potential game file corruption of some kind that may need a Steam Game file verification to double check.

The last is most definitely a network connection log that would align with your lost connection in game - unfortunately this error doesnt give me, not a dev at EHG, any specifics… It could be anything from the server disconnecting you due to some issue to any number of networking problems or configurations between your gaming PC and the server itself and anything inbetween not liking some part of the connection.

One thing I did note is that that you are on the jpn-east server and I have seen one or two other people mention problems that were also on this server… Not enough to say the server was down but maybe with the increased load after the new patch dropped, that particular server is flaking… Only a dev would be able to tell for sure and I am just speculating here.

As a test, I would try a different server (yeah it may be slower) but see if it has more success.

Another thing I couldnt get - you mention End-game but dont provide specifics? There have been previous bugs where the problem was linked to a specific part/map of the game so it would be important to understand if that could be what is causing your problem - a bug in a very specific place or interaction in the game. People are regularly finding very specific bugs like this and its very possible you could be one of them.

Ohhh alright thank youuu so much!!! :slight_smile:

I see that’s my loot filter. I’ll give it a shot to remove it and update if it works. How can I prevent this kind of loot filter errors?

On the second one, alright i’ll try again to verify steam files

the last I don’t know neither huhu because my network is doing fine on other apps but thank you for pointing out

Last time i tried connecting to all available servers but still I’m having the same error :frowning:

Ohh okay sorry not being specific hehe. This what usually/always happening. Actually now not just on end game but also on any new character. So every time I log in to a character, I can stay online for many hours just not going to any portal or teleporting to a new map. Once I go to any portals or teleport to a new map, after 15-30secs… Lost connection will show up

Thank you again @vapourfire for helping I hope deleting that Loot filter will fix this

Hi @vapourfire here is the new player log. Sadly still not working. Not sure why loot filter issue still present even though I already deleted it
Player.log (225.8 KB)

Dont get your hopes up regarding the loot filter - it may just be something going wrong in addition to your connection issue.

Verify Steam - always good

You could be experiencing the problem that others are having with massive delays between loading maps / teleporting - thats a known problem and might be what you are having … i.e. its timing out - some are saying its as long as 60 seconds for some maps… Devs are working on that apparently…

DId you delete them in game or from the folder while the game isnt running? Usually you have to delete them from the folder - the game gets itself in a knot if you try and delete corrupted filters from in-game.

This log has got a LOT more network errors than the old one… including new ones saying its having some sort of problem loading your character data… Unfortunately I have no reference to what it is pointing to…

I have a feeling that your problem could be related the other one that everyone is having when they transition from map to map… without any other info, that would be my best bet.

the positive side - the devs are very aware of this issue - so maybe the next hotfix will resolve it…

Yes, both in game and C:\Users\Username\AppData\LocalLow\Eleventh Hour Games\Last Epoch\Filters folder are empty

Oh no :frowning: actually adding this detail. The day before the 0.9.2 update. That day gave me a whole day to play without any issue. I can log in log out anytime in the game. But after they release 0.9.2, the lost connection is back :frowning:

Thats very strange - then where is the game trying to load that filter from? It cannot even know it exists to be able to log it… thats weird… are you sure that file doesnt exist somewhere?

The timeout problem only started in 0.9.2 so thats what I would put the money on…

Same kinda weird also :frowning: Does the EHG team need to do some clear caching on there end maybe? Maybe my save data on them still finding these loot filters. Also can you help me one last thing? :frowning: Every time I’m getting this Lost connection issue, my disk storage gets 20mb+ lower and lower. I tried uninstalling the game but I’m not getting my original disk space before I install Last Epoch. Can you help me where to delete those files storing this Lost connection error?

Loot filters are all local to your PC so there shouldnt be any clearing of caching needed from EHG. They dont have access to your machine. The savegames themselves dont reference the filters (at least not the offline saves) so honestly have no idea.

The games stores logs that are player.log and player-prev.log and if there are problems these files can get pretty large but they are usually overwritten with each restart of the game so they shouldnt increase the space used on your machine over time… There are no large files that I know of and none on my system that are big enough for me to notice after crashes etc.

When the game loses connection does LE crash to the desktop? I.e. could Windows be logging crashes? Or does the game just go back to the login page?

Maybe you can search your system for new timestamp files and just see what is new - that may give you an idea of what is going on.

One thought, 20mb is pretty small these days and I personally wouldnt notice files like this being generated on my system until they really piled up - do you have a free space issue on your system? Windows is notoriously bad & potentially unstable when a system begins to run out of space for swap and other memory management. This can affect virtually everything and anything on your system.

Tried everything now. All the info I found how to fix this issue. Even tried to update everything on my PC. Seems nothing is working :frowning:

Sad. Beta 0.9.2b Patch Notes they still not fix this issue in this patch. Very disappointed :frowning:

Myself, and all my friends who play encounter this bug repeatedly.

Some days no issues, other days ever time you go to zone, or sometimes in the middle of a zone. DNS cleared before launch, network monitoring shows not package loss or intermittent signal. Don’t experience connectivity problems with any other played games. Just this one.

This is a server side issue for sure.

still no updates when this issue will be fix?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.