My Account
× My Account Forum Buy Now

Last Epoch Forums

Loss of Computer Power

I tried playing today and out of the blue, my AFCI / GFCI outlet tripped causing a complete loss of power. I replaced the outlet and cleaned out the computer and it still causes my computer to shutdown. I’ve tried other games and applications and it only seems to happen with Last Epoch. It always occurs within a few minutes. Has anyone else had something similar happen?

Hey…

LE is unoptimised so it can push hardware components which in turn draw more power from the power supply and if there is a problem with the power delivery it can crash the computer… Power delivery can also be affected by the motherboard power components - ie. if a capacitor on the mboard is blow or dying then you can get intermittent power issues - and you will not notice them unless the system is stressed.

However, it should NOT be tripping the circuits in your home. This should not be happening if a power supply fails due to overload unless it has developed a short. This could be a failed component in the power supply or something that got into the power supply like a piece of wire/screw etc.

Two things…
Test something of decent load on that same circuit to see if it trips… If it does then you need your electrician… If it doesnt then your PC is having hassles and I would start with the power supply… then motherboard… then anything else…

I was trying to avoid having to replace the power supply or other components until I can build a new computer. Components for the newest stuff are hard to come by. I’ve tried other things with no problems. I guess I’ll have to avoid LE for a little while until I can replace parts, build a new PC, or LE becomes better optimized. Thank you for your advice.

Sure… but just double check the circuit independantly from the PC issues.

Even if your power supply is flaky it should not be tripping your breakers like that so its best to make 100% sure your home wiring is ok. Wouldnt want your house burning down or something. For me this would be a piece of mind thing - even if there turns out be nothing wrong, I would still want to check it.

1 Like

I thought for sure it was just me, but this has also started happening to me, and only when LE runs.

Cuts my PC power after 10~30 minutes. Seems to have started happening after 8.2G.

Hey, Welcome to the forums…

I will reply in your separate post…