My Account
× My Account Forum Buy Now

Last Epoch Forums

Losing controller functionality. Reproducible

Hi. I recently bought the Steam version and I’m having a bizarre problem that I don’t recall having up to this point (2.5 hours played). If I can’t resolve it or this appears to be a “me” thing, I guess I’ll ask for a refund because for me having decent control support is a requisite for these types of games.

Okay, so I have a dualshock 4. Connected straight into Steam with only PS4 controller and Xbox controller support selected on Big Picture. For the two first sessions it worked like a charm, despite being shown as an “xinput controller”. And now I’ve encountered this bug where I’ll lose some controller functionality, but not all.

STEPS TO REPRODUCE:

  • Log in game.
  • Summon the main menu (with “start”)
  • Press down on the D-pad 4 times (as if to select “log out”, I can’t recall if it’s 3 or 4 presses).

When doing that, the menu button will be unselected. I can still use the right stick to cursor around, and the left stick and action buttons will still work to move my toon around and talk to people, but I won’t be able to close menus with start (I can however, OPEN the pause menu with “start”, just not close anything). I can summon the “select” menu, but some menus will open when releasing and some won’t (I can open inventory, can’t open maps). I believe I’ll be able to open portals and control the zoom with the d-pad, but won’t be able to navigate items or menus without cursoring around with the right stick. It’s like the menu functionality will just stop working.

I’ve tried unplugging the controller, removing it and selecting it again, no dice. I’ve tried big picture on, off, unselecting PS4 support from Steam (which bizarrely will detect the ds4 as “dualshock”), I’ve tried ds4windows, I’ve connected my xbox controller. In every instance, the steps above will break menu functionality. The only case where I’ll recover gamepad functionality will be if I close the game, then launch it again. I have no other controllers connected to my computer, and the other half of the functionality appears to be working fine, just missing the whole menu/UI side of things.

I’m sorry for the half assed testing in this case, but I’m up to 2.6 hours and I won’t be able to get my refund if I test any further. If this problem can be reproduced, and you need any more information, I’ll be glad to log in and help fix it, I can play the game at a later time if this is not something that for some reason only happens to me. I’ll have the game installed in my computer for a week more if you need any files or logs, but I will avoid launching the game any further so as not to compromise my refund chances. Any help will be appreciated. Thank you.

Hey there…

I dont use a controller and dont have one to test this issue but I did a quick shoutout on the discord channel to see if someone can reproduce this issue…

By the devs own admission, controller support is not yet complete (only planned for 100% on release of 1.0) so it could be that this is something specific that you have stumbled on.

Please post the player.log and player-prev.log - the debug files might have something to explain what is going on.

Two log files, coming right up.

Player.log (44.4 KB)
Player-prev.log (61.4 KB)

I completely understand if this is a beta thing and to be honest, the game can be played anyway with this. I’m just concerned about this being some weird interaction with my system that will never get fixed, because if I’m at risk of losing menu functionality and the only way to resolve it is to close the game (considering how sparse auto-saves are) I’m not sure I want to put up with it. If this happens to other people, however (or by some miracle it shows on the log files), then I’ll happily assist in diagnosing and resolving this.

Thanks for including these logs…

There are definitely Controller related debug messages that I havent seen in logs with people that use controllers successfully.

Looks like the controller component is definitely struggling - its connecting to the controller and then disconnecting over and over and crashing with various types of errors related to the UI and Navigation. There is even a specific debug message referring to a problem with d input.

The devs do read these technical support & bug posts and while they dont always respond, they do take note of what is happening so these logs will help when they see this.

One thing I was thinking… There are plenty of people using controllers fine (even with the limitations of the support) so there might be something else at work here… LE doesnt like the Steam Overlay and I am wondering if Steam is messing around and causing odd things - its not unheard of…

There is actually a standalone, non-steam version of the game that you get access to even if you purchased the Steam version (see your account https://lastepoch.com/player/account/overview) - maybe that version would be better for controllers - just guessing here.

Based on other players feedback, third party apps can also be a benefit (where they just emulate a keypress so the game things its a keyboard use) or can cause more problems by confusing the input commands that the game is getting. So it might be something you could test out a bit more…

Your point about it working for a while and then not is also interesting and makes me wonder what could have changed that caused this.

There are a few instances I know about where if you use both the keyboard and controller at the same time, then the game gets confused and messes up… That one was confirmed by the devs on discord so if you are doing that then maybe this is a side effect… The solution for that particular issue is to use one or the other - not both.

I personally hate using controllers - my hands just never fit properly & I get craps - and dont have one so I cannot really test anything out myself unfortunately so its impossible for me to test anything and see what happens even if I wanted to.

Huh! Didn’t know we had access to the non-steam version with steam purchases. I’m downloading the game off-steam now and will definitely try it out, see if that gives out any different results.

I uh… launched the game again (could be 'cause I wanted to troubleshoot more, could be 'cause I like the game) and I was able to get some more testing data. I can confirm that the problem happens when the “log out” button is highlighted, regardless if you press “down” three times or if you press “up” on the d-pad enough times to circle around the menu and select “log out” as well, and regardless of any inputs in between. If logging out to the character menu, menu functionality will work again once I’ve logged in-game.

The only nonstandard thing I can think of with my computer is that I’m using vgiembus and hidhide (two drivers that allow the dualshock to be used with ds4windows and hide the original controller, respectively), but this was reproducible on my wired xbox controller, I’m not sure if this has anything to do with it.

Anyway, thank you for the additional input, and it’s good to know that the problems are showing on the log files. I’ll try the off-steam version as well as taking hidhide out and see if that does anything.

Message from Discord

From Leif Einar Amundison*:* I just tested this myself, and I can confirm this. Regardless of the controller used (Tried PS5, PS4, and XBox1) this always occurs when using the DPad. I don’t know what exactly causes this, it’s as though the game tries to select a button that exists below the “end session” prompt and then just promptly flings the cursor out of the game window. I can’t reproduce this reliably, but sometimes it fixes itself when switching back to Mouse and Keyboard and wiggling the mouse around.
I had this, too, when I bought the game back in December 2021 and tried out the controller support, just for fun. I thought it was just a me problem, but it seems that is a serious issue with controller support.

(Discord)

Can confirm this happens with the non-steam version as well, and that HidHide is not to blame. I’ll try the mouse wiggle method, but so far I can also confirm that selecting “leave game” and returning to the character selection screen seems to do the trick.

Well hey, if this is reproducible, shows in the error logs, and does not seem to have to do with my setup, then I can rest easy. It’s not a critical problem (to my knowledge at this point in time) so I can live with it, regardless of how annoying it can be if I trigger it inadvertently. Thanks for asking around Vapourfire, and thank you for looking at the logs and confirming that it shows.

1 Like