My Account
× My Account Forum Buy Now

Last Epoch Forums

Linux OOM Error - changing area crashes game

Hi,

here are some facts about my setup:
OS: Manjaro Kernel 5.13
CPU: AMD Ryzen 5 3600
RAM: 16GB
GPU: NVIDIA GeForce RTX 2060 Super

Playing via Steam.

When changing an area I get the following error message in the log file and the game closes immediately

oom-kill:constraint=CONSTRAINT_NONE,nodemask=(null),cpuset=/,mems_allowed=0,global_oom,task_memcg=/user.slice/user-1000.slice/user@1000.service/app.slice/app-steam-c4f9c39dd6354a4c9fbf93aa363fc8>

Out of memory: Killed process 5025 (Last Epoch.x86_) total-vm:24251952kB, anon-rss:12580960kB, file-rss:280508kB, shmem-rss:20512kB, UID:1000 pgtables:31588kB oom_score_adj:0

Greetings

Jürgen

Hey there… Welcome to the forums…

Crashes when changing location - i.e. taking a portal or loading into a new map are usually signs of three things… GPU driver issues, game corruption or performance/setting related instability.

These issues are usually OS independent… LE only officially supports Ubuntu based distributions but a lot of people are able to get the game working on others - it usually just requires more “under the hood” effort… especially if something goes wrong.

As you havent included the full player.log, I cannot see if there is anything else that might be more specific as to the error you are having so I am going to assume that its one of the usual culprits.

My recommendation would be to

  1. check your GPU drivers - I think Mesa versions are on 21.3 when I last checked.

  2. Verify the game files via Steam - very important for ALL and any issues with the game right now.

  3. Temporarily reduce your in-game settings to very low @ 1080p with all special items disabled (shadows AA etc) and a framerate limited in game at 60fps (very important to have an fps limit)… If the crashing stops with these exact settings then its likely you have the known performance instability issues and simply need to be more conservative with your settings choices in favour of more stability than eyecandy… Simply increase the settings one by one until you get to an acceptable tradeoff between quality/performance/stability… Remember this is more about the unoptimised state of the game right now… not your hardware… If the crashing is still there, then the problem could be more serious…

Thanks for your response.

With version 8.2 it worked like a charm with graphic settings set to ultra.
Drivers are up-to-date and the framerate ist limited to 60FPS.
Game files passed verification without any errors.

Setting everything to very low did the trick.

Here are the logs for everything set to ultra.

le_graphicsmanager.ini (468 Bytes)
Player-prev.log (37.5 KB)
Player.log (20.3 KB)

0.8.3 has added a boatload of new features etc and Chapter 9 new animations/mobs etc are definitely more resource intensive so there are a lot of people who have experienced a small but noticeable performance hit… From past experience, I expec the devs to improve things as they go… its sort of a wave like graph, new things degrade performance, then it improves again, then they add more etc…

Having said that, the Ultra setting is a problem child… it is always more unstable than other settings and imho I dont really notice the improved quality in the thick of battle… I prefer stability & performance… My recommendation to anyone who asks is not to run Ultra right now - it just isnt worth it beyond “sight seeing” the game…

I would recommend you just up your settings to something around High and see if things are still stable and go with that till the devs get around to optimising the game… apparently the multiplayer version will have a big impact on performance - heres hoping for a positive one…