Linux native client + Radeon GPU could cause epilepsy from mobs flashes + whole screen blinking in same maps

You need to fix linux native client. There are HUGE graphical glitches for linux gamers despite the existence of a native linux client:

  1. nvidia users report that can play OK the game through proton - NOT native

  2. radeon users (like me) cannot play through proton or with -force-vulkan because performance is terrible for some unknown reason. (I have a radeon 5600XT + Ryzen 5800X3D and get max 30 FPS through proton while I get 250 FPS natively)
    see reported proton request here: Last Epoch (899770) · Issue #6642 · ValveSoftware/Proton · GitHub

  3. The problem is that playing natively I get FLASHES either in mobs or the whole screen in some echoes, not all of them (i.e. I get flashes when sirens are in the screen. The problem is minimized (NOT ELIMINATED) if I use AMD_DEBUG=nodcc %command% and set volumetric lighting to “very low” and enable SMAA antialising. This means I also get a -30% performance in FPS.

I hate myself for booting windows in order to play despite I bought the game because of the linux client.

I have more than 100 hours in the game and tried hundreds of tinkering methods and settings to eliminate the flashes but it wasn’t possible to fully eliminate them. Either I’ll get epilepsy playing the game or I need to play it in windows… (see example of the flashes

Not to mention the INVISIBLE character models in the character selection screen, which has been reported months ago ans still not fixed.

So please either FIX the native linux client or STOP selling it. I can play perfectly many many games that do not have native linux support through proton and I can’t play Last Epoch which supposedly has a linux native client.

PLEASE FIX! This is frustrating. If you can’t fix it, PLEASE work with Valve to improve proton so we can play the game from proton.

I have recorded gameplay which shows the whole screen blinking problem. If a dev replies and decides to work on the problem, I can post logs and additional videos showcasing the problem.

Hi @tux2 ,

I’m playing on Linux too (you can explore my past posts), my conclusion is that you should just abandon the Linux client. Don’t care about it.

Just target getting the Windows client to work well. Here I can probably help you a bit.

First of all, don’t use the standard Steam proton layer; the Proton GE layer which is community driven is updated much more regularly. I literally double my FPS with it. The Github project has all the instructions necessary:

Secondly, make sure your Vulkan drivers are properly installed, and that the vulkan libraries are using the correct ones:

$ vulkaninfo | grep driverName
        driverName      = radv
        driverName                                           = radv

Since you’re on Radeon, you want radv to be displayed here. You do not want amdvlk or amdgpu-pro. You’ll need to change the packages and drivers installed if you see this. Lustris has a really great set of resources about what drivers to install:

This is particularly important to DXVK, which is the Vulkan compatibility layer to D3D11 (which is used in the game). Note that you do not need to install DXVK independently, it’s already installed in Proton-GE.

Lastly, you’ll need to configure your command line path on Steam, as well as the compatibility layer used. I’m also on Radeon, this is with the command line I use, which works for me:

  1. In your game library, go to “Properties” → “Compatibility” and select “GE-ProtonX-XX”
  2. In launch options, set some variables, such as: DXVK_HUD=devinfo,fps,frametimes,scale=0.5 PROTON_NO_ESYNC=1 FMOD_ALSA_DEVICE=pulse gamemoderun %command%

The DXVK_HUD variable shows me some info on how DXVK is doing. PROTON_NO_ESYNC is to disable ESYNC (in the hope of forcing FSYNC), note that I also use gamemoderun which you’ll need to install (or remove if you don’t want it), it gives me a slight boost in performance.

With this, while activating Fidelity FX, I get usually 50-60FPS sometimes 40PFS on my old Radeon from 2019:

 lspci | grep Radeon
0b:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 14 [Radeon RX 5500/5500M / Pro 5500M] (rev c5)

Which is less powerful than yours.

All the best!


I am afraid nothing of the above worked. I used latest protonGE 8.4 (I had tried that anyway), I made sure my driver is radv, I tried the launch options you suggested, I used bleeding edge mesa 23.2 (from oibaf’s ppa) and I get max 45 FPS (in the End of Time monolith). This is without enemies and it is unacceptable compared to 250 FPS I can get in the same monolith in Windows, or with linux native version. Using ptoton, when I enter an echo and start fighting enemies it is a greek tragedy. This is the only game that has this behavior for me. All other games I play through proton perform excellent (i.e. grim dawn, xdefiant etc).

This is my system report:

george@ryzen:~$ inxi -SPARM -GCDN -v1 -xGCRS
  Host: ryzen Kernel: 6.3.7-060307-generic x86_64 bits: 64 compiler: N/A
    Desktop: Cinnamon 5.6.8 Distro: Linux Mint 21.1 Vera
    base: Ubuntu 22.04 jammy
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B350-F GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 6042
    date: 04/28/2022
  Info: 8-core model: AMD Ryzen 7 5800X3D bits: 64 type: MT MCP arch: Zen 3
    rev: 2 cache: L1: 512 KiB L2: 4 MiB L3: 96 MiB
  Speed (MHz): avg: 2200 min/max: 2200/4549 boost: enabled cores: 1: 2200
    2: 2200 3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 2200 10: 2200
    11: 2200 12: 2200 13: 2200 14: 2200 15: 2200 16: 2200 bogomips: 108588
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    vendor: Sapphire driver: amdgpu v: kernel bus-ID: 09:00.0
  Display: x11 server: X.Org v: driver: X: loaded: amdgpu,ati
    unloaded: fbdev,modesetting,radeon,vesa gpu: amdgpu resolution: 1920x1080
  OpenGL: renderer: AMD Radeon RX 5600 XT (navi10 LLVM 15.0.7 DRM 3.52
    v: 4.6 Mesa 23.2.0-devel (git-96cf453 2023-06-08 jammy-oibaf-ppa)
    direct render: Yes
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
    bus-ID: 09:00.1
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 0b:00.4
  Sound Server-1: ALSA v: k6.3.7-060307-generic running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.99.1 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    port: e000 bus-ID: 04:00.0
  Message: No RAID data found.
  Local Storage: total: 7.28 TiB used: 1.52 TiB (20.9%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
    size: 931.51 GiB temp: 35.9 C
  ID-2: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB
  ID-3: /dev/sdb vendor: Toshiba model: HDWD130 size: 2.73 TiB
  ID-4: /dev/sdc vendor: Toshiba model: HDWD130 size: 2.73 TiB
  ID-1: / size: 313.91 GiB used: 53.96 GiB (17.2%) fs: ext4
    dev: /dev/nvme0n1p4
  ID-2: /boot/efi size: 96 MiB used: 48.5 MiB (50.6%) fs: vfat
    dev: /dev/nvme0n1p3
  Processes: 416 Uptime: 1h 54m Memory: 31.24 GiB used: 5.01 GiB (16.0%)
  Init: systemd runlevel: 5 Compilers: gcc: 12.1.0 Packages: 3033 Shell: Bash
  v: 5.1.16 inxi: 3.3.13

Hi @tux2

Seems like it didn’t help. Regrettably that’s the best setup I arrived at for myself.

Check out the protonDB which a list of setup/ratings from user feedback (you can also submit yours, if you have not checked it out already):

Another thing I did try, was to control my own env (so as to set my own DXVK version, so I ran bottles in flatpak as the steam runtime layer. This is pretty involved, and probably more tinkering than needed.

1 Like

The problem also is mentioned in proton/valve github page as a request for improvement.

I hope some dev from valve tries to fix the problem, sind last epoch’s devs don’t care about linux version obviously…

1 Like

version 0.9.1d3

Still no fix for graphical problems for Linux client.

For RADEON GPUs, there is an easy patch from a very smart guy that completely solves the problem of invisible characters in character selection screen and possibly solves the flashing & blinking problem (still testing to find out).

Flashing & blinking problem is still here despite the fix of invisible characters in character selection screen.

For this problem alone, I started an investigation thread. Feel free to contribute there if you have any info regarding this matter.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.