My Account
× My Account Forum Buy Now

Last Epoch Forums

LINUX launch options for AMD dedicated laptop card?

I found the following for STEAM client, where do I put these launch options on standalone linux client? I just got ‘new’ Dell i5505 with all AMD, game can’t be using GPU correctly. I’m used to nVidia, new to AMD on linux, any advice is appreciated!

I’m only getting 15fps so something’s not right
I tried setting arguments in LUTRIS per below, no effect

If you are using an AMD GPU with the MESA Drivers you must set:
-force-vulkan -gfx-enable-gfx-jobs 0

as a startoption.

Hey there…

Two things:

  1. I do not know the specifics for passing arguments to the linux standalone player… The game uses the Unity Game Engine… so you might be able to find a search result that shows how to add arguments to a Unity player game… I did a quick search in the Unity manual online but couldnt find an example to quote for use on Linux (plenty of examples for Windows/MacOS) - you might find something…

  2. I looked up your laptop spec… from what I can find, it comes with integrated graphics, Vega 10 graphcis on AMD or Nvidia MX330 graphics on Intel… Unfortunately neither of these meets the minimum performance requirements for playing LE… The minimum is a graphics card of about the performance of a 660 Ti… On an AMD i5505 you have a Vega 10 integrated GPU… this is about 150% SLOWER than the minimum requirement… So the fact that you are getting 15fps is ACTUALLY VERY GOOD and I dont think you should expect to get anything better no matter what settings you use…

EDIT: I found another Dell “G5” i5505 laptop which has an AMD Radeon RX 5600M - is this your model? If it is, then my point 2 would no longer apply and you should be getting 60fps+ depending on quality settings.

It’s got RX 5600M and still only runs 15 fps, somehow it’s NOT using GPU IMHO, Mesa etc all updated, just very lousy performance. I’m new to AMD drivers on Linux, read something about forcing dedicated GPU, but I’m a bit lost, nVidia linux just works

EDITL all the gl tests I run get full accel from GPU, just NOT LE and that’s only game I run

Hey there…

Still looking for a better how-to-guide, but I found this:

the comments might also have more info for your problem…

Wonder if this has better options to configure linux AMD drivers to use specific GPUs?

https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux-21-30

well, I gave up on AMD graphics, everybody dumps on nVidia on linux but at least it works, I can get 90+ fps w/o any messing around, thanks for the links tho, it is appreciated!

1 Like