My Account
× My Account Forum Buy Now

Last Epoch Forums

Linux: game suck on splash screen and doesn't open on Dell G3 laptop

Hello
I’m trying to solve this issue for a couple days without any success… I’m trying to play LE on my laptop Dell G3 and I got always the same result: the game stop on the splash screen and I receive a message to shutdown the game or choose to wait. If I wait, my notebook crashes and I have to do a hard reboot.

I’ve tried to use the steam launcher and it doesn’t work.
I’ve tried to use the Linux installer and doesn’t work neither.
I’ve tested on Linux Mint, Pop OS, Ubuntu Linux and I got the same results.
I have another machine, a desktop, using Linux Mint and there works perfectly using the Steam Launcher.

Laptop specs:

  • NVIDIA Corporation TU116M [GeForce GTX 1660 Ti Mobile] / NVIDIA GeForce GTX 1660 Ti with Max-Q Design/PCIe/SSE2
  • 16 gb RAM
  • Intel® Core™ i7-9750H CPU @ 2.60GHz × 12
  • OS: Pop!_OS 21.04

Anyone has any idea how to solve that?
Thanks!

Hey there… Welcome to the forums…

I know a few people who have the game running fine on Pop!_OS with Steam or the standalone launcher… I tested it myself to the point of launching the game on Pop! - didnt play because my hardware was below spec (old HP laptop), but it launched…

So, assuming that it does actually work…

Please can you post the following files:

  1. player.log - games debug file that should hopefully contain something to indicate whats not working
  2. error.log - crash report file (if the game managed to generate one)
  3. le_graphicsmanager.ini - the game settings…
  4. system info - on linux you can do this via Steam
  5. launcher-log.txt - the standalone launcher log file (might have something before the player.log kicks in)

https://support.lastepoch.com/hc/en-us/sections/1260801697209-Useful-Files

Also… regarding the fact that you can get it working on your desktop system… can you compare what is different - that can help figure out what the possible cause could be? Things like MESA drivers etc are very important.

There are also reports of people struggling with Nvidia based GPUs because of driver issues that required lots of messing around with driver combinations etc (rolling back to older drivers, trying new ones)… in comparison, AMD GPUs seem to work out of the box.

Another issue with laptops is the issue of ensuring that LE runs ONLY on the discreet GPU (i.e. in your case the 1660Ti Maxq) - if the laptop swaps between the iGPU and the discreet GPU then LE will not run / crash. On windows this is fairly easy to enforce at the driver/windows os or even Bios level, but I am not sure how to do this on Linux… Its a pretty important thing to ensure…

if you copied the launcher folder from a backup, it has wrong perms, I fixed the suse and arch issues same way, just re-DL or change perms to your current user (chown)