My Account
× My Account Forum Buy Now

Last Epoch Forums

Linux core dump on start

Had it working perfectly under linux mint.
I installed a new disk drive and so had to re-install mint.
Tried to run my existing installation and it core dumped.
so started over with a freshly downloaded launcher, and it’s core dumping too.

linux mint 20.2 Uma, using the nvidia-470 driver.

can’t do much because there’s absolutely no clue as to what might be going on.

help !

Thanks.

Found path: /home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64
Mono path[0] = '/home/<user>/LastEpoch2/patcher/LastEpochLauncher_Data/Managed'
Mono config path = '/home/<user>/LastEpoch2/patcher/LastEpochLauncher_Data/Mono/etc'
Preloaded 'ScreenSelector.so'
Preloaded 'libgetdiskspace.so'
Preloaded 'librsync.so'
Display 0 'VP2771 27"': 2560x1440 (primary device).
Logging to /home/<user>/.config/unity3d/Eleventh Hour Games/LastEpochLauncher/Player.log
Stacktrace:


Native stacktrace:

	/home/<user>/LastEpoch2/patcher/LastEpochLauncher_Data/Mono/x86_64/libmono.so(+0x987d3) [0x7fef9e4e27d3]
	/lib/x86_64-linux-gnu/libpthread.so.0(+0x153c0) [0x7fefa48ab3c0]
	/lib/x86_64-linux-gnu/libc.so.6(gsignal+0xcb) [0x7fefa46e818b]
	/lib/x86_64-linux-gnu/libc.so.6(abort+0x12b) [0x7fefa46c7859]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xd2d116]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher_Data/Mono/x86_64/libmono.so(+0xd90cd) [0x7fef9e5230cd]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher_Data/Mono/x86_64/libmono.so(+0x3737f) [0x7fef9e48137f]
	/lib/x86_64-linux-gnu/libpthread.so.0(+0x153c0) [0x7fefa48ab3c0]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xcb1ce8]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xa097d2]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xa0c6b3]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xa0ccbf]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xa0cf30]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xe0cd29]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0x17983b5]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0x17bf5fb]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0x17bf94e]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0x17bfac8]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0x17bfc64]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0x17af938]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0x17a4cee]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xe1ca4d]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xe1cf66]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xe1dc17]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xd7a911]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xd82e2a]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xd87d1c]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xd87ea5]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xa1f1de]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0xc4f30b]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0x44daae]
	/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0x7fefa46c90b3]
	/home/<user>/LastEpoch2/patcher/LastEpochLauncher.x86_64() [0x45a5e1]

Debug info from gdb:

I refuse to debug myself!
No threads.

=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Aborted (core dumped)

and … it’s fixed.
this is a total WTF moment ?!
i would like to preface by saying i did NOT, repeat: did NOT, reboot.

i have steam running on linux. however i had one game under steam that didn’t want to work (Torchlight 2 if you must know, lol).

I had some steam cruft leftover from the fact that i copied over my home directory, so i went through and found every steam related folder, which was only a couple of them, and deleted them. there was also a .steampid file and another hidden file lying around that i deleted too.

then i re-installed steam.
downloaded T2 again (i deleted the steam game directory)
T2 now runs. i thought “cool”.

then, just for giggles, i tried LE again.
wtf ?! the new launcher i downloaded starts working.

so i cancel it and move to my previous directory, and try that version again.

AND IT WORKS.

The only thing i can think of is that the steam installation from scratch maybe pulls in some dependent libraries (it’s a debian package, so that might happen) ?? But those libraries would have been there the 1st time i ran steam (since i had to re-install it for the new disk drive).

it’s very confusing.

I’m very happy, but this seems really weird…

I think you are right with your guess… It could very well be that Steam on Linux re-installed some missing dependencies when you re-installed it - or even just updated a library… It could be that your messing with the “cruft” leftovers forced Steam to reinstall things it had assumed where already working/in place but were not in the correct place/outdated versions… and the side effect of this was fixing the launcher too?

No idea really… i dont tend to mess under the hood with Linux - at least not for desktop/gaming use…

Glad it got working again… Who knew updating Steam on Linux would help the LE launcher work… :wink:

i’ve run executables that are missing libraries and they just error out, they don’t core dump.

Also, note to future travelers

ldd

I completely forgot about that command. Wish i had remembered to try it before i re-installed steam.

~/LastEpoch$ ldd Launcher
||linux-vdso.so.1 (0x00007ffecc9f9000)|
|---|---|
||libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007ff1609d0000)|
||libfontconfig.so.1 => /lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007ff160989000)|
||libfreetype.so.6 => /lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007ff1608ca000)|
||libxcb-glx.so.0 => /lib/x86_64-linux-gnu/libxcb-glx.so.0 (0x00007ff1608ad000)|
||libX11-xcb.so.1 => /lib/x86_64-linux-gnu/libX11-xcb.so.1 (0x00007ff1608a8000)|
||libX11.so.6 => /lib/x86_64-linux-gnu/libX11.so.6 (0x00007ff16076b000)|
||libXi.so.6 => /lib/x86_64-linux-gnu/libXi.so.6 (0x00007ff160757000)|
||libXrender.so.1 => /lib/x86_64-linux-gnu/libXrender.so.1 (0x00007ff16054d000)|
||libxcb.so.1 => /lib/x86_64-linux-gnu/libxcb.so.1 (0x00007ff160523000)|
||libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007ff16051d000)|
||libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007ff1603f4000)|
||libGL.so.1 => /lib/x86_64-linux-gnu/libGL.so.1 (0x00007ff16036c000)|
||libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007ff160347000)|
||libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007ff160165000)|
||libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007ff160016000)|
||libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007ff15fffb000)|
||libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007ff15fe09000)|
||/lib64/ld-linux-x86-64.so.2 (0x00007ff160a06000)|
||libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007ff15fddb000)|
||libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007ff15fdd0000)|
||libpng16.so.16 => /lib/x86_64-linux-gnu/libpng16.so.16 (0x00007ff15fd98000)|
||libXext.so.6 => /lib/x86_64-linux-gnu/libXext.so.6 (0x00007ff15fd83000)|
||libXau.so.6 => /lib/x86_64-linux-gnu/libXau.so.6 (0x00007ff15fd7d000)|
||libXdmcp.so.6 => /lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007ff15fd75000)|
||libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007ff15fd00000)|
||libGLdispatch.so.0 => /lib/x86_64-linux-gnu/libGLdispatch.so.0 (0x00007ff15fc48000)|
||libGLX.so.0 => /lib/x86_64-linux-gnu/libGLX.so.0 (0x00007ff15fc14000)|
||libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007ff15fbfa000)|