Last Epoch on macOS

Hi everyone,

I have two questions, please :

  1. Did anyone try Last Epoch on Mac with Game Porting Toolkit and if yes, does it run well ?
  2. Since Apple finally seems to support gaming with their Game Porting Toolkit + their new Metal 3 API, is there any chance EHG brings the game back on Mac ?

Thank you !

1 Like

Hey there.

Probably too early for anyone to have tried this but from what i gather, the Game Porting Toolkit is unlikely to run well from a performance perspective - if you can even get LE running. You could probably check for any games using the Unity game engine (esp. 2019LTS) and if there are some working with the Game Porting Toolkit, its possible LE may work.

Re native Mac support - LE is currently developed on the 2019LTS version of Unity & as I understand it, EHG would need to upgrade to the latest (or just newer) Unity version to allow for native export of the game to work on M Silicon. Mike & co have confirmed numerous times that while this could be something they do in the future, its a very large undertaking - I think Mike mentioned that it would take a year to upgrade Unity versions (at that stage of the development about a 18months ago) - time they simply dont have right now. People have asked for this wrt, using native Mac as well as supporting things like DLSS/FSR and other newer unity features.

4 Likes

Thank you for this very complete and precise answer.
Hope for some good news about playing on Mac in the future so ^^

1 Like

I’d like that as well, but I’m not sure it bodes well. Even Blizzard killed Mac support for D4. One of the reasons why I decided against playing it. All previous versions I played on my Mac. I bought LE when it still was Mac playable and was certainly disappointed when they discontinued that but fully understood it. Going forward though, I no longer will purchase games that are Windows only especially now that BootCamp will eventually die off.

And so as not to turn this into a PC v. Mac debate. This is a choice. I don’t care what anyone else’s reasons are for going Mac or PC. Would it be great if EHG could support Mac? Absolutely. Do I understand why they aren’t currently? Absolutely.

3 Likes

Blizzard started D4 a long time ago so i understand why they didn’t develop on Mac but with Apple last announces about gaming, i really hope to see more games to come !

But for little studios like EHG i understand it’s too much work at the moment to make a Mac version.

For Blizzard it should be the minimum from now. But when you see their last D4 patch…we are from getting anything lol…

Well, I can imagine that Blizz are lacking in resources due to being such a small indie developer it’s fair enough that they concentrate on the larger market…

1 Like

For those that are interested, I was able to get Last Epoch working with the Game Porting Toolkit along with the release-version of Sonoma. For reference, this is working for me on my M1 Max, MacBook Pro, with 32 GB of RAM, as of October 2023 - YMMV.

  1. To start, install a Windows instance of Steam. I used this guide and it worked well for me: GitHub - domschl/WinSteamOnMac: Run the Windows version of Steam on macOS Sonoma with Apple's Game porting toolkit Beta. I did have to try starting Steam up a couple of times to get it to load properly (be sure to kill any wine-related processes that don’t end after a few minutes when trying to restart Steam). After getting Steam to load correctly I haven’t had an issue.
  2. Install Last Epoch like you normally would through Steam
  3. Start Last Epoch from Steam. This may take a few minutes but should load eventually. The first time I started it up the LE window was grey and appeared to be hung so I force quit all Wine and Wineserver related items in Activity Monitor.
  4. Once I restarted Steam and LE, it started up fine and I was able to play without issue.

While I’m new to Last Epoch (moved over after getting bored with D4), I have a played a few hours without noticing any issues in terms of graphics, gameplay, sound, etc. I also have a Windows laptop and switched to it for a bit and didn’t notice any difference.

That said, the emulation is not perfect: after playing for a while on my Mac and closing the game, I came back to start the game but Unity kept crashing before the game could fully load. This was odd given that it had been running for a while without issue and I assumed that something to do with the graphics settings was causing an issue. To fix this crash I had to delete the boot.config file at <WINE_HOME>/drive_c/Program Files (x86)/Steam/steamapps/common/Last Epoch/Last Epoch_Data/boot.config and le_graphicsmanager.ini file at <WINE_HOME>/drive_c/users/crossover/AppData/LocalLow/Eleventh Hour Games/Last Epoch/le_graphicsmanager.ini. I haven’t put a ton of time into figuring what is causing the issue but my guess is that I switched the Graphics from Medium to Very High which resulted in something that is not supported in the DirectX translation. Removing these files effectively reset the graphics to the default mode and allows the game to start and run normally.

I am really happy to get this working on my MacBook Pro as switching between machines is annoying (definitely a first-world problem). It’s kind of absurd that this works as well as it does given the emulation of DirectX, Windows, and CPU architecture; the same approach works for D4 which has much more demanding requirements and really highlights what a beast the M-series is!

3 Likes

Dude, this is pretty friggin’ cool. I’m not really a power user anymore but if this is possible, it would make my day. I currently don’t have the budget to get a new mac yet, I tend to use mine a lonnnngggg time before I upgrade (which is one of the great mac benefits) but if this is indeed possible and the ‘replacement’ for bootcamp in the future, that’s awesome, especially if it runs so well.

Thanks for spotlighting this. Bookmarking this post.

Yep I’m using Crossover 23.6. Standard Steam install followed by LE. I run it in high DPI mode using D3DMetal (GPTK) at a resolution of around 1200P and seems fine, bit of what I think is compilation stutter but that smoothed out fairly quick.

Haven’t done much benchmarking, was getting 70 odd fps with high settings at the lower stock low dpi resolution of around 980P I think it is but find that a bit soft so sacrificed some fps. Haven’t played long enough to see much density on the screen so will do more work on the sweet spot once I have a better profile to work with.

14" M1 Max.

1 Like

Is that a common Mac term? 'Cause its giving me a mental image of you printing the screen out & playing LE as a flickbook instead of on a monitor.

No more uncommon than for Windows. Never heard of High DPI scaling on Windows?

Its referencing ‘Retina’ DPI levels on displays, eg Macbook Pro/5k 27" monitors/Surface Laptops etc. So you end up having to scale UI elements otherwise they would be tiny.

I guess you are on a 1440p or lower monitor? Kicks in around 4k on a 27" screen, my 14" screen is at around 1964p for reference. (254 DPI or pixels per inch if you prefer)

1 Like

Nope, only ever seen DPI used with respect to printing. Though I do remember Apple making a bit of a fuss about the retina display when they launched it.

I am on a 1440 monitor, though given I now have a 4080 graphics card, if I could afford a 4k monitor I’d get one (divorce, unlikely to happen any time soon).

Really cool to hear this is actually a doable thing. I’m not yet ready for a new mac (I tend to wear mine into the ground because one of the perks of them being more expensive is in the long run they also last a lot longer), but this at least bodes well for me to be able to keep playing LE when that time comes.

Oh dude. I know this can be a mixed thing depending on the situation so whichever this is (good or bad) I hope it goes as smooth as possible.

1 Like

Currently having this exact issue - but this fix is not working for me. Any other ideas?

I came back to start the game but Unity kept crashing before the game could fully load. This was odd given that it had been running for a while without issue and I assumed that something to do with the graphics settings was causing an issue. To fix this crash I had to delete the boot.config file at <WINE_HOME>/drive_c/Program Files (x86)/Steam/steamapps/common/Last Epoch/Last Epoch_Data/boot.config and le_graphicsmanager.ini file at <WINE_HOME>/drive_c/users/crossover/AppData/LocalLow/Eleventh Hour Games/Last Epoch/le_graphicsmanager.ini .

This issue ^^

Hi everyone, just installed and played successfully LE on Mac ( M2 max ) using Crossover 2 3.7 ! Here are the steps:

  • create a Steam bottle
  • install LE with Steam
  • best performance/ no glitches or bug, use D3D Metal combined with Esync
  • enjoy :grinning:
    I’m playing smoothly with ultra quality settings, 2540x1440 and really happy, can’t wait for the new update and official release !
    Cheers,

Thanks to Akmad’s suggestion about dumping those files, I’ve had good luck getting the game to load. One thing I"m still having some issues with is after several zone’s loading screens, it’ll freeze up on changing zones and I’ll have to restart. Has anyone else ran into that? I don’t know if it persists into monoliths or not as I’m just picking back up the game.

Running currently though a Whiskey setup bottle for Steam. I am not sure if I’m using D3D Metal or how to check specifically. But happy to try much of anything.

Hi,

Another Mac user here. Successfully running Last Epoch using WhiskeyApp on Sonoma. Running smoothly with Ultra gfx mode as well. Using 14" M1 Max. Only issue I am having currently that I am yet to figure out is that trying to create a loot filter makes the game hang. Pasting in a filter into the directory and trying to select it causes the game to crash as well. Other than that game has been smooth sailing so far! :slight_smile:

I am using Whiskey as well and I haven’t had any issues with the landing zone screens. Whiskey by default uses msync. You can change it to esync and try by clicking the Bottle Configuration button for your bottle in Whiskey. I had it set to msync and didn’t have any issues. Tried changing to esync to see if it fixes my issues with the filter button but no change haha.

Quick update if anyone else faces the loot filter issue. I solved it! Looks like for some reason its the clipboard thats causing the issue. So if you have something copied in your MacOS clipboard (text, files, etc), the game hangs when opening the filters. So all you need to do is either restart your computer or just clear it via a terminal command. I am not sure if it’s ok to paste terminal commands here or post links to sites on how to do it, but a google search for “clear macos clipboard” will give you the command on how to do it without having to restart. Very happy loot filters are working now :slight_smile: