Keyboard response delay

I’m having the issue of keyboard response in Last Epoch, it’s occurred around twice each day, and it happened suddenly while playing and the keyboard will have huge laggy and seems like no response, however the button will be clicked around 10 to 20 secs later, and each time I will be required to restart PC to resume normal.
I had tried to use two different Logitech keyboard and one more “no brand” keyboard, and the same happening, it’s extremely annoying and I have no any keyboard issue in other games, just Last Epoch.
I had confirmed that no controller assigned.
Also I tried to re-install the game client via Steam, however the issue still occurred.
I can’t find any similar case and help in FAQ / Forum… And have no idea how to proceed to troubleshooting.
Player.log (398.1 KB)
Player-prev.log (297.6 KB)

Having the same issue. After playing the game, when it starts lagging in monoliths, you enter it, your spells don’t cast, then the game catches up, keys stop registering on the first push. Even after closin the game and steam, in windows, the same thing happens, with browser tabs, windows… everythig, like everything is lagging. The fix is to restart the pc for me.

1 Like


Apparently the issue was solved for me by unchecking the “Allow windows to turn off device to save power” , in device manager, HID, usb input device/ properties/ power management.

Don’t know what in last epoch triggers laptop to start putting the keyboard to sleep, as this hasn’t happened before with any game or app. Hope this helps.

I had a similar issue. A lot of delay (around 5 seconds) for each key press and duplicated key randomly…
I tryed Liviulica fix and it didn’t help.
What solved it for me was to shut down TeamViewer (the whole process).

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.