My Account
× My Account Forum Buy Now

Last Epoch Forums

Just Bought the game on Steam and can't enter LE-24

I bought the game on steam, I created an account and it stills say that I don’t have a licence… LE-24 code error

I cant get in either, bought game in steamn

Same issue here. I get LE-24 and I can’t find clear directions on how to link my Steam account to my account on the website…

Can we get some help pls

Same problem! Just bought the game on steam, same error,

Same issue here. Just bought through steam and getting LE-24 error.

Same issue.

I validated the files on steam and this fixed this.

Hello there,

Can you submit a ticket to support.lastepoch.com ? We will then work with you to resolve this. I will go ahead and attempt to resolve in the mean time. Even if it is fixed though, it would be nice to get your logs so that we can identify the root cause.

thank you,

-Alux

Same problem today files validation did not help submited a ticket

i cant get in either same error code and all i bought the game from nexus, it says to try linking steam but i cant find a way to even try and do so

Hello there! Everything looks solid to me now. Are you still experiencing issues?

Hey there Silancia, do you mind submitting a ticket to support.lastepoch.com? We will need to take a look into your account.

-Alux

propblem resolved thankyou very much

Working properly now

Same problem. Files validation did not help. Submited a ticket yesterday and wait

I have the same issue. Just opened a ticket through your website

propblem resolved, tnx

I don’t have LE-24. I just get stuck on the entering Ettera screen. When I go to account management on the last epoch website it says I need to buy it, even though I bought it on steam.

Also just opened a ticket. Posting for a bit of visibility for anyone else looking for issues and help.

EDIT: They reached out and reinstated it on their end for me. Thank you!

Bumping this thread. Purchased through Steam, created an account when launching LE, verified the account on the website. site still says I don’t own the game, and can’t get passed the ‘Entering Eterra’ screen, just a spinning portal. My 2 hour Steam refund window is almost up, so may need to refund.