My Account
× My Account Forum Buy Now

Last Epoch Forums

[ISSUE] 'Fatal Error in GC' error (0.7.7b)

Experiencing this occur playing lightning-focused sorcerer. Modal crash window reads:

“Fatal error in GC. Unexpected mark stack overflow.”

Skills being used are: Teleport, Static Orb, Lightning Blast and Fire Shield

EDIT Including game log: Player.log (1.6 MB)

1 Like

Sorry about this! Can you please post the crash report from C:/Users/edit/AppData/Local/Temp/Eleventh Hour Games/Last Epoch/Crashes as indicated by the log file? You will likely need to add them to a .zip for it to upload. Your system information would help as well.

Sure thing:
Crash_2020-03-29_181933237.zip (2.1 MB)
DxDiag.txt (99.9 KB)
le_graphicsmanager.ini (517 Bytes)

1 Like

Same issue just happened.
Player Log and Player-prev Log.zip (59.5 KB)
Crash Report Google Drive Link
le_graphicsmanager.ini (494 Bytes)
DxDiag.zip (14.7 KB)
Crash happened when attempting to transfer to Shining Cove from Harton’s Dreadnought via the story quest marker.

1 Like

Same for me. Happened several times during arena- and monolith runs.
le_graphicsmanager.ini (487 Bytes)
DxDiag.txt (98.4 KB)
Can’t upload the crash reports because even when zipped they are >5mb

You can post a link to a file sharing site if you like.

Thanks for the reports everyone! (And if other people are having this issue I’d still like you to upload the relevant files)

Allright, here is the link to mediafire
I have included 3 crash folders.

Crash_2020-03-31_143910899.zip (1.6 MB) le_graphicsmanager.ini (496 Bytes)

1 Like

Same for me. Lightning based sorcerer. This is the second time it’s happened to me. Both times it was when I was going from one zone to another. Not using the teleporter pad, but rather the “door” zone marker to go from one to another. Sorry, not sure what each one is technically called.

Update: since this post, it’s happened 2 more times. These times, it was when I was casting Lightning Blast on mobs. Like another poster said, it was never an issue until one of the last couple patches.

Here’s my files. Also included my DxDiag in the folder

And another one on my sorcerer after no crashes on Necro and Void Knight for several hours.
Crash_2020-04-01_212848421.zip (2.6 MB)

Hey everyone. Very sorry that we haven’t been able to provide results to any of you yet. We haven’t been able to experience this crash internally, which makes it difficult to debug.

I would really appreciate it if anyone who’s having this issue would post screenshots of each of their skill trees. There may be a particular node or combination of nodes that is making this crash happen, so I’d like to recreate the builds everyone is using.

Thanks again!

Hackaloken,
Here’s a zip of my Skill and Passive Trees on my mage. If you need any more information let me/us know.

Here’s screenshots of my skills and passives. Just in case you need the skill tree, too.

Update: Since uploading my screenshots, the game just had the Fatal Error while I was entering the monolith zone. The crash only seems to only happen when switching zones or casting on enemies.

Update 2: This was a first… after completing a monolith run, I was half way through picking up the loot and got the fatal error.

I am having the same problem as the rest of the people here, though when I crash it’s frequently in the monolith and I can’t get through more than 3 timelines before the crash and because i’m in a timeline when it crashes it resets my timelines back to the start and I can’t get to the 5th and get an arena key no matter how many times I try.

Crash_2020-04-02_155151252.zip (1.9 MB) le_graphicsmanager.ini (498 Bytes) skills.zip (2.4 MB)

Experimented with checking both boxes, limiting my FPS, with no help. Still crashing. I have noticed it takes any where from 45min to 90min of straight game play before it crashes. On average though, it’s usually around the 1 hour mark when it gives the error.

Edit 1 - Additional idea: When I get home from work, I’ll see if going from full screen to a windowed mode helps or gives the same error.

Edit 2 - Update: Well, it crashed while casting Lightning Blast, even in maximized window mode.

2 Likes

I have the same error, also with a Lightning spellcaster. A bit digging into the error logs posted above, it seems there are thousands of threads created that all call the Unity plugin by Digital Ruby, generating the lightning bolt effects.

Relevant line from the ‘error.log’ file:

0x000002510122ECDC (Assembly-CSharp) DigitalRuby.ThunderAndLightning.LightningThreadState.BackgroundThreadMethod()

1 Like

hmmmm interesting find! Hopefully this helps them.

Keen eye :wink: We’re already looking at specifically that leak internally, but there’s also more than one issue occurring; the complexity is in breaking them apart to deal with them individually.

sreens passive/skills.
Screenshots_Skills_Mage.zip (3,8 MB)
DxDiag.zip (16,5 KB)