My Account
× My Account Forum Buy Now

Last Epoch Forums

Is the game down?Fixed

Bought a 50$ supporter pack today trying to log into the game cant even get past login it either says incorrect or does a infinite loading circle I know I put the right password in just made the account it has been about an hour or 2 since this issue and still having it even tried to make a new password as i’m logged into the website but the save changes is greyed out after I fill out new password?

I don’t think it helped removed and reinstalled but what did help was clicking forgot password and using a numerical only password

Hey there,

Apologies for the technical problem, and glad to hear that you got it resolved!

Hope you don’t mind me setting this post as the “solution” - the forum doesn’t actually support the first post of a thread being marked as a solution to itself.

What do you mean by a numerical only password?I have the same issue and want to give it a try 'cause every troubleshooting guide I’ved done does’nt worked.

A post was merged into an existing topic: Unable to log-in

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.