My Account
× My Account Forum Buy Now

Last Epoch Forums


Hi all! I downloaded the game today and when I opened the ‘‘’’ I could see 2 lines/files. One of them were the actual Launcher installer sp I pressed that one/unzipped it. Small window, downloading 77000+Kb. Then the launcher appeared. Started downloading the game (3.8Gb) Played another game while waiting. Went out from that game when the download was complete. — I could now press Play and choose graphics/resolution. The game started and I think I played for 2 hours straight. It’s now 5 in the morning and I wanted to sleep. Quit the game. —Now I noticed that there were no Icon on the Desktop. And I started searching for the files/the game on my computer - But I cannot find it. Tried to install it/unzip it again but now I get an error, to little diskspace. Uuuum ok what disk?! Searched for LastEpoch / Last Epoch / Eleventh Hours Games / AlphaLauncher - But no I cant find it. And the only harddrive that has ‘‘little’’ space is my main harddrive (SSD) which have the OS installed. And I tried around to drag the Zip-files to another bigger harddrive but it just says error.

Can someone help me please? I want to play it again and I want to install it on a bigger hardrive, even have a shortcut on my desktop!

Hi there,

I’m very sorry to hear about this!

Here’s some advice which will hopefully prevent a repeat;

  • You shouldn’t need to choose one of two files - we would recommend choosing to extract files from the .zip folder directly. If you have Windows 10, it should offer you this option if you right-click on the .zip folder. Programs such as 7-Zip will also be able to do this. We would not recommend choosing to perform a partial extraction.
  • We have seen some reports that permissions issues can cause the game files to be placed in a temporary directory, which we’re investigating. For the moment we would recommend right-clicking on the Launcher and selecting Run as Administrator.
  • While the installation doesn’t currently create a shortcut on the desktop, after the game is installed you should be right-click on the launcher and choose to create one, before moving that to the desktop. We would advise that any shortcuts which are created be to the Launcher to ensure that any available updates will be downloaded.

We’re aware that this is very rough, and in the future we’ll be making a lot of improvements to the installation experience. Our current focus is on creating more content for the game, but during beta we’ll be addressing as many of these issues as we can.

Sorry again!

Hi! Thank you for reply!

When I say 1 of 2 files, I mean 1 .exe and 1 .dat. I will try some more now that I slept.

How would you try to uninstall it? Im afraid it installed itself more than once or doubled it files somehow, because when I played the game my //C Harddrive had 10Gb+ left. When I couldn’t find the game after quitting it and I opened the .zip file once more only to be told I had to little diskspace I checked the free space, It was only 8.73Gb left now and ‘‘Red’’/ warning soon to be full. I DONT want my main/ OS hardrive to be that full. So help me uninstall it please. What will be the files names? I want search it all up and choose uninstall, and then install your awesome game on the hardrive which have 100Gb+ :open_mouth:

I have windows 8.1. Used winrar to open the .zip file

EDIT: I know found some files. Under OS© - Users - Kevin (my name) - AppData - Local - Temp. Searched for 2018 - 12 - 20 so I could see all files altered/added. They are all called Rar$EXa0.(followed by 3 numbers - 943 is the file that contains last epoch launcher) But I still cannot find the uninstall.

EDIT 2: Um no almost all of them have the launcher in them, they take 287Mb per Rar$ except fpr the 673, it is 7.38Gb! So it seems I found where the whole game is.
So under OS© - Users - Kevin (my name) - AppData - Local - Temp - Rar$EXa0.673 - App I now found the game and can now play it! Should I throw away the other Rar$EXa0 files ? They have been created different timestamps so maybe when I thought I pressed the launcher I only pressed the install launcher? Throwing the other Rar$ files and see if I still can play it

EDIT 3 : It’s no longer on my C drive and my C drive now have 17Gb+ Free space! And my E drive have under 100Gb and I can play the game! So I successfully moved the game :smiley: Let’s open up a Red Bull and enjoy the game!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.