Huge FPS drop since patch 0.8.4


I have been experiencing some troubles trying to play the game sine patch 0.8.4 has been released. Before this patch my fps would stay at about 70 the whole time at the medium settings. Since this patch my fps is stuck at 5, turning the game unplayable.

Find attached some files about the system if needed:
DxDiag.txt (102.0 KB)
le_graphicsmanager.ini (519 Bytes)

Thanks in advance for the help!

1 Like

Hey thereā€¦ Welcome to the forumsā€¦

Thanks for the attached filesā€¦ you are unforunately missing the most important oneā€¦ player.log - its the games debug fileā€¦ Please can you add this to the thread.

A drop from 70fps to 5fps is most definitely not normal and is not the usual experience even for the game in its current beta and unoptimised state. You havent really provided examples/detail of when this happens or if its permanently stuck at 5fps even in the character selection window so I am going to have to assume certain things and make some generalised suggestions.

The first suggestion is to make 100% sure that your GPU drivers & up to date and installed using a clean, safe mode installation NOT a normal gpu driver upgrade as that will not always correct problem driver files or remove old files no longer needed. Use something like DDU if you dont know how to do this process manually. Also, make sure that your GPU driver settings are default and not overriding any specific things like vsync, antialisaing etcā€¦ You also need to monitor you GPU clock speeds etc to double check that its not in some sort of throttling mode due to some previous issue - check against the publised base clocks etc. If the 5fps your are experiencing is permanent no matter what you are doing, then there is a bigger issue at play here and I would suggest your test your GPU by running some benchmarks and monitoring it specifically to see if its still performing to spec.

Next is to make sure that the game files are okā€¦ on Steam a game file verification will do this.

Make sure that your OS is patched and more importantly that there are no failed updates or critical updates waiting for your approval. You are on 19043 so it should be fine, just check for failures.

Looking at the info you have provided:

The diagnostic section of the dxdiag report (end of the file) shows that LE is crashing on d3d11.dll (Direct3d) and UnityPlayer.dll (the game engine). Without seeing the player.log, to confirm, its probably a performance related issueā€¦

You system is virtually identical to mine i5-7500/1060/16gb/NVME except for having more cores on your CPU which the game doesnt use anyway. Like you, I play at 1080p, very low setting with special features disabled. However, you are not limiting the game using the framerate limitsā€¦ Which means that LE will try and max out your GPU whenever it can and when it does this, the game will become very unstable and crash or having huge fps spikesā€¦ If I do this, I can get 100fps but the game will crash all the time. You need to enable a framerate limit that keeps your GPU at between 60-65% usage while your character is standing in town doing nothingā€¦ For me that is a fps limit of between 55-60fps.

Other things:

  1. some people get different performance depending on if they use Windowed or Fullscreen modesā€¦ Try changing your to see if it makes a difference. (note you still need the framerate limit enabled).

  2. Are you running any other applications while testing LEā€¦ Temporarily dont run anything else while playing the gameā€¦ doesnt matter what it is, just dont run it to see if its is potentially part of the problemā€¦ There are many applications that cause problems with the Unity game engine (e.g. Citrix) so just dont run anytyhing elseā€¦ This will also leave more resources for the game to useā€¦ Note that this includes services.

  3. Your system has some odd errors on ucrtbase.dll with are Microsoft C++ components. Acrobat is crashing, the MsiExec.exe Microsoft installer has a few crashesā€¦ I recommend that you View Reliability History on your system and check what is going on and if there are serious issues that you need to fixā€¦ If some of these dlls etc are needed by the game engine and are potentially messed up, it could indirectly be causing performance issuesā€¦

1 Like

Sorry, I didnā€™t really specify the problem hahaha

So since the patch 0.8.4 my game is stuck between 5 and 10 fps, even in the character menu you can notice the slowdown. Idling in the city we can reach 12 fps. The gpu usage is constantly at 100%. I did a clean installation of the game and ran it without anything in the background using the graphics configurations that you suggested and the problem persisted.

I did a clean installation of the GPU drivers as you suggested and ran some benchmarks, the GPU and CPU seems fine, got similar results from past benchmarks. Try running the game again, still 5 fps.

I ran the following commands in powershell trying to find and fix any dll problem:
SFC /scannow
Repair-WindowsImage -Online -RestoreHealth
The SFC scan found some problem and fixed it, the second one didnā€™t find any. Try running the game again, still 5 fps.

Here is the latest dxdiag and player if needed:
DxDiag.txt (102.1 KB)
Player.log (21.7 KB)

I am going to look for any malware kind of problem now, checking the Reliability History didnā€™t show anything really out of the ordinary ecxept for acrobat pdf reader crashing without any reason so I will look into it.

Thanks so much for the help! :slight_smile:

Okā€¦ Those framerates should not be happening on your systemā€¦ Even the character menu for me is running at 75fpsā€¦ There is definitely something odd going onā€¦

SFCā€¦ Good idea - worrying that it found things to fix thoā€¦ i.e. something messed it up.
Clean Driver - Ok.
Install the game - Okā€¦ but make sure to run a Steam Game File verification tooā€¦ just to make sure.
Benchmarks - ok.
Player.log doesnt show anything abnormalā€¦ there is nothing that is a warning sign of anything.

Dxdiag: Found something newā€¦ There is a crash record of Last Epoch on the nvoglv64.dll - this is an OpenGL part of the Nvidia driverā€¦ The player.log is showing the normal DirectX implementation of the game loading as it should as default on Windowsā€¦ and there are none of the usual OpenGL messages that you would see if it was using OpenGL.

I have also never seen this crash error with that DLL beforeā€¦ so this is definitely something new.

Why is the game crashing on the Opengl part of the driver when its not even using OpenGL?

This could definitely explain the odd performance you are experiencingā€¦

Your game driversā€¦ are they all set to default? No configuration overrides like half vsync, AA etcā€¦ No special apps that do anything graphical etcā€¦ no third party overlay type things running at the same time?

Do you have any OpenGL specific development tools or things installed?

Having the same issue on my end. Running a Ryzen 5 3600, Radeon 5600 XT, 16GB RAM, on Very Low settings. Never had any issues before patch and was able to level to 82. But now at the monolith Iā€™m just having 28 FPS max. Do I need to clear something like cache? Should I reinstall? Thanks.

All configurations are set to default, nothing special in the way.
For troubleshooting purposes I tried:
disabling the Xbox bar from windows;
reinstalled microsoft c++ components;
ran steam verification;
disabled hardware virtualization on BIOS;

The problem persisted

There is two softwares that may be causing problems (Iā€™m not sure if I had them installed in this machine the last time the game worked properly): Virtualbox and OCAD. Unfortunately I canā€™t uninstall them right now because I still have some work to do with them, but maybe in the next few days. I hardly believe they are the problem (both are not running in the background in any way while the game is open), but maybe virtualbox install something that is having conflict with the game.

Hey thereā€¦ Welcome to the forumā€¦
Please can you create your own thread in the technical section with your logs and other informationā€¦ Thanks


Xbox bar. cant hurt to disable it - you shouldnt use any overlays with LE except for afterburner/rivatuner if you wanted to - those dont cause problems.
Microsoft C++ ok
Steam. ok
Hardware virtualisation in biosā€¦ doubt that would have done anything.

VirtualBOX shouldnt be involved unless its got some sort of passthrough GPU configuration thats active - I havent used it in ages so I cannot rememberā€¦ You dont want anything messing with your GPU in any way.

OCADā€¦ Never heard of it beforeā€¦ Dont know if it makes any GPU driver configs for better performance etc? Website doesnt say if it used OpenGL or DirectXā€¦

I mentioned Citrix before because the game grinds to single digit fps if its screen mirroring / virtual desktop component is runningā€¦ anything that loads virtual drivers also tends to mess around with gaming performanceā€¦ Similar things happen with Teamviewerā€¦

You sure there isnt anything else running/service in the background that is trying to use your GPU? Did an ex install a bitcoin miner you dont know about? :wink:

1 Like

Some new information, I was able to reach way higher fps with different characters and in different zones. The highest I could reach is 40 fps in the lower sewers, imperial era, using an acolyte. But most of the time it stays between 5 and 15 fps, the initial zones usually have the lowest fps.

I double checked everything running in the background and it seems like there isnā€™t anything running, HWmonitor shows my GPU usage between 0~3% while writting this, with nothing else open.

I got some softwares that are built in opengl in this machine but canā€™t really uninstall them right now, 5 days from now I will be able to do it and I may even do a clean installation of windows. But I really donā€™t think they may be the problem because I always had them.

I ran out of ideas of what to try out hahaha
Thanks for all the help anyway! I guess I will wait a few days

Dont really understand itā€¦ you should be getting virtually the same performance as I doā€¦

OpenGL apps themselves should really be doing anything unless there is something really odd - like some OpenGL developement SDK or something that isnt normally on an end users machine that is confusing the unity engineā€¦ Maybe the problem has got nothing to do with OpenGLā€¦ maybe the driver just crashed at an odd moment?

You could maybe try running the Last Epoch Exe manually with some Unity Player command lines to force it to use certain features etcā€¦

See Unity - Manual: Unity Standalone Player command line arguments

1 Like

I tried to launch the game with a bunch of different parameters but any of them solved. I guess I will give it some time and try solving it again later.

Thanks for all the help!

Omg i hae the exact same problem. I had zero problems before.
I even played the evening and a few hours before 0.8.4, zero problems.
Iam stuck at 2 fps sometimes which makes the game unplayable while before that i had between 30 and 50 fps depending on the map, density etc.

How do you do this?

1 Like

You can create a dxdiag log by opening the dxdiag window and clicking on save information, you can open dxdiag by writting dxdiag on a run window (windows key + R).

The graphics configuration can be found on AppData\LocalLow\Eleventh Hour Games\Last Epoch, you should post your Player.txt that is on the same path as it have some important information as well. If you need to reach appdata you can do so by typing %appdata% on a run window (Windows key + R).

Unfortunately I was not able to solve this yet :frowning:

1 Like

I was able to fix the problem, looks like it was some kind of corrupted file. The steam integrity check never found it as a problem, also uninstalling and installing it throught steam was not able to fix it.
Fix walkthrought:

  • Uninstall Last Epoch throught steam
  • Delete Last Epoch folder inside SteamLibrary\steamapps\common
  • ATTENTION Backup the files inside the Last Epoch folder inside AppData\LocalLow\Eleventh Hour Games; Then delete everything except for the Saves and Filters folders.
  • Download the game again throught steam

This fixed the problem and even made the performance a bit better than before the problem.


iam going to try this tommorow!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.