My Account
× My Account Forum Buy Now

Last Epoch Forums

High CPU and GPU usage - Lowest settings possible

  I bought the game yesterday, unfortunately when I try to play the game on my laptop my temps go through the roof even at the login screen. Generally, all modern games stay in very good limits when capping fps to 30-60. Last Epoch though no matter what I do CPU is 80+ and GPU is 70+

Steps I have taken:
-Lowest possible setting (15 fps, v-sync off, low everything, everything off)
-re-installed game
-wiped computer - fresh windows install

DxDiag.txt (113.1 KB)
le_graphicsmanager.ini (452 Bytes)

Hey there, welcome to the forum…

Without the player.log debug file (in the same folder as the le_graphicsmanager.ini) I cannot be sure, but without any further info, I would guess that the game is trying to run on the iGPU in your CPU and not the 3070 Mobile GPU… If it were using the 3070 gpu, there is no chance a framerate limit of 15fps would be causing any issues. But if its trying to run on the iGPU, its very possible it will have problems.

Looking at your Dxdiag its saying your iGPU is enabled on the internal monitor but the 3070 doesnt have associated monitor details so this seems to hint that my guess may be correct.

This happens OFTEN on laptops depending on their default configuration, performance configuration (i.e. is it set on max performance) and sometimes even laptop vendor applications.

If this IS what is happening, then there are two places you can force the game to run on the 3070 - one at Windows level (Advanced Graphical Settings) and the other at the Driver level - tell the driver that the LE executable file must run on the 3070 GPU.

And obviously make 100% sure its running on max performance before launching the game.

If forcing the game to run on the specific GPU doesnt work, then please include your player.log

1 Like

Figured it out,

after adding Last Epoch to nVidia’s control panel I noticed it was defaulting to my integrated AMD GPU. I switch to high-end nVidia GPU and capped fps to 60 in the control panel.
Game runs great now, albeit a little high in ultra settings, but on medium my temps barely go above idle.

Yip… thought so…

1 Like

Thank you for your time!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.