Game loads, but login screen is blank (Steam Deck)

I just HAD to go and ruin it…

So, I had a bit of a hard time getting the game up and running in the first place moving between the native Linux version and the Windows version with Proton compatibility. Every loading screen would crash with both, but performance was horrendous with Windows. Finally get it running with Linux native, all is good. Decent performance, no more crashes, was able to create a character and level till almost 20 offline… then, I had to go and mess it up.

I know most games, especially ones that might be demanding of the Steam Deck, only run well enough in Gaming mode and either run horribly (or not at all) in Desktop mode. I wanted to see, so I tried playing in Desktop mode. Game seemingly ran fine at first on the Deck’s screen, but moving it to the TV it’s docked to basically had it take up the full screen, but only display in a small corner (basically the native 1280x800 of the Deck). So, I closed the game and went back to Gaming mode…

… However, now every time I try and load the game, I get nowhere. The game will start to load, the screen will flash blue, green or purple, and then stay at a black screen. The login music plays fine, my cursor changes to the game’s cursor and reacts to me moving, the Deck’s performance stats all update as normal… but the entire screen is just black. Since nothing is loaded, I can’t click on anything. I’ve tried clicking where the Play Online or Play Offline buttons would be, but nothing.

I verified the integrity of the game files through Steam: Nothing.
I tried to play the game through Gaming and Desktop mode again: Nothing.
I tried uninstalling the game and installing it from scratch again: Nothing.

I’m at my wits end here… and after having so many issues getting the game to run in the first place on the Steam Deck, and it was working perfectly fine before tonight.


Player-prev.log (58.2 KB)
Player.log (58.2 KB)

So, just in case this happens for someone else, I did a bunch of things and eventually got it fixed. I verified game files, un-installed and re-installed, etc… The two last things I did, which I honestly can’t remember which one “fixed” it, is I moved the game from the internal drive to the SD card, and then forced compatibility with Steam Linux Runtime 1.0.

After that, the game was working fine and I was able to remove the compatibility to let it go back to Steam Linux Runtime 2.0. I haven’t tried moving it back to the internal SSD… since I don’t want to brick it another time, lol.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.