My Account
× My Account Forum Buy Now

Last Epoch Forums

Game is freezing my PC

Hello,

I have played Last Epoch and never had problems. Since I have started playing a couple of days ago again, Last Epoch is freezing my whole PC - have to reboot the computer. Happened luckily every single time when I was out of combat (playing HC). Happens regularly right now and can’t play the game like this.
Have tried different things to solve the problem:

  • verified the game files in the steam library
  • changed display mode
  • lowered game settings (but shouldn’t be the problem anyway - have played the game before on highest settings without any issues)

My specs:

AMD Ryzen 7 2700X
NVIDIA GeForce GTX 1070
Asus Prime X470-Pro
16 GB Memory DDR4 SDRAM
Microsoft Windows 10 Professional (x64)

Log files:

Player.log (34.2 KB)
Player-prev.log (37.1 KB)

Hey… Welcome to the forums…

Sorry you are having hassles…

Please can you include your dxdiags and in-game settings ini file… This will provide more sepcifics on your system/ drivers and what settings you are using in-game exactly.

Verifying the game files is the first thing to try as corrupted or missing game files are usually the cause of crashing so its important to do that.

Not sure what exactly you mean by changing display mode or lowering the game settings - the game has definite stability issues depending on in-game settings - e.g. playing the game with all settings on Ultra with no framerate limit is almost guaranteed to cause a crash esp. at high resolutions - newer, faster hardware simply delays the inevitable but it will eventually crash or freeze up.

These issues are all a factor of the current beta state of LE and the fact that the devs have not dediated themselves to dealing with performance issues right now.

The way to test for the graphic related stability is to temporarily set your system to 1080p, 60fps framerate limited (not vsync) and ALL in game settings to very low or disabled… If the crashes are still happening at these exact settings then its unlikely to be graphic setting related instability.

Which brings me to the next question… are you monitoring your system while playing… i.e. GPU usage & temps especially? For example, if you are not using framerate limiting, beta LE can push a GPU to 100% usage pretty easily - just opening inventory in town can get close… Obviously maxing out a GPU like this for any length of time is not ideal for thermal and stability issues and it can cause flaky things to happen when the fps spikes… It is important to monitor all components (CPU, Memory, Thermals etc) as something can provide a hint at where a potential problem could be. What is yours doing when you play?

I cannot also tell without the dxdiag, but is your OS Patched and are you using a recent graphics card driver - I say recent because the absolute newest is not always the most stable…

At the end of the dxdiag you will also see windows diagnostic info outlining all the errors that have happened recently on your system… You need to check that to see if it give any indication of what may be happening on your system and or what LE is doing… Serious errors in this section will need attention.

Are you running anything else when you are playing LE? Disable all overlays (Steam/nvidia) and temporarily disable or do not run any other applications while testing… doesnt matter if you think the app is irrelevant - temporarily not use it… There are plenty of obscure things like Citrix and Teamviewer that mess with LE so its best to just leave everything off for testing.

1 Like

Thanks for writing this reply and taking this much time.

I have recognized after your reply, that my GPU is at 100% usage. Have limited FPS to 60 and now I’m at about 60-70 % usage. That should fix the problem - I guess.

Still strange that I had absolute no problems a couple of weeks before, when I was playing on highest settings with unlimited FPS. Was running Twitch Streams and other software beside of the game and never had an issue.

But seems like it’s fixed for now.

Thank you!

Hey… Glad that has worked for you… Pretty confident that its probably the cause but I’d give it some time to be sure tho…

Unlimited FPS has been an issue since forever… Some people are lucky and their hardware seems to take it in its stride and others have such frequent crashes they want to get a refund. I figure its a combination of peoples hardware, the persons understanding of how to maintain it and the fact that LE is a bit of a dog when it comes to performance right now…

I wouldnt feel that bad if I were you… There are players with 3080s and Ryzen 5900s that have to dial back settings for stability right now… Granted they are trying to play at 4k etc but even they have to make concessions…

The latest 0.8.2 patch that changed all the UI components has introduced some performance issues - in my opinion at least… Things like opening the stash while in the End of Time will push my 60fps limited GPU from about 65-70% usage to 100% immediately… Previous to the patch it didnt do this. On the plus side, general play framerates and usage seems improved but EHG obviously have some work to do yet…

1 Like