My Account
× My Account Forum Buy Now

Last Epoch Forums

Game freeze/crash on login

Hello, this week I’ve started having a problem where the game won’t make it to login/character selection. It freezes at the “switch user” login screen when launched through Steam, and launching the exe directly from windows works until I enter my login info, at which point it freezes.
It was working fine when I was playing Monday evening, and as far as I know the only thing that changed on my setup was my steam display ID (subsequent changes/variations/return to what it was Monday didn’t fix the crash). Steam verifies all files as valid.
Player.log (10.7 KB)
I haven’t yet tried the full uninstall/reinstall, just wondering if there are any other known/suggested fixes for this issue before I redownload (thanks datacaps).

Hey… Welcome to the forums…

Not sure exactly how the game links from Steam but it could be that changing your display id has messed up the Steam account linking… Unfortunately only EHG can help with those kinds of issues so you may have to submit a support request .

Before you do that however, you could try logging into https://lastepoch.com/player/account/overview and checking the Link to Steam button (while you have the steam client open)… This may “fix” the problem… cant be sure.

Also… the player.log file seems to show that you are successfully logging in (but considering your problem it could just be an old player.log from Monday evening - you need to verify that this is a file updated since then).

There is also the alternative EHG game launcher that works without Steam - available from the same account page linked above… you could try that.

Independently of the login possible issues… Freezes can also be caused by corrupted game files (verification through steam should be run more than once to make sure) and things like gpu drivers, high in-game settings or even windows updates etc… Did you update anything between Monday evening and now?

I am having a similar issue, getting stuck at the same point since yesterday (July 2). I played fine the night before. Of note the ‘controller detected’ popup displays and never goes away. Since it started yesterday i have updated my graphics drivers, and was able to get in last night (once) by hitting the Escape key. That “fix” or coincidence has not worked today. Player log says i logged in successfully but i never get the start button, only ‘Switch User’.
Player.log (10.7 KB)

Hey…

Any chance you can unplug the controller physically, reboot your system and then try and launch the game with jus the keyboard and mouse.

I will try unplugging the controller next - what i found on the latest try was that it is just a VERY long delay. I walked away for a bit and it eventually displayed the expected button and i was able to login. If I click the screen before it is ready, i get the ‘…has stopped responding’ dialog.

I had the same issue.
When I launch the game from Steam client, it sticks after I enter my credentials. The game does not freeze, animations are running, portal is rotating, but it never proceeds to the character selection.
I did not do any software or hardware changes recently, and I performed files check.
But when I launched the .exe directly, it logged in successfully.

I have had similar stopped responding messages (although not recently) - if you chose wait then the game seems to recover and login - at least for me.

The reason I suggested the controller test is that there were lots of controller problems when 0.8.2 dropped that the devs fixed in subsequent minor updates.

This has happened before when Steam was having a problem with cached credentials and the devs suggested the temporary fix on Discord of running the exe directly… hope this is not happening again now.

Yeah I guess it just suddenly started requiring like 5 minutes to load instead of being nearly instant. I was able to get to a character select screen by waiting long enough tonight.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.