My Account
× My Account Forum Buy Now

Last Epoch Forums

Game crashing a lot on latest patch

I last played the patch at the end of November and it was stable. Now I can hardly get through 2 monoliths and it either crashes to desktop or just freezes. RAM free at any moment is at least 50% since I have total 32G. I have done the steam verify. Crashes usually happen trying to start a new monolith. DxDiag.txt (90.6 KB) Crash_2020-12-31_163443142.zip (50.3 KB)

I just got the game during the Rogue release, and I’m having a very similar experience to what you described. Without fail, the game will lock my entire computer up and require a forced restart during each play session. Wanted to throw in my two cents so I can follow your thread for a fix.

1 Like

Hi,

Yes I am the same. It doesn’t happen a LOT, pretty random, but always as I have just spawned into a monolith echo. It isn’t too much grief for me to restart the game, it just gets annoying when I get the message saying “your progress has been put back 3 echoes”, and I’m thinking, well yeah, thanks for that, wasn’t my fault!!!

1 Like

This is my issue too. I would not have worried about restarting otherwise. Been stuck at the same monolith level for a week now because of this.

I do not know about the last patch, I downloaded the game 2 days ago. It usually freezes on character creation or on character selection. If I switch to a different app and switch back to the game it unfreezes for 2-3 sec and freezes again. In rare cases when I can load the map, the game crashes when I try to enter a new map. I tried the steam app and client from this site, everything is the same.
win10+intel i5+RX580 (driver ver. 19.12.2)

Solved: the issue is with windows swap file. it was disabled on HDD and placed in RAM. I created a 4G swap file on SSD HDD and all freezes and crashes disappeared.

How much RAM is on your system? Afaik I do not need a swap file because I have 32G RAM and at the moment I do not exceed 50% usage.

Same issues with and without swap. Support guys any ideas?

I can complete 3 echoes, but when entering the 4th my game freezes and goes unresponsive forcing a restart. Then I lose 4 levels and have been constantly losing progress in my echo.

I just tested up to level 100 with arena - no issues. This only happens with echoes as everyone has said. Recently it has been freezing more than crashing on start of echo.

As others have said, this problem still remains and is causing some amount of frustration now, once again I have lost more progress due to the game just freezing the moment I enter an Echo.
Seems to be 1 step forward and 2 steps back at the moment! As my character isn’t max level yet, I can still regard it as a levelling experience, but pretty soon it will start to get really annoying!! :grinning:

Now I’m getting frozen (program becomes unresponsive) once I enter Echo. Had it happen twice in 5 minutes, I’m done with this game until they fix this BS. Literally wasting my time since I lose progress everytime it happens

I have 16G RAM and the maximum used ram never reached even 10G. After some time the game started to crash upon startup again. It happened after my PC was working for several days without a reboot. I did another test and increased the swap file size to 8G and all crashes disappeared again.

Same issue here. Crashes quite often. every 1 or 2 echoes

Same here!
It wasn’t that common before the last update, but now my game crashes almost every 5 minutes, is there anyway to fix this issue?