Game crashes with UnityPlayer.dll error

Faulting application name: Last Epoch.exe, version: 2019.4.40.50731, time stamp: 0x62a10ee1
Faulting module name: UnityPlayer.dll, version: 2019.4.40.50731, time stamp: 0x62a11020
Exception code: 0xc0000005
Fault offset: 0x0000000000466dfa
Faulting process id: 0x0x5EF4
Faulting application start time: 0x0x1DA69EADCEE3495
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\Last Epoch\Last Epoch.exe
Faulting module path: C:\Program Files (x86)\Steam\steamapps\common\Last Epoch\UnityPlayer.dll
Report Id: 79068487-49c2-4d52-88ba-9ff86ea7132c
Faulting package full name:
Faulting package-relative application ID

Faulting application name: Last Epoch.exe, version: 2019.4.40.50731, time stamp: 0x62a10ee1
Faulting module name: d3d11.dll, version: 10.0.22621.2506, time stamp: 0xf2ce1d59
Exception code: 0xc0000005
Fault offset: 0x000000000010565d
Faulting process id: 0x0x3054
Faulting application start time: 0x0x1DA6999C4406C4B
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\Last Epoch\Last Epoch.exe
Faulting module path: C:\WINDOWS\SYSTEM32\d3d11.dll
Report Id: 14301460-a5b7-4a2b-b3a3-01a77b72b65b
Faulting package full name:
Faulting package-relative application ID:

Same crashing issue.

Laptop Alienware M15 R7
12th Gen Intel(R) Core ™ i7-12700H
32Gb Ram
Driver’s and OS up to date.

Can’t understand why we keep crashing. It’s frustrating to play with such low graphics.

Any news about this issue?

My laptop has 32GB of RAM. If I were to follow your suggestion to increase the virtual memory, should I increase it to 64GB?

The situation is frustrating. Some specific monoliths are simply unplayable.

Ive been in the same boat as everyone else in this thread. I disabled XMP and I havent had a crash at all since. I would really love to not disable XMP, for obvious reasons, so a future fix for this would be really appreciated.

I’m not in the mood to disable mine just because some other players report that they keep crashing after it. Please, if you crash again or if you manage to fix it, repost here :wink:

It is difficult to say how much virtual memory is required, as system specs differ. So getting to a resolution will probably take some tinkering and testing with different virtual memory and graphics settings. The first goal is just to get stability, then you can adjust to higher quality graphics settings, one setting at a time, till the game starts crashing again, and you know you hit the limit.

My suggestion would be to start testing with the following settings:

  • Set your virtual memory to 32768 (32GB).

Graphics Settings:

  • Master Quality = Medium (go to low if crash. This setting resets all the other settings, so adjust afterward).

  • Shadow Quality = Very Low (set higher later with testing, not really noticeable above Medium).

  • Grass Density = Off (Can enable with testing if needed).

  • Reflections = Low (Not much difference going higher later).

  • Ambient Occlusion = Low (Not much difference going higher later)

  • Volumetric Lightning, Screen Space Reflections, Terrain Quality = Very Low (barely noticeable with higher settings)

64 GB virtual memory seems very excessive. But it is very quick to test with your current settings and might just work out.

I dont know if anyone else is getting this. Today I am experiencing way more crashes for some reason. With the XMP disabled and everything low. yesterday i had a few crashes like less than 5 in 5 hour game time. I now get every 5 mins a crash, tried for the last 2 hours. I am really gonna give up on this game if this doesnt get address by devs or at least a proper work around… Since this is a memory leak after all.

Just an update - I discovered my bios had an update (built the system 5 weeks ago) - so installed that and re-enabled XMP. Im 3 hours deep with no crashes at all. Pre bios update that was impossible as my crashes were every 5-20 minutes.

Computer:      GIGABYTE B650 GAMING X AX
CPU:           AMD Ryzen 7 7800X3D (Raphael, RPL-B2)
               4200 MHz (42.00x100.0) @ 3593 MHz (36.00x99.8)
Motherboard:   GIGABYTE B650 GAMING X AX
BIOS:          FA2, 01/10/2024
Chipset:       AMD B650 (Promontory PROM21L.1)
Memory:        32768 MBytes @ 2994 MHz, 30-38-38-96
               - 16384 MB PC48000 DDR5 SDRAM - G.Skill F5-6000J3038F16G
               - 16384 MB PC48000 DDR5 SDRAM - G.Skill F5-6000J3038F16G
Graphics:      NVIDIA GeForce RTX 4070 Ti (AD104-400) [Zotac]
               NVIDIA GeForce RTX 4070 Ti, 12282 MB GDDR6X SDRAM
Graphics:      AMD Raphael - Internal GPU [GIGABYTE]
               AMD Radeon, 512 MB DDR5 SDRAM
Drive:         WDC  WDBNCE0010PNC, 976.8 GB, Serial ATA 6Gb/s @ 6Gb/s
Drive:         Samsung SSD 860 EVO 500GB, 488.4 GB, Serial ATA 6Gb/s @ 6Gb/s
Drive:         CT1000P1SSD8, 976.8 GB, NVMe
Drive:         Samsung SSD 990 PRO with Heatsink 2TB, 1953.5 GB, NVMe
Sound:         NVIDIA AD104 - High Definition Audio Controller
Sound:         ATI/AMD Zen APU - Display HD Audio Controller
Sound:         AMD Zen - Audio Processor - HD Audio Controller
Network:       RealTek Semiconductor RTL8852CE WiFi 6E PCI-E NIC
Network:       RealTek Semiconductor RTL8125 Gaming 2.5GbE Family Ethernet Controller
OS:            Microsoft Windows 11 Professional (x64) Build 22631.3155 (23H2)

Thanks for the suggestion SOTOH. Updated BIOS to latest version game still crashes, if i set settings to ultra game crashes within 2 mins. get like 150 -210 frames. just makes me so sad…

I have no idea, played POE for 3 hours no issue, juicing red maps with 6k wisps no issues… I am out of ideas, thanks for all the contributions, will try a clean install once more and if that doesnt work tomorrow time to uninstall till next cycle…

1 Like

Having the same issue. Update BIOS , XMP is disabled, tried varied virtual memory settings, reinstalled the game, updated drivers, compatibility modes, different/low graphic settings and FPS limits… and many other potential fixes. I think I’ve tried everything anyone has suggested on any possible forum or video this week.

13th Gen Intel i9-13900
RTX 4070ti
32GB Ram

I keep crashing constantly… before 1.0 the game was runnig just fine.
I started running the game on Verry Low setting and windowed mode in lower res, while keeping an eye on the Task-Manager. an a random Bridge my GPU shoots up frpm 30% usage to 99% and starts overheating.

unityplayer.dll crashing here as well, wish they had options to turn off settings rather than just very low.

I’ve suddenly started having these crashes on a very frequent basis. Tabbing in and out of the game or leaving it in the background appears to make it more likely to occur but when foregrounded it is preceded by a couple of seconds of stuttering/rendering lag.

It only started, for me, after upgrading my NVidia drivers to the latest version (551.61). Considering I’ve been playing for 5 years without any crashes on multiple PC’s this seems very pertinent.

The crashes are reported thus in Event Viewer:

Faulting application name: Last Epoch.exe, version: 2019.4.40.50731, time stamp: 0x62a10ee1
Faulting module name: UnityPlayer.dll, version: 2019.4.40.50731, time stamp: 0x62a11020
Exception code: 0xc0000005
Fault offset: 0x0000000000d7bd8f
Faulting process id: 0x0x92DC
Faulting application start time: 0x0x1DA6B2438F3FD0D
Faulting application path: D:\SteamLibrary\steamapps\common\Last Epoch\Last Epoch.exe
Faulting module path: D:\SteamLibrary\steamapps\common\Last Epoch\UnityPlayer.dll

But in Reliability History the report is:

Faulting Application Path: D:\SteamLibrary\steamapps\common\Last Epoch\Last Epoch.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: Last Epoch.exe
Application Version: 2019.4.40.50731
Application Timestamp: 62a10ee1
Fault Module Name: nvwgf2umx.dll
Fault Module Version:
Fault Module Timestamp: 65cdf06b
Exception Code: c0000005
Exception Offset: 00000000002cacbe

I have had it happening without updating to 551.61. I’m actually running 546.33 the most generally stable for Turing cards (RTX 20xx) of recent releases. The new release had some poor feedback on the nV subreddit and it doesn’t even have any patch notes for Last Epoch so saw no reason.

My system has no problem with more intensive games like BG3 or recent games with questionable optimization like Granblue Fantasy Relink.

For me, my error is like the OP. Faulting application is Last Epoch, faulting module is Unityplayer.dll

I rolled my driver back to an earlier version and it had no effect so it doesn’t seem to be that after all.

Instead I reduced my settings from mostly Ultra to mostly Very High. My fans dropped from a constant 2000+ RPM to a quiet 600 and the game hasn’t crashed since.

Not a single crash in the last three days.

Have set FPS limit (suggestion 60, I run 49 on an ancient system), and using graphics card driver software for limiting the FPS as the in game settings does not impose a constant limitation. The game has a tendency to spike GPU usage to 100% periodically, even in loading or character selection screens.

Another suggestion would be to check the Windows Reliability Monitor, to see if any other problems are showing up.

Windows start → type “relia” and enter or click “View reliability history”.

Remember to use the in game bug report tool (can be done at login or character select too) and enable attach log files, as this will allow EHG to diagnose much more efficiently and get us fixes faster.

Other changes that might be useful, more for disconnects instead of crashes though.

  • Disable VPN and associated security (infinite loading screen and crashing VPN background process and Steam for me, requiring a complete system reboot)- works with VPN again for me since yesterday.
  • Realtek (onboard) NIC, rollback drivers to native Windows driver (common problem).

After some more hours play, I still haven’t had a foreground crash since reducing my settings. However the game will now crash when backgrounded. Every time.

1 Like

Never-ending story for my also. Just created another bug report: Game keeps crashing

It’s really frustrating, especially not being able to find working solution. Sometimes I can play for hours, sometimes 1st echo and it crashes. Just boosted my swap even higher - will see if that helps but I do remember similar issue in GTA5 years ago, then playing a bit with virtual memory helped.

This has just started happening to me today with patches and At first I could get to a couple of zones then crash. Now I can’t even load into town.

Was hoping with the new patch the issue would be resolved. I got a new motherboard, since I had encountered some other problems. Asus Strix rog B550 AGAMING motherboard. can play for like 10 mins and game crashes. XMP is enabled and I did not increase virtual memory since other games dont require these work arounds, I only disabled overlays. I am getting way better performance with new motherboard so there was definitely an issue with the old motherboard.

Hopefully they address more memory leak issues. I was just standing in a corrupted monolith and while i was typing this game crashed with unity player error… :frowning:

I reinstalled my drivers 3 days ago. No crashes. 2ith the new update I’m crashing everytime I leave the end of time, sometimes on the log in screen.