My Account
× My Account Forum Buy Now

Last Epoch Forums

Game crashes each time I try to play with the primalist

Hello!
I recently bought Last Epoch, and I started playing an accolyte through the campaign. I’m currently lvl 40.
I wanted to try a bit of another class and created a primalist. So the creation cinematic started and after that the game freezes and nothing seems to work.
I killed the process and launched the game again, to try again, now the cinematic don’t show up (which I feel is normal as I watched) but nothing happens, I stay on the character selection with the game like processing something but never do anything (I let it do its thing for a hour or so).

I tried multiple times with always the same results, and the game loads normally on my other character. I tried deleting the primalist and make a new one but the result is the same.

I will try to make another character than a primalist to see if the result is the same.

Besides that your game is really good and I like it, it doesn’t bother me to stay on my accolyte for now but I still would looooove to try other classes! x)

Hey there… Welcome to the forum…

You dont provide any game logs or specific setup info like if you are using Steam or not so its hard to offer some suggestions.

The most important steps whenever having hassles with LE are:

  1. If you are using Steam, then its very important to verify the game files to ensure that your installation is not messed up.

  2. Make sure your GPU drivers are recent (last 3 months) and installed with a CLEAN installation not an upgrade

  3. Make sure your Windows is fully patched and there are no failed or awaiting permission updates.

  4. Temporarily do not use any other apps while testing LE - this includes things like Steam Overlays etc… Just dont use them to make sure they are not involved…

In most cases points 1) & 2) tend to solve issues… but if not, then you are going to have to post your player.log (immediately from the session where you experienced the issues), your le_graphicsmanager.ini (the settings file) and the output of a dxdiag report (your system & driver information)… These may have some indication of what is going on.

You dont provide any game logs or specific setup info like if you are using Steam or not so its hard to offer some suggestions.

Ah yes! Sorry. Not home right now, I’m not using steam, and my drivers are the recent one, at least I think so, I will check as soon as I can. I was thinking of maybe re-install the game. And I didn’t use any other apps while playing.

Ok… Its important to provide more detail else it really is a guessing game…

If you are using the standalone install, then you may have to consider a re-installation to make sure its installed ok… Problem installs unfortunately do tend to happen more often around patch time and they can cause odd things like you are experiencing. Its easier/quicker with Steam because of the file verification…

Another possible issue here is related to the performance instability that the game has at the moment… sometimes playing the game at settings that are too high (for the beta state of the game & your hardware) can cause issues very similar to what you describe especially when loading into maps etc… To test this is very easy - just set the game to 1080p, 60fps framerate limited (in game & not vsync), all quality on Very Low and special features disabled or on their lowest option… If the primalist loads fine, then the performance issues are likely the cause and you simply need to be conservative with your settings as a workaround until the devs can dedicate time to optimising the game…

Be sure to post the logs etc if you are unable to get things working with the above suggestions…

I reinstalled it and it works fine, sorry for the bother :smiley:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.