My Account
× My Account Forum Buy Now

Last Epoch Forums

FPS drops in the ruins of Welryn even on low settings

In the zone Ruins of Welryn in the ruined era, I get big fps drops no matter what graphics settings I use, Ultra or low drops just the same. I got a decent rig so there shouldn’t be a reason for such dramatic fps drops on even low settings, in one of the earlier areas of the game. My pc is a 2060 Super, Ryzen 5 3600, 16 GB of ddr4 RAM and a SATA SSD with 500 GBs of space. Nothing is running in the background. If needed more info I can post it. My build is a rogue, blade dancer using Flurry and cinder strike. Sorry for my English, I’m not a native. Should I Also Send DxDiag file too? If so do I need to run the application while playing in the zone in game?
le_graphicsmanager.ini (480 Bytes)

Hey… Welcome to the forums…

Please post more information

LE is in beta so there are definitely performance related issues in the game right now… One of these is the possibility that certain maps cause inexplicable fps drops… these have been mostly fixed by previous patches but its not impossible… The key for map based FPS problems is that the only way to confirm it is to replicate the issue to confirm… I run a 1060/i5-7500 and I get no noticeable fps spikes in this particular map…

So…assuming the map is generall ok for most people, the next step is to see what specific settings you are using that could be a “deadly combination”

From the settings file… I see that you are running everything enabled and on Ultra… This is not recommended… I know you are running a system that should capable of doing so especially at 1080p, but LE is unoptimised and this means that using higher settings highlights any issues that LE is having and players notice problems… For example, while there is very little difference in visual quality between Medium and Ultra settings, you will notice that the GPU usage % is considerable and maxing out the GPU essentially makes the game unstable and it starts doing very odd things.

Even people on 30 series gpus with the latest 5000 series AMDs have confirmed problems if they push Ultra settings - especially on higher resolutions.

Your settings file shows that you are using Vsync… LE has odd problems with vsync… I recommend using framerate limiting (*enable the check box). One of the things this prevents is your GPU maxing out for no reason… I have found that you need to restrict LE else it runs away with the GPU and you begin to get very large FPS drops for no reason… For example, if I do not use framerate limiting, my old 1060 can run the game at 100fps on low/1080p but I get bizarre 40fps spikes or the game freezes…

Try playing the game on the following settings and see what happens:
1080p, 60fps framerate limited, ALL in-game settings on very low, disabled or the lowest setting… Be sure to check each item manually dont just use the drop down at the top.

Also

  • Make sure to verify the game files through steam
  • Make sure your Windows Os is patched properly to 19043
  • Make sure you are using a recent gpu driver… For nvidia do not use version 466.77

Post the other files and I will see if I can help further.

Hey thank for the reply. No matter the settings I play in it lags the same way in that particular zone. Low, medium, high and ultra lags just the same, I do run on ultra, because on 99% of the game it runs fine at 75 fps G-Sync 1080p. I’m running vsync on because with g-sync on and caped framerate at 73 fps as per online recommendations, I still gets tearing, so vsync helps with the tearing issue while capping the frame rate so I don’t get any input lag or half frame rate when dropping bellow the monitor’s refresh rate as per non gsync. I’m on the latest driver version and windows update 2004. I did notice how ever, that I can only get gsync to work on exclusive fullscreen and not on borderless no matter what game I play with it on, I tried using gsync with windowed and fullscreen mode on the nvidia control panel but it doesn’t seem to work. The Gsync is working as even if I cap frame rate at 50-65 I still get smooth experience as if i was playing with static 75 fps cap and vsync on with no drop. It’s actually even better, just that in this zone it drops way too much on my end. BTW I’m running on the official client, not on steam. What other files do u mean? the DxDiag? As I asked in my post, do I need to run it while playing in the zone?
Player.log (100.7 KB)
Player-prev.log (1.2 MB)
launcher-log.txt (48.0 KB)
output_log.txt (875.6 KB)
DxDiag.zip (15.8 KB)

Hi.

If the settings dont make any difference then there is something else at work here…

You need to monitor your GPU usage if you insist on running Ultra mode - as I mentioned before, its not a question of your hardware, its the current unoptimised state of the game that is important here… The forums are full of people having issues running on maxed out settings (like Ultra) and the moment they accept that they should be conservative with their settings, things improve… Its up to you really but I am sure your GPU will appreciate a breather… Obviously when the devs get to fixing the optimisation issues then things like this shouldnt matter anymore but for now its (imho) just not worth it.

Windows 2004 - I have no idea what build update that refers to (this is something that you can see in Dxdiag). Google says that update is from March… The main thing here is that there were a batch of updates from Microsoft in May/April that caused fps problems in games - these were subsequently updated in later updates (amongst other fixes) - so its very important that Windows is updated.

GPU drivers - again this is in the dxdiag report… A thing to point out here is that graphics drivers are usually one of the first things to check with problems like this… Sometimes the latest and greatest doesnt work as well as a older driver or a new driver might have a bug (like version 466.77 had)… Drivers can also have non default settings that can cause problems… e.g. DSR configuration can make a big difference in certian situations…

Vsync Gsync etc… These are important as they can be conflicting each other… you need to be careful with the setting and make sure they are not messing with each other… Tearing is also something that has been a problem that some players say have been resolved by changing gpu drivers and by setting vsync on a driver level exception for the lastepoch exe… This doesnt explain the fps loss in the map tho…

The one thing you didnt mention what how BIG the fps spikes you get are? 10-20fps… 30-40fps? Larger? Does the game seem like its stuttering or freezing for a split second?

Can you monitor your GPU usage when you are in this map? I.e. does your GPU usage % increase or do you just get lower fps?

Dxdiag can be run at any time and the output exported.

Edit… I see you have added the files… will look at them now.

Hey sorry for not giving enough info, I did run the game once before sending the files, and I put the graphics settings in low to make sure it’s not a setting thing, and yeah it dropped quite badly in combat or in certain random moments. I’m not sure how bad the drops are in numbers but it feels pretty bad, It felt like going from 60-70 to like 30-40 I’d say but it could be even lower. I Suspect the G-sync might not be even working with the game’s exclusive fullscreen, because as I said it tends to not work on windowed and borderless but only on true exclusive, and in other games, exclusive fullscreen tends to have very slow alt tabbing, and this game’s exclusive fullscreen mode is very fast at it, like if it is borderless fullscreen, idk it could be placebo from this game’s exclusive fullscreen being just good at it and that would explain the smooth experience through out the other game’s areas like with gsync being truly enabled. About the gpu usage, i can do a test with riva turner and after burner’s statics on to see if it is a gpu or cpu usage problem I’ll just have to reinstall these programs, i did update windows to the latest version i could without it being 21h1 because it had corrupted my older ssd and the ssd of other people before on the internet, so I’m a bit hesitant to update to that big number version of windows.

The player.log is fairly normal although it is reporting a message:

Particle System is trying to spawn on a mesh with zero surface area

I dont recall seeing that in other player.log files and it might be something that the devs can check on. @KissingAiur - any chance you can see if this is a known issue causing fps loss - specifically on the Welryn maps?

The launcher log seems like its working fine and patching the game properly.
Same for the output log.

From the dxdiag…

Your windows is on 19041… the latest is 19043

Your AOC monitor technical documentation says it support FreeSync, and has no mention of GSync… are you sure its actually working?

The diagnostic section at the end of your dxdiag file has some worrying items:

You have LiveKernelEvent 141 errors… These can be quite serious as they can be caused by bad GPU drivers, overheating GPU, agressive overclocking, memory problems and even problems with harddrives… You need to check your WIndows Events and run some tests on your system. Google is your friend.

PoE has also crashed regularly on your system - it could be related to the above…

You also have WindowsWcpOtherFailure3 errors - these are related to windows updating properly… I recommend that you run Windows File System Checker to see if you can fix whatever is causing this issue…

Nvidia updated gsync to support freesync, i don’t overclock my system so it can’t be that, but i’ll have a look at it, poe crashes on any system, it could be that but i know what causes it, when i alt tab off of poe and leave the game in the background whilst playing on exclusive fullscreen mode after a long time and i alt tab back to the game it crashes fairly often, so that’s probably it. I had gotten one windows update not working after having formatted the pc and i did check with microsoft support and fixed the issue, was able to update it then, haven’t had any update issues since. I use my windows on ssd only, the HD is for storage only. I’m updating windows to the most recent version now. PS: Ok done i’ll just restart the pc. Thank you so much for all ur help. I hope i can get this fixed.
PPS: the fps issues are only in the ruined version of welryn, not the imperial one.

Edit: I updated windows but in system info it didn’t change the version number to the one u stated as the most recent, could be that the most recent ur saying is related to the 21H1 update which I’m hesitant to install…
Edit 2: I used the windows system file checker and it prompted that there were corrupted files but it managed to fix them.

Edit 3: Ok, I did run a Riva turner test and it looks like I’m starting out in the zone with 60 ish fps, then as I walk through and kill monsters, it starts dropping down to the 50’s, then eventually down to mid 40’s and by the end of it I’m at 40 ish fps close to the entrance to the under district. BTW I disabled Vsync and limited the fps to 60, 70 then 73 to see if it changed anything, smooth framerate in town and other areas but stuttery as in Ruined Welryn.

Freesync… Ok. Personally I am wary of the gsync, freesync etc as I have never really had much success with them - at least not noticeable really. But thn I have not ever really had a high end gsync capable monitor etc…

Overclocking Ok.

Check memory XMP profiles - technically these are overclocking but usually automatic and tend to be stable depending on motherboard/bios/memory manufacturer… mainly they need to match the CPU capabilities.

Watch for thermal issues on any components - these can cause the same Kernel errors and wouldnt leave any visible software trace. E.g. Your 2060 shouldnt get near/over 80 degrees C. (it will survive, but thats far too close to its thermal max). Case thermals can also be a factor…

The main thing is to trace these livekernelevents to something - they are not good irrespective of anything else on your system.

PoE… Ok. The main thing here is that you know what caused it.

Windows Update - its been a few months now since 21h1 dropped and it does fix a lot of general windows issues - up to you I suppose but the main thing is that you are not running the problem KB5001330 and KB5001337 updates from earlier in the year and the simplest way to ensure that is to update.

Ruined Welryn… Ok… There is another person currently having with an fps issue in Welryn docks but his setup and game log messages are entirely different to yours and the only real thing that is the same is that he is also struggling with gsync/screen tearing too.

Riva test - Ok… this sheds a bit more light on the problem… You have a gradual decrease in FPS while playing - thats different to temporary FPS spikes which I assumed you were having.

There have been a few people that mentioned similar to this (not specific to particular maps tho)… They play the game and at the start of the map they will have e.g. 100fps… and by the end they will have e.g. 60fps… If they tele back to town or load another map, then things “reset” back to 100fps…

Some of these are attributable to the way the players proceed through maps - i.e. they rush through pulling mobs instead of clearing and this means that by the end of the map they have a huge number of off-screen mobs all pathing to find the player and this drops fps… The devs changed updated the pathing in 0.8.2 but its still something that can happen.

In some instances it almost seems like it could be memory issues but there has been no way to confirm this as you can monitor RAM and it doesnt show an increase beyond jumping higher or lower depending on maps/mobs etc… It seems to return back to what it was after a map or two. This kind of thing only the devs will be able to trace so its no help to us right now.

Other players found that these fps decreases were caused by problems with their systems - corrupted/old drivers, updates, and generally expecting more from their hardware than LE can deliver right now.

The main thing about limiting the framerates is that it seems to smooth fps spikes and prevents LE from maxing out the GPU and getting unstable… This usually works for most players…

The key thing here for you is that the game is still playable… there just seems to be some very specific instance/set of circumstances that could be a bug/issue…

Lets see what the devs come back with.

Alright, thanks for all ur help, I’ll check my thermals to see if things are out of normal i.e. over 80 on my gpu and stuff, I’ll also update my windows to the 21h1, hopefully it won’t damage my ssd like it did to my last one when I updated earlier this year xD. As u said, the game if far from unplayable, and I can even play on ultra on 99% of cases, which i know is not recommended, that’s why I’ll drop to very high instead. Anyway, hopefully the devs can find what ever is causing this to happen to me and the other people having similar issues. The only overclocking thing I can think of is my mother board’s bios, performance mode over the normal mode, which I chose in the bios, as I think it just affects how much power it sends to the components, not really the cpu, ram and gpu’s clock like a regular overclock. If u think this could be the cause and I shouldn’t use it, then I can try see if disabling it helps any. U mentioned my 2060, but I want to clarify that it’s a 2060 super, cause a lot of people assume the 2060 super is just a better version of the 2060, when it’s really a slightly toned down version of a 2070, which makes a huge difference in performance, as it performs just 1 or 2 fps shy of a 2070 performance, and has 8 gb of vram which helps a lot with high res textures(like when modding skyrim with 4k textures ; ) ). Anyway I want to again thank you for ur time. I really appreciate it :slight_smile:

Np…

Thermals… always good to keep an eye on those… I mainly notice it on my systems because I hate fan noise :wink:

Updating to 21h1 - honestly, its unlikely to resolve it… If you are worried about it, just leave the update but check for those KBs and make sure they are not running and make sure there are no problems with optional or deferred updates. I dont have 21h1 installed on most of my systems but it doesnt seem to make a difference/or cause any problems that I can see.

Motherboard performance mode… well, that might have something to do with the livekernel events but I would check the details in the Windows Event log before changing bios… One thing I defintiely would do is check if there is a bios update that affects performance/stability.

2060 super - yes… I just got lazy typing it out… :wink:

Ok, i just don’t understand the whole events thing, what is that? is that the windows event viewer app? What are livekernel events? Googeling brings up people with problems with windows freezing or something and it’s generally a driver issue, but as i said i’m on the most recent driver version, and i haven’t encountered any full on windows freeze, i took a look in to the event viewer app and the application’s logs state a few errors as u said, some i can’t make anything out of or seem just regular windows stuff like internet error or updated to newer version, the others are from poe crashing and one from last epoch launcher, the only karnel based thing i see is karnelbase.dll from poe crash. IDK what to make of all that… there is also a bunch of warning logs in there too, way too many for me to check each one, mostly they seem to be about updating something to newer version as well.

… I’ll try and explain it as best I can without getting too complicated …

The diagnostic section at the end of the DXDIAG export contains a list of the last 10 noteworthy errors that your system has had to deal with.

These errors can be viewed in more detail in the windows application called Event Viewer. You can look at the dxdiag text file for the exact names of the events to search for.

Each of these events is associated with a particular event name and then usually a list of secondary information that relates to the type of event, the applications involved, the system dynamic link libraries (dlls), file versions and various other informaiton that is supposed to help figure out what happened. Most of the time this information can look like gobbledygook if you dont understand it.

These events can be classed as Critical, Warning, Informational, Errors etc… and in another set of categories like System, Application, Security etc… Obviously Critical issues can be quite serious and warning messages are usually worth making sure they dont become serious… For example, your computer crashing to reboot level is likely going to be critical… your harddrive failing might include warning messages about being unable to write.read the drive.

Most errors are usually related to applications that have crashed due to any number of things… For example a badly coded app might try and do something its not supposed to do and crash… A game might try and access a graphics card driver and a bug in the driver causes the game to crash…

Sometimes these errors are not really errors - just information that Windows deemed important enough to note… an example of this can be an application that didnt close properly and didnt clear the memory it was using - these kinds of errors are less serious.

Occassionally, there are serious errors with names like BlueScreen (obvious) and LiveKernelEvent… To a normal user they are very difficult to understand… but looking at the additional information provided in the event viewer you can see for example a BlueScreen might have crashed on a dll file that belonged to a particular piece of hardware… then you can deduce that perhaps that dll needs updating or perhaps there is something wrong with that hardware… LiveKernelEvents are trickier… For example your events come with a code of 141… This can mean lots of different causes - primarily they tend to be driver related and usually GPU but thats not the only possiblity… thats why its important to see what further information is available in the event viewer to help pinpoint where the problem could be. And remember, just because you have installed the latest drivers doesnt mean that they are working properly or are bug free…

Unfortunately all the different errors are not listed somewhere and neither or they easy to understand for someone who has not done low level technical support so its not very easy to fix things as a normal windows user… Google does help, but you can easily go down the garden path and not actually fix anything… especially if you just search for something like “LiveKernelEvent”…

A lot of time the solution for Event Log errors are relatively easy… Update Windows, install new version of an app causing problems, updated some driver or change a configuration somewhere… Other times they can be hardware related - i.e. warning could indicate that your harddrive is failing and needs replacing before you lose your data… Other times errors can be so complicated or obscure that you cannot find the cause let alone the solution…

The key is that you really shouldnt ignore any errors (especially critical /warning level ones) IF you cannot explain or know why its happening… E.g. if you know that PoE always crashes when you alt tab then you can ignore the PoE error message because you know why and how it happens and its not something that is messing with your machine… only PoE…

Windows tends to hide a lot of things from users to make the user experience easier and smoother but when something goes wrong and you have to look under the hood it can be a little overwhelming to find things that you never saw or realised where happening…

Wow! I can’t put in words how good ur explanation was, and how helpful u have been, if not for fixing the problem it self then god sently shed light on such a confusingly obscure and technical issue, that i would have absolutely no idea on how and why it was happening, let alone how to fix it. As u said googling only got me so far, search results for LiveKernelEvent got me to a handful of, oh update ur drivers sort of solution in various forums, so i was as clueless after googling as i was before, maybe even more clueless, specially considering that I wasn’t even thinking of the possibility that, having the latest driver version, might just not be the solution, considering that the driver it self could be the culprit. Anyway I think I’ll just live on and ignore this, considering i know what is causing the errors and how to avoid it, and it isn’t really affecting the overall behavior of windows or poe it self, it’s just a minor annoyance. In reguards to LE, i’ll leave this one as a thing for the devs to look in to and as a characteristic of the game still being in beta state. Thank you for everything. :smiley:

1 Like