Failed To Initialize player

Every time I try to start the game trough Steam I get this error:

Failed to initialize graphics.
Make sure you have DirectX 11 installed, have up to date
drivers for your graphics card and have not disabled
3D acceleration in display settings.
InitializeEngineGraphics failed

I’m on Windows 10 version 21H1 (updated).
I have a AMD RX580 and updated the drivers…
Attached Logs I found inside the game folder.

Last Epoch_d3d11.log (16.3 KB)
Last Epoch_dxgi.log (5.3 KB)

Hey, Welcome to the forums…

I dont recall seeing this kind of error posted about before…

Assuming the installation ran ok, if a game stops at this level with DirectX it means that there is something wrong with GPU drivers or some issue on Windows. DirectX is built into Windows 10 and installs/updates as part of the Windows Update cycle so it cannot be uninstalled or separately reinstalled… This error could also indicate corrupted system files or runtime DLLs that are either not installed or the wrong versions…

Please can you upload your DXDIAG output.

Please look in BOOTDRIVE:\Users\USERNAME\AppData\LocalLow\Eleventh Hour Games
and upload any player.log and le_graphicsmanager.ini files.

Some things to do:

  1. Make sure that there are no failed or pending Windows Updates
  2. Make sure that Steam is updated to the latest version
  3. Verify the LE game files through Steam to ensure the installation is ok.
  4. Run Windows System File Checker to make sure that your system files are ok.
  5. Check “View Reliability History” on your system and make sure that any errors are corrected.
  6. You may need to do a safe mode GPU driver reinstallation (or use somehting like DDU) to make 100% sure your GPU drivers are installed correctly and havent become corrupted.

Hello Sir,
Thank you for your time, I have been getting some wierd graphics crashes when using Chrome. I did all the steps recommended and nothig works. I’ll attach the logs requested. I did the Window System file Checkeer and I did say It corrected some corrupted files but I still get the same error when trying to launch the game.
Next Ill try doing DDU e completely removing my VGA drivers.
If that dont work, I think I need to do a clean Windows re-install but since I have Linux (dual boot) I need to research how to do that first.
Player.log (672 Bytes)
Player-prev.log (672 Bytes)
le_graphicsmanager.ini (487 Bytes)
DxDiag.txt (102.2 KB)
CBS.log (699.4 KB)


The fact that SFC found problems is not great - sometimes you need to run these more than once to be sure things get updated - You also need to run WIndows update each time to make sure that update is working.

The information in your DXDiag shows that Last Epoch is crashing on d3d11.dll and with a secondary error of StackHash_xxxx - these kinds of errors are 100% related to graphics drivers and looking at the player.log I would definitely say something is wrong on your system wrt the GPU and your DirectX installation… I would definitely recommend a safe mode driver reinstall / DDU at the very least, but it might be more serious than that…

Your uTorrent is also crashing on GDI32.dll - which is another part of the graphic device subsystem on your machine… To me this just confirms that you have more than one issue with graphics on your machine and you should probably stop doing anything else until you can fix it… Reinstallation is obviously good as it resets everything but it doesnt explain what happened so it can happen again if you are not careful.

I would also physically check your GPU and make sure its correctly seated in your motherboard, free moving fan (without clicking or grinding noise) & clear of any dust etc and that any power connectors are in place correctly - its unlikely this is a problem but its always good to double check this kind of thing - especially on old cards.

Reinstalling Windows with Linux dual boot is not usually a problem. Just look for an online example that matches your particular Linux distro and it should be a step by step.

I also see you are using VB-Audio & Voicemeeter… Please make sure that you are using the latest possbile versions of this software and virtual device drivers - there have been players using older versions of these apps and have had odd problems.

Good afternoon,

So after I read your comments I turned my PC off and removed my VGA and did a clean up and checked/tightened all screws (some were loose).

Then I proceed to do DDU in safe mode without internet connection (so windows update messed with the drivers).

After that I did a clean driver installation that I had downloaded before.

I stress tested with some games I have installed (F1 2020, Grim Dawn…) and they all run very good, normal GPU temperatures all around.

And than I tried launching Last Epoch and I still got the same error. I even uninstalled LE and installed it again. Same result.

Just for science I installed Last Epoch on my Linux distro that has Fedora 34 and It runs well, I noticed some lags here and there but I think the Vulkan Shaders didn’t load properly.

My guess is something with my Windows 10. I did tried closing all other programs and uninstalled uTorrent.exe (it was having crashes too).

Thank you for your time and I really appreciate your suggestions.


Few things I am worried about…

  • SFC finding corrupted system files - never a good sign unless you know why the system files were messed up. The problem here is that you dont know how bad it actually is… I do no know how you have your dual boot setup/drive partitions for linux etc, but maybe its part of the issue with the corrupted system files?

  • Every search result I have looked up with the Unity error of Failing to initialise graphics all say its the GPU drivers or DirectX has been disabled/corrupted.

For GPU drivers people either reinstall as you have or roll back to an older driver.

For DirectX its more difficult as Windows 10 already has DirectX installed… Maybe your system needs some files from the older distributions - I doubt it/makes no sense to me but this error is so odd that I am guessing here… Personally I have never needed to do this on any of my Windows 10 machines and between my teenage kids and I we play a wide variety of games that need DirectX… However you might want to try the previous DirectX installation to see if it can replace/add anything that is missing on your system.

Other games - hard to say if this is even a valid test - for example, Grim Dawn was released in 2016 using DirectX 9… LE is using a game engine from 2019 and from what I see of the Unity game engine, it defaults to DirectX 11… F1 2020 uses the Ego Game Engine and who knows how this is handling things on your machine or even if its using DirectX - it can use OpenGL instead…

There are ways to try and force the Unity game engine to use older DirectX feature levels or different by using command lines (like -force-d3d12 or -force-feature-level-9-3) but honestly… I think this is not the way to go about fixing the problem on your system.

So when I installed Linux I did on another 120 SSD that had nothing saved on it. Because of that I didn’t had to partition the SSD where Windows is installed. Windows 10 is installed on a 1Tb SSD and Linux on a 120Gb SSD.

I did tried reinstalling the DirectX from the same location you linked.

My guess is after the 21H1 update something went bad. It’s not the first time I have Windows problems after It has gone trough a major update. Since I don’t understand enough Windows to fix this I should just do a clean install and hope for the best.

I’ll do that now and I’ll come back with the results.

So after reinstalling Windows Last Epoch launches perfectly.

I guess Windows is just like that some times.

Ok… Patches can mess things up… I personally havent done the 21h1 installation yet myself and I doubt I will until forced to do so but it still shouldnt mess things up like it has…

Now that its working I would suggest you make a System Restore Point on your windows installation - it will take some space but this will give you something to revert back to if you experience Windows problems again - its like a “last known good config” that you can restore if things stop working again…

A restore point also works if you patch Windows & something goes wrong - you can revert back to before the patch…

Anyway… Glad the game is at least working again… Just in time for Fridays update!

You just SAVE a lot of time for me now because I always forget to do a Restire Point.

Can’t wait for the new updates.

Anyways thanks for you help and last question do I need to do anything to close this request? Or It closes automatically? (First time doing any Forum post);


Just pick the post where you confirmed the reinstallation worked - there is an option to mark this post as the solution to the thread… it will then close in 3 days unless someone replies… if you leave the thread open, then it will stay for 2 months (i think) before the auto close feature kicks in.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.