My Account
× My Account Forum Buy Now

Last Epoch Forums

Exe not responding

Hadn’t played the game in a while and tried firing it up and now it just hangs at the “entering eterra” screen or the account login. Freezes up and when I click anything I get the .exe not responding error message.
I’ve reinstalled and cleared my dns cache. no other apps running. Newish graphic drivers but not the newest drivers.
I upgraded my gpu to an RTX 3070 recently but that’s the only change. Don’t see how that would make the app not respond.

Hey… Welcome to the forums…

Please can you post your system info, player.logs and in-game settings information. They may contain more information as to what is going on.

What happens if you chose Wait when you get the program not responding problem? Sometimes waiting at this point (instead of ending the process) allows the game to deal with the login timeouts - especially if you have not played/logged into the game in a while - you dont say how long ago you last tried to play.

New graphic card might require you to reset the in-game graphic settings so that the game assumes default configs (these would not have changed when you reinstalled the game)… You can do this by renaming the le_graphicsmanager.ini file (to something like oldle_graphicsmanager.ini) in your Last Epoch folder (with nothing launched obviously).

Graphics drivers… make sure you are not using 466.77 - this has issues. Also, did you reinstall the drivers when you updated the hardware or did you just continue using the existing installed drivers (assuming you were on Nvidia before) - this can potentially cause issues depending on which components of the driver were installed on your older hardware vs the new hardware…