My Account
× My Account Forum Buy Now

Last Epoch Forums

Error : "This APP can't run on your PC To find a version for your pc, check wi"

  1. Downloaded the Demo

  2. Extracted from zip

  3. had 3 items in folder :
    a - Last Epoch Kickstarter Demo_Data
    b - Last Epoch Kickstarter Demo.exe
    c - UnityPlayer.dll

  4. Double click on the .exe results in a windows error :
    “This APP can’t run on your PC To find a version for your pc, check with software publisher”


System information :
Intel i5-3470@3.2ghz
RAM: 8.00 GB
System type: 64-bit operating system, x64-based processor
Windows specifications:
Edition : WIndows 10 Pro
Version : 1709
OS Build : 16299.371

Video : NVIDIA GeFOrce GTX 660

Hi mate,

Thanks for bringing things from Discord to here, and I’m really sorry for all the inconvenience you’ve been having trying to check out Last Epoch. We really want to get you in if we can!

Could I please ask for a DxDiag to help us investigate? Here’s a guide;

Have you tried extracting the .zip a second time? That often fixes issues, if not try re-downloading. Sorry about this!

Yes i did and it does not work.

Someone on Discord noticed that the icon of the .exe looks wrong.

I believe my computer doesnt not recognize it. If i “Run as Administrator” i get this :

I also tried removing the spaces between words ( by renameing it) but it still doesnt work.


Yes, I’m the one noticing that Windows fell back to a default icon. Have you tried completely removing Last Epoch and downloading it again as Hackalöken suggested?

Problem solved with Zoaper’s help.

I used winrar to extract.

When i opened the ZIP, and saw the 3 things in it, click-dragged those 3 in a new folder. Extraction happend. But the exe didnt work.

Second time, I just rightclicked the zip, and clicked “extract to” a new folder. The exe was good. I basically did the exact same thing, by 2 methods… I now have 2 game folders, containing the exact same files, exact same size. 1 works, and 1 doesnt.