My Account
× My Account Forum Buy Now

Last Epoch Forums

Crashing on launch after patch 0.8.4g

When launching, at title screen I get an error of some kind that I can’t even read because it and the game both just close.

Edit: Managed to get a screen grab of what flashes before crash. LEcrash.zip (674.4 KB)

Edit: Fixed by verifying through steam, Verify link

Known issue we’ve tried to get the devs to acknowledge and investigate. See thread here among others over the past two weeks. All we can do is wait for a fix. You can attempt verifying the game’s integrity or reinstalling, though.

Same problem here. After the update my game just crash when loading

Solved updating my GPU driver and checking file integrity

with the new update i was playing for a good many hours before a crash. problem aside from the crash, the game is not outputting crash logs.

it crashed discord too. again it feels like the game is trying to use more memory than is available.

i7 9700F
Nvidia GTX 1650 (4GB)
Windows 11 (16GB RAM) 3GB - 8GB paging file.

i do not have Citrix, all folders i need to exclude from windows defender are excluded, i am running the latest video drivers, and latest windows updates. when it comes to game, app, progam installation im very careful and thorough on how i do it so as to not have any issues.

1 game that is crashing and its this one.

I just got the game yesterday and I am having the same problem. Game crashes on launch. I am using the steam launcher. Verifying steam files does not work consistently.