My Account
× My Account Forum Buy Now

Last Epoch Forums

Crashing cannot start game Any tips?

Since i purchased it three or four days ago, i’ve been having problems with launching it, i try and start it through steam and stand alone, and each time it’s the same problem, not sure what could be causing it, really interested in trying the game, is there any work around to this? i run it as admin, tried compatibility. But still the same outcome, whether i try loading it through the launcher or Steam. if anyone has any advice i’d be glad to try it. looking forward to playing.output_log.txt (1009 Bytes)

It’s a paint Print screen so, sorry about that. haha. I’ve also tried disconnecting my second monitor.

Fixed, workaround is uninstalling my antivirus, even with the exemptions it didn’t download specific files, not sure which ones, along with reinstalling the game then when it booted and the problem happened again, verify the cache and another driver update. hope it helps some.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.