My Account
× My Account Forum Buy Now

Last Epoch Forums

Crash due to memory management?

Hello 11th Hour Games

When I try to play, after selecting a character I see usual loading screen, then I got message about missing memory (though I have 16GB of RAM), then the game crashes. Could you give me some hints please?

Hey there…

Please can you include the following files:

  1. Player.log - the games debug file which may contain a hint at what is happening.
  2. le_graphicsmanager.ini - the games settings file to see what configuration you are using.
  3. the output from a Dxdiag report - your system info, hardware/devicedrivers/diagnostics.

The first two are found on windows in:
BootDrive:\Users\USERNAME\AppData\LocalLow\Eleventh Hour Games

Btw, how to check integrity of files? I was searching for the option in launcher, but didn’t find it.
The files:
le_graphicsmanager.ini (487 Bytes)
output_log.txt (33.8 KB)
DxDiag.txt (57.9 KB)

You player.log file? The output_log.txt doesnt have detail that the player.log has so its hard to see any errors that could help.

I think the standalone launcher checks for patches automatically, but I am not sure how well it verifies the files - seems like a lot of people using the launcher tend to try reinstallations to be sure… I havent used it beyond testing patching… I play via Steam.

I did notice something very odd tho:
Your output_log.txt says the game engine is:
Initialize engine version: 2018.3.8f1 (fc0fe30d6d91)
I just downloaded the standalone player to check what my output file says:
Initialize engine version: 2018.4.2f1 (d6fb3630ea75)
So there is definitely an update to your game installation - just comparing output logfile versions 2018.3.8f1 and 2018.4.2f1

I am not sure if this is related to Windows 7 vs Windows 10 and the game engine (Unity) , but my first suggestion would be to reinstall the game to make 100% sure you are using the latest version possible for your setup.

The DXDIAG file unforunately doesnt output diagnostics on Windows 7 (it does on windows 10) so I cannot easily see if there is a general problem on your system or something specific that LE is reporting… I recommend that you look in your Event Viewer and see if there are 1) any errors that are registered around the time you are testing LE and 2) any other serious errors on your system that could be related - things like DirectX, hardware errors, etc…

I was hoping for more detail from the files but its hard on Win7… so, do you recall what the Missing Memory error was exactly? Any chance you can screenshot it when it happens again?

without more specific detail, I would recommend the following:

  1. Make sure your WIndows 7 is updated to the absolutely latest you can… This is obviously trickey now that Microsoft no longer supports it, but updating things like DirectX manually could make a difference. Checking Platform updates which include Direct3d etc updates etc could help - even if they just reinstall a patch to make sure there are no messed up / corrupted files. You are using new GPU drivers and a GPU that didnt exist when Win7 was still actively supported so its important to try any and all means to ensure that things are up to date as much as you can.

  2. Make 100% sure NOT to run any other applications while testing LE. This includes overlays or any other applications no matter how OBSCURE you might think it is… There are plenty of third party apps that cause issues with the game engine - especially older Win7 ones… Just temporarily dont use anything to tick them off the list of possible issues.

  3. As a test regarding your OP description… Backup your LE folder with the savegames… on win10 this is in Bootdrive:\Users\USERNAME\AppData\LocalLow\Eleventh Hour Games - I cannot recall what user folder tree Win7 used but you should be able to find these… After you are 100% sure you have backed it up, then try and delete the contents of the Eleventh Hour Games folder entirely… This will reset everything and remove all saves, settings, filters etc… If the game runs after this, then it could be that something was corrupted in your previous files (this can happen on a beta game like LE)… If it makes no difference then obviously your files are not the cause of the issue.

  4. A last test is to set ALL your in-game settings to very low and all special effects to disabled… BEFORE loading a character… LE is in beta so sometimes performance issues can cause problems and the very low all disabled config is a good way to quickly test - obviously if the game starts without errors, then the problem is settings/hardware related…

The player.log might provide more info…

Ah my mistake, I’ve added the wrong file, sorry.
Player.log (17.6 KB)
Player-prev.log (1.4 KB)

Ok…

The player.log is reporting two things that I think are relevant here:

  1. Its reverting to an older DirectX version - this is probably Win7 related

  2. The game is unable to load certain 2D textures due to memory issues.

  3. After attempting to load (and failing) a dozen or so times, it then crashes and creates a crash log in C:/Users/MASTER~1/AppData/Local/Temp/Eleventh Hour Games/Last Epoch/Crashes

  4. Your GPU has 6gb of ram so it should be able to load these textures, but its on Windows 7 with an older DirectX version and as I mentioned before I think its probably like putting high octane gas (your new GPU) into an antique car (Windows 7)… Something is not playing nice together… On windows 10, this kind of DirectX error is usually solved by resinstalling a GPU driver (safe mode or DDU) and verifying/reinstalling the game and chosing lower settings… I am not sure that is would make a difference on Win7 because of the DirectX versions and other possible Win7 concerns.

The only thing that I can think might make a difference is my point 4 above… Reduce the game settings to the absolute lowest they can be and disable all features and see if this allows the game to load the textures and launch the game properly.

Before creating the topic I’ve updated GPU driver, then, as you suggested, I’ve erased Eleventh Hour Games folder from localLow entirely(keeping Saves aside), and reinstalled the game. Then I’ve tried to run the game, without any browser running, and actually it worked fine on medium settings - at least I was able to get into the End of Times, or whatever the starting location when you log in is called. Will try to do some Monolith run, or continue the main story.

Ok… So the usual fixes still do work on Win7… I would test for a day or two more and if everything is fine, then consider closing this thread with a solution summary…

If you still notice issues, then the only other thing to try is dropping the in-game settings…