"Couldn't connect to server." with Windows 10

Hello !

I bought the game on Steam, could link the account here with Steam, but I keep receiving an error “Couldn’t connect to server.” on main menu. I am playing on Windows 10, and the only issues I could find about it were linked to people playing on other OS than Windows.

Last Epoch is also in the list of authorized programs in the firewall. I also tried the DSIM image verification that was linked in another topic.

Any ideas about how I could fix it? I can’t play the game at all since I cannot login.

Thank you in advance!

Hey there!

Thanks for supporting us. :slight_smile:

Could you please attach the game’s log file to a response so that we can look into this for you? You should be able to do so by clicking on the button and then browsing to the file.

Here it is! Thanks for your quick help!

output_log.txt (20.0 KB)

After rebooting both router and cable modem several times and doing more tinkering, it finally worked. I’m leaving this here in case someone meets the same issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.