Consistently losing connection

Ever since launch, even when I’m having no other issues, I lose connection to the game servers very often. Last playsession I had no issues logging in, no performance issues when playing the game, but I did lose connection to game servers 11 times in a 2 hour timespan.

Before launch I didn’t have this issue, online play worked perfectly fine.

I’ve tried flushing DNS, doing an IP release/renew, and I’ve tried disabling firewall to no avail.
This is rapidly destroying my enjoyment of the game so I’d love it if someone could suggest me some other things to do to maybe fix it.

1 Like

Ive been experiencing the same issues. First mostly due to “inactivity” while cheking passives, crafting, skills etc. but now it happen even when im inside monoliths.

Ive also tried to flush DNS among other things but it has not worked.

I am also experiencing lost in connection. I checked my ping and network with website tools and it looks stable. I am afraid this problem may be Last Epoch’s server end. I play in the U.S. West

I am having the same problem. It started happening a day ago. Before that I was having no issues, now I constantly get the lost connection error. My internet is fine, ping time to server is 20ms. I even tried different ISP but same issue. I am not sure if there were a patch, but something definitely changed yesterday.

They clearly don’t care, but I think this one is related: Error "Lost Connection" when switching zones - #74 by 2Dumb4POE2smrt4D4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.