Client crashes upon connecting

Hello, Please resolve the connection issues from Egypt because I really want to play with my friends on launch :frowning: .

1 Like

February 2024 I have the same problem :confused: playing in South America server, has anyone found a solution to this? Or we just have to wait to have some kind of answer from the devs? It’s sad bc I bought this game years ago and I am really hyped to finally play the 1.0 :sob:

I made it work in Egypt using Exitlag

Also from Egypt here. I’m able to get to character creation in online mode but the game crashes right after the intro cinematic. Character is still there when I open the game again, but if I try to enter the game with the character it goes to “connecting” and then the game crashes again.

I checked the player log and player-prev log and these lines were there respectively:

Player.log (90.0 KB)
“2024-02-04T08:16:56.5843589+00:00 Failed to connect to server. (IP=173.233.138.92;Port=17484)”

Player-prev.log (164.3 KB)

“2024-02-04T08:03:57.5532120+00:00 Failed to connect to server. (IP=23.109.143.4;Port=16246)”

I’m able to ping the server IP addresses but unable to reach the server through those port numbers. It does seem to be that the ports (or range of ports that the game is using to connect to servers) are being blocked.

It’s also worth noting that the game runs fine in offline mode, this crash only happens when trying to access the game in online mode.

1 Like

Just wanted to put an update here, I’ve managed to connect to the game online using CloudFlare WARP. The game is running fine, other than having a bit of delay going between zones. I hope this helps anyone else that’s facing the same issue.

1 Like

I tried it and sadly WARP doesn’t work reliably with me … Thanks for the tip though :slight_smile: … I just really wish someone from EHG just talk to us regarding this issue …

1 Like

Good morning! Mine has the same problem. Every time I try to play Online my game closes. I play in South America. In offline mode it works normally.

Hi guys, I was having the same issue and I solve it, made a post about this problem and possible solutions for you, hope it works for you too!

So … 10 days away from 1.0 launch and still no fix for this issue :frowning: !

Hello Everyone , found a temporary fix to connect to the game.

Cloudflare is working , but you have to use an older version for the game to connect , make sure you never update this version for the game to work.

Use this link App Center , search for the version 2023–3–450 , make sure to enable 1.1.1.1 with warp in cloudflare.

It should be working.

Regards,

Today, offline stopped working as well. I press offline, and it keep loading indefinitely, and nothing happens at all, it just stay there.

Edit: it was only during servers downtime, which is weird, I was trying to play offline.