Can't get past Character Login Screen

Bought the game, downloaded it, made an online character, but “connecting” just stays stuck and spins, then it eventually kicks me out. I’ve disabled all of my firewall stuff and no luck. Very frustrated, please help.

Hey there

Please reply and upload your player.log file and a dxdiag report. I’ll have a look at them and see if I can make any suggestions.

In the meantime, try verifying Steam game file integrityjust in case :slight_smile:

Steam file integrity check came back, no errors. Here are the requested files.
DxDiag.txt (105.8 KB)
Player.log (81.3 KB)

You’re on the right track with the networking issues

2023-03-31T04:08:05.9046289+00:00 Player 0 Connected (IP=;Port=7877)

2023-03-31T04:08:36.7398045+00:00 Disconnected (IP=;Port=7877)

To diagnose this sort of network issue, you can run a traceroute on Windows: How to Run a Traceroute on a Windows 10 Computer : HelloTech How

You use the command tracert and then it might show some errors such as Request Timed Out and Destination Unreachable.

You can then provide this information to your ISP and to EHG Technical Support ( for them to investigate further. More often than not, this sort of “uncreachable network” issue will be between you and the EHG servers, so you’ll need your ISP to help.

So I’ve tried connecting a handful of of times and am getting different IPs. Tracert to each one of them. All of them leave my ISP without any issues. However, any timeouts I have seen are on the last couple of hops. I’ve submitted a ticket with this information, however, not very confident it will get an answer since my last one is still stuck in ether somewhere lol.

Edit: To be clear, all tracerts complete successfully. Some have timeouts, but these are at the end of the trace.

Hey IODRIVE, maybe you can help me in a similar situation, got the game, been playing for 13 hours, with many connection issues, but at present cant make it past the character screen with the firewall off,

Verified Steam game files integrity > No issues
The game log file: Player -
Player.log (183.3 KB)

any help is greatly appreciated really just trying to play with some friends :]

You have similar errors in your log and DxDiag as other people who I’ve noticed have this issue.

One thing you could try is restarting Windows into Safe Mode with Networking.

This will minimise the drivers which are loaded, so if Last Epoch runs correctly in this mode, it would be useful for EHG to know and also may provide some indicator around which customer-specific configurations contribute to these issues.

You would also have more information as you could possibly point the finger at some drivers or software on your computer which are contributing.

1 Like

So, I’m having this same issue. Has this been solved successfully at all? I was really looking forward to playing with my friends but IF i make it past character select it’s for 10 - 15 minutes before the game just kicks me.

thanks for this ill give it a go and report my findings

shall I collect logs while in safe mode, just ran the game with safe mode and networking, and the same issue is still present took Screenshots to upload as well if need be, I can also add the build number while in safe mode, I tried loading the game and doing the steps to log into my character a few times, makes it past the load screen > character screen > same issue

Just wanted to post an update, I can create new characters just fine and play them for quite a while, but eventually get disconnected from the game server and can’t touch that character again.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.