Can't connect to server after logging in

SSIA. I login but it starts “Entering Eterra” and doesn’t go anywhere.

Hey, Welcome to the forums…

You havent really provided much info to work with here so its pretty hard for anyone to help you…

  • Are you using Steam or the Standalone Launcher?
  • Have you ever been able to get into the game or is this something that has happened after previously playing?
  • When last did you play the game? Sometimes there is a problem with older logins.
  • What operating system are you using? Linux? Windows?
  • Are you sure your internet conneciton is working properly? Is there any potential issue with firewalling? People with upstream DNS issues sometimes get stuck at this Entering Eterra point.

Without any specific information (or game player.log files) all I can offer is:

  • Make sure that your OS is updated & doesnt have any networking issues
  • Make sure that you GPU is using a recent driver (something from the last 2-3 months)
  • If you are using Steam, make sure to verify the game files.
  • Make sure not to run anything else on your system while you are trying to test LE… This includes things like graphical overlays etc. Just temporarily dont use anything.

Note - if you are a new player, there is sometimes a delay when buying the game through Steam and when you can first login - not sure why this happens but it usually clears itself after a while without needing to do anything.

You can also login to your EHG account and manually perform the LInk to Steam option and/or consider downloading the standalone launcher that doesnt use Steam to see if that works.

If you get any specific login error messages then you need to send a support request to EHG to get them to check your account. (Link in top right).

Failing all of that, you will need to provide much more information as to your setup (dxdiag output), game logs - player.log and your in-game graphics setting file (le_graphicsmanager.ini).

I was using the Steam version. I just downloaded and tried the standalone launcher, and now it works. Thanks. :slight_smile:

Ah… thats probably the odd Steam issue then or something went wonky with the Steam Linking process. Glad you can still play tho… Would be interesting to see if the Steam version works now that you have been able to play via the standalone.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.