Cannot start Echoes and randomly get disconnected halfway through if they start

Finally seeing this bug reported out in the wild. My buddy has this exact thing happening. Bumping, hope attention can be brought to this. THANK YOU for posting!!!

So after about 2 days of completely pulling my hair out trying to get this game to work, I hit a breakthrough and I haven’t had the desync issue since.

To start, I installed ProtonVPN to confirm that the issue I was seeing was not just US West, but also US Center, and US East. I made the issue happen everywhere including EU servers. I’ve been having this issue on my local home internet, and I’ve gone as far as contacting my ISP to make sure my IP address was not rotating/changing causing the random disconnects.

About 2 hours into my testing, the issue occurred and about 45 seconds after my desync issue my VPN gave me a curious error:

“Your connection has been disabled because you are using a server that does not support peer-to-peer (P2P) traffic.”

This is very concerning because I had already disabled EVERY process on my PC and even disabled my firewall, so I could 100% confirm the issue was Last Epoch.

I upgraded my ProtonVPN to turn on p2p support and port forwarding support, and I haven’t had a desync issue since.

So my theory is Last Epoch is for some reason initiating a p2p connection when something happens in the game (probably some error) and that p2p connection is likely being throttled by ISPs or some weird issue with the game client. This would explain why other users complain that when this issue happens other apps on their computer get VERY slow.

Hopefully a developer can look into this,.


I’ve also been having this issue, or something similar. When loading a new echo I get lag and most of the times everything just stops and I get disconnected from the server.
I didn’t have this issue during 0.9 launch day or the day after, but started getting this issue after that.

Bumping. This game-breaking bug is still alive and well. Please help devs! Loving your game but this makes it unplayable.

This is the exact issue im having as well.

Thanks Phoxly, this is great investigative work! What ISP are you on?

I made this post about my issue, but we should just merge on your thread. For me, I get all other apps slowing down massively, but other devices on my wifi network are fine during this time.

I think your suspicion that this is on the ISP side is good. I have sometimes seen my ISP throttle torrent traffic as well. I’m on comcast/xfinity, and I guess I’ll try contacting them tomorrow about this (if I don’t die on hold that is).

However it would also be great if Last Epoch changed their protocol not to trigger this detection, or at least worked with the ISPs directly to figure out what’s going wrong here.

All this information is much appreciated, I’m working on gathering as much data as I can on this issue from this thread and others.

Same issue. It happened randomly before but the last few days its unplayable. Was only happening in parties before but now it happens when solo as well… playing lightning mage. teleport seems to be a big trigger

I’m in the US northeast. Just spoke with Xfinity support and I think they gave me the runaround. I use an ARRIS SB8200 modem and they claim it isn’t rated for the top download speeds of my internet plan (1.2Gpbs, it’s rated up to 957 Mbps), so therefore I should rent a modem from them and then they can send out a technician. They did some diagnostics on their end and didn’t find anything wrong, even though I experienced a lag spike in the middle of one of their tests. I also experience massive bandwidth throttling with torrents, e.g. ubuntu image.

They also suggested lowering my plan to something my modem is rated for. I guess it’s possible this is a modem issue and triggers when it’s overwhelmed, causing throttling of the source devices. I’ll try to do some googling on this. But given Phoxly solved their issue with a VPN I doubt that’s really the cause. The technician didn’t seem to understand me (or was unwilling to engage) on whether xfinity does any throttling based on traffic type (e.g. p2p).

I look forward to this being resolved, though I guess the silver lining for now is I get to blame my deaths on lag legitimately.

Spent a bunch of time debugging my modem, looked at event logs, got suspicious about its downstream/upstream power, SNR, etc. Didn’t find anything too conclusive so went and tried the VPN route (paid for a month of Nord for this, ugh), and it mostly fixed everything. No big latency spikes for almost 2 hours now.

Overall latency is worse now, but still very playable. I still see minor character skips/desyncs, but they jump me back less than 1 second vs the 30s+ I had before, and they seem relatively rare. With ping to running I don’t see 2s-3s spikes anymore. I did once see an increase to 200-300ms for about 5s. Almost like the same traffic pattern causes some amount of trouble for the VPN as it did for my network without the VPN, but the severity is much lower.

Game is currently unplayable for me. I encounter massive desync in almost every echo despite my latency being 20-30ms.
Player.log (107.3 KB)

Having this exact same issue. Would love to play the game but its not worth playing 5 min at a time and having to fight against the servers.

After switching to VPN on Friday, had mostly no issues playing until Sunday evening. Worst lag spikes would be up to 200-300ms. But since Sunday evening, even on VPN, the issue is back just as bad as before (3s+ lag spikes, triggered by loading a monolith or within a monolith). Not sure if this is dependent on VPN server chosen or something else, but I couldn’t really resolve it by reconnecting. I don’t think our household internet use was changing during those times.

I’m trying it with VPN (also Nord) and same issues as before. This is super frustrating, I have lost 100% of my arena Keys to this

Even worse today, can’t even complete a single mono.

If you find anything new about those issues you can contribute here: network-lag-issues-megathread

Still required to use a VPN or get perma desync’d 15 minutes in.

I experienced this after a recent firmware update to my firewall. Couldn’t figure out what was going on for a few days until I was randomly going through my settings and found that P2P was set to block on my firewall. I turned that off and have not been disconnected since then.

1 Like

What’s crazy is I asked the devs in discord if they use P2P at all and they said no, yet it’s clear that using a P2P VPN or in your case enabling it in the firewall fixes the issue.

I mean if the devs want proof I have FW logs showing that there is P2P blocking from their servers when I was getting disconnected