Buying prophecies sometimes buys the wrong prophecy

Happened to me on my very first prophecy I picked. I selected a 450 favor cost prophecy with set item as a reward, and instead I received a different prophecy, it cost 500 favor and the reward were some rares.
It happened on the south telescope (Mesembria), I don’t remember which celestial thingy was displayed.

1 Like

Happened to me as well. so far 2 out of 2. really frustrating when joining and wanting to try it out only to get random prophecies in content you didnt want to do with rewards that you didnt want.


Same here, bought a prophecy with unique rings as reward, and got a prophecy with set rings as reward. Next time I’ll record the screen when I’ll buy prophecies.

1 Like

I can confirm this does not cause the bug. I got the wrong Prophecy when selecting a very basic campaign one I had access to (The Alchemist - Diamond Matron kills).

I didn’t even know you could click N S E W to change item types, so that definitely doesn’t cause the bug. I’ve purchased from Idols, and from Armors, both without and with a lens. Both bugged.

I’m 0 for 2 so far. Does it give y’all the wrong thing every time, or just occasionally?

1 Like

Still a problem. My new character just wasted almost 10,000 favor on useless prophecies. Instead of the newby friendly ones I picked, I got tier 3 and tier 4 dungeons (with a ‘no dungeon’ lenses in every telescope no less) and a 220 corruption monolith boss. Almost all the favor I built up over playing through the campaign spent on stuff that’s going to be useless for a long while.


I did some analysis and I have 2 theories. Possibly circumstantial but after the 1st two Prophecies bugged out, 4 in a row have now worked.

Theory 1: Only the Mesembria Telescope (jewelry) is functioning properly. It’s the 1st telescope encountered, situated between stash and waypoint. Likely the one used by 99% of players. Use only this telescope, and rotate it to whichever item type you want.

Theory 2: One of the checkbox options causes the bug. My results:

  • 0/2 with On/Off. On for Always show reward icons, Off for Disable confirmation windows
  • 4/4 success with Off/On, the opposite.

Try things out and let us know how it goes!

Late edit: Sadly I’ve debunked both theories. 0/2, then 9/9 worked, but 0/1 now. Got the bug again and don’t know why. Only pattern is I’d bought Jewelry 5 times in a row and just now switched to Idols, but probably coincidence. Edit2: hmm actually I might have absent-mindedly walked to the Idol telescope instead of stick to the Accessory one. Theory 1 may still be possible.

1 Like

This happened to me twice already.

1 Like

I just ran into this bug.
First I ran into the failure to purchase bug.
So I found another prophecy to purchase. Purchased it, and noticed that more favor was spent than I expected. Checked prophecies and it turns out I received a different one than I had purchased - one I did not want at all.


Yep, still a thing. I just unlocked the Circle of Fortune. Bought my first prophecy, turned into a completely different one. Thought I was too stupid to buy correctly or prophecys had a weird mechanic, where they would sometimes change, because, you know, divination is not an exact science.
Googled, found out it is a bug.
Second time around, double checked I clicked the right things, still turned into something completely different. So 0/2 so far for prophecys :frowning:

1 Like

Same thing happened to me. My very first prophecy ever too :frowning:

EDIT: I have been trying to use only the accessory telescope and use the W/E/N/S buttons on screen to cycle through the rest telescopes, as someone else mentioned, and i haven’t had this happen again. Not sure if its 100% ok like this but it has worked for me

Same here two time in a raw bought a prophecie, and yep not given the one I choose… Completly broken mechanics… fix your game please, and I like to stop to be the invisible drood also .

This just happened to me with my first prophecy purchase for the quest for joining the faction.

Was very confused!

I’ve also had this issue. First prophecy I bought didn’t even show up. The second one was completely different from the one I chose.

How is this ginormous bug still not fixed 2 weeks into release?
Bug severity/prioritization needs to be a thing!

1 Like

Just happened to me on my very first prophecy. Bought one for 2 unique helms and got one for an exalted armour in monolith, which I can’t even access yet.

glad im not the only one. This should really be high on the priority list to fix. so much wasted favour.

Currently 0/4. Frustrating to say the least.

1 Like

This bug is still ongoing. I just reached endgame and started using prophecies and only 2/7 actually gave me what I purchased. I understand if it was just failed and gave me the points back, but to give me a random task that is not even useful for my class or build makes it a waste of time to do until it’s fixed.

Dumbfounded this core system remains broken 4 weeks into release! Maybe they are stuck in an Early Access mindset?

Dreams I had that LE might compete for top ARPG sadly evaporated. :cry:

1 Like

I just had this happen to me. I chose an exalted wand prophecy for campaign and somehow have a unique mace prophecy for soulfire that i dont want.