My Account
× My Account Forum Buy Now

Last Epoch Forums

Black display on Linux

Sometimes the screen goes black.
I’ve seen this happening when starting a new game and sporadic during game play.
I assume it has something to do with the graphics so I’ve tried turning on and off some features and changing the resolution but without any luck.

My specs:
Linux 4.19.36-1-MANJARO #1 SMP PREEMPT Sat Apr 20 22:05:46 UTC 2019 x86_64 GNU/Linux
GeForce GTX 1060 6GB - NVIDIA Driver Version: 418.56
8 GB Ram

I can not find any logs but I will try to run the game through the console to try to reproduce the error and have some output.

No output in the console but I found the log file in Linux:
/home/‘name’/.config/unity3d/Eleventh Hour Games/Last Epoch/Player.log
Uploaded my Player.log:

I see maybe a pattern, right before the screen turns black, the light from e.g. campfires starts to flicker… strange
I hope it helps, will try to get more info.

I’m having this problem as well. I’ve noticed it doesn’t always happen in the same area either. Yesterday half the council chamber was blacked out, today it was all fine.

@hickin Are you also experiencing the game crashing to desktop when loading new areas? Happens quite a bit to me, unfortunately.

OS: Manjaro Linux
Kernel: 5.0.9-2-Manjaro
GPU: NVIDIA GeForce GTX 1050 Ti 4GB
Driver: NVIDIA 418.56

I would say the same, the place isn’t the same but after say 20-30 minutes in the game play the light of torches and campfire seems to stop and start showing light like someone turns on and off a light switch several time.
Then it goes black a couple of times then total black, at least for me.
I think I’ve had a couple of crashes but my guess is that there is some memory leak that causes this but we’ll see.

Also, the Player.log grows very very quick. Mine was over 1.2 GB text file.

I’ve not noticed the light switch effect, I’ll pay more attention next time I boot up the game and see if I get the same. Right now the crashes are kinda killing my motivation to play because when I reload the game I always end up a few stages back from where they happen and all the gear/items I found are gone.

Here is my Player.log -

edit: I had shadows turned off is why I never noticed the flickering, just had it happen after enabling shadows and it does look like someone flicking a light switch really fast. Game then crashed when I tried to leave the area. Updated my log file.

Problem still persists on new patch. This was followed by yet another crash.

Hmm I haven’t had any problems after last post.
I think I turned on antialising - fast and after that I still haven’t had any trouble.
Have you tried anything like that @clashrep?

Happens on both Fast and Slow setting for me. Just ran around for a bit with AA disabled and didn’t get the black screen. Hopefully that fixes it for now fingers crossed . Funny that enabling AA fixed it for you and disabling seems to have for me.

Thanks for the tip in the right direction @hickin!

edit: Of course I spoke too soon, still get black screens :frowning:

And what settings on V-sync @clashrep?
You mentioned that once the game started up black when entering the world, I had that problem as well once.
Also the error occurred at different times and at different places, just to make it clear.

V-sync disabled.

I’ve not had the game load into a black screen, but yeah it’s always in a different area and seemingly at random. It’s like if I’m moving to the right and I get the black screen I can move back to the left and it will go away. Start moving right again and it’ll go black when I cross a certain threshold. It used to be that I could move past it by just keeping going through the map, the black screen would go away, but since the 0.7b patch it’s always followed by a crash to desktop (have a bug report open about the frequent crashes I’m experiencing as well), which wasn’t the case before. The last time this happened it deleted my character.

edit - specs / log in case anyone from eleventh hour sees this:

hardinfo_report.txt (30.6 KB)

I have noticed this as well, it looks like we all have nvidia gpu’s to. The flickering also crashes my game when certain bosses or foes use electric attacks. This happens on the latest patch 0.7.0d.

I was able to stop the black screen and crashes by setting all graphics options to very low. Hope a proper fix for this is coming soon though.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.