Beta 0.9e Patch Notes

100% this. I’m really digging the game but getting bounced around while moving, not even using the skills, is really jarring :confused:

What I’ve noticed is that it seems to trigger from having a queued movement. So if you are holding force move during the Lunge/Shift you will get stuck.

Brand of Arcanus still broken with Galvanize?

Noticed a visual bug with the new patch, if you level up multiple skills. When you go to the skill tree of the first skill, visually the skill points for the other skills disappear, you can still spend them, but it says you have 0 to spend and no (1) on the icon.

It usually happens to me when target monster is using some sort of movement ability just as I’m about to Lunge to it. Also have been stuck several times to monsters that “spawn”, like coming from under the ground or flying from the sky, sorry, can’t remember actual names.

This was driving me crazy. Thank you for fixing this :slight_smile:

I tried to replicated lunge bug and only happens to me when I lunge offscreen as you can see in this picture, no monsters in screen and it just stop moving. Mouse was in upper left corner.

I am not sure if this is the place to ask this question but I am depending on nvidia geforce now to play the game. After patches 0.9c and 0.9d the game was in patching state for 20 hours. I played a bit after it came back to playable state, than 0.9e come out and I guess it has been around 8-9 hours since its release. Game is still on patching state on geforce now. Maybe this is a local problem. I live in Turkey and we have a different provider for geforce now. Maybe its different on eu servers I am not sure.

Best regards.

Thank you guys for the awesome job in the last patches going on from the 0.9 launch. Im really impressed with the amount of work you guys can put together in such a low period of time. Keep it up!

It also happens when targeting areas where an enemy is going go appear when you get closer (coming from ceiling or appearing from the ground)

Was always on enemies, in MP if it died on the way to it, you’d get the stuck animation

Any update for The Immortal Empire quest line yet? We can not proceed any further as the mobs do not spawn after talking to the Seer. Would love to love able to continue past this point.

Backapack when ?

Go to, login with Steam and claim it.

1 Like

I have been unable to connect into my character or into a new character ever since 0.9e patch. I have tried a bunch of stuff but nothing seems to help.
Any idea what might be causing this or how to fix it?


Same here

Settings reset with new patch yay… now I’m realy awayke while my sound system went into overdrive and i haven’t hit the mute button fast enough.

I can confirm lunge is not activating on enemies that pop up from the ground, it consistently freezes up on them, like worms and such.
It’s hard to catch because you have to be holding the button down off screen and it land on an enemy that was going to come up from the ground.
Working on breakables now since the patch fix.
Haven’t tried it against the enemies coming down from the ceiling like the spiders, but I assume it’s same, just undetectable enemies until they reveal or something.

Also it’s still consuming both charges if you have 2 so please keep looking into that, thanks for all your hard work.

This is happening on enemies which are either hidden until approached or are on the screen edge/offscreen which seem to be dormant because of performance reasons I assume.

I was able to “test” if there are mobs in the ground in front of me with lunge (it would freeze me) and then go to the place and the mobs would start their animation and come out of the ground.

I think this effect would be more prominent for people playing on widescreen monitors, since a friend told me he could see the dormant mobs standing around on the extended edges of the screen where a 16:9 screen would have ended.

The game is great and I continue to be excited for the future of it! You are doing a great job!

This still doesn’t fully explain what’s happened. If this was true, Flame Reave with Rhythm of Fire up on the current patch should be the same size as it was at all times in 0.9. But currently Flame Reave with Rhythm of Fire up is ~50% smaller than it was in 0.9, and ~75% smaller baseline.

Someone posted pictures on reddit here

It definitely feels smaller than it was in 0.8.5

1 Like