Bad performance without any seeable reason

firstly ive skipped the last main patch so my last performance comparision will be a bit older.

The problem:
Low fps (if im lucky its at 50fps normaly more like 30) and framedrops (99th percentile below 10fps)

System:
OS: Windows 10 21h2
CPU: Threadripper 1920x (12core 24threads @4.1ghz)
Ram: 32GB 3000mhz
GPU: RTX 3080 (440W tdp @2000mhz and 10000mhz memory)
gpu driver: 511.65
Storage: System and LE on nvme SSD Raid (3tb of samsung ssds with over 9gb/s read and write capabilities and responsetimes while ingame of at most 2ms)
mouse: pollrate reduced to 250hz while playing as it also caused me major performance issues in the past
System is rockstable for years never had any performance problems (aside from known things that are just on the games sides)
monitor: 2 monitor both at 1440p (the one running LE is at 165hz)
Temps are as you would expect from the hardware (not cool but far from tjmax)

Situation:
the performance this patch is far worse than what i know from LE.
normaly i notice this performance in the endgame or during heavier fights but this baseline is while standing on a teleporter in random earlygame regions on a new char.
the settings do not seem to matter in terms of performance.
My GPUs memory seems to get blasted with data (about 9gb/10gb) (i know this does not have to be a problem)
GPU core at about 40% no matter if ultra or low settings
No cpu core is getting high utilization (even splitted le from the rest of my system using process lasso seeing the highest thread at about 50% (12 threads for everything else 12 threads with only LE running on them))
Ram seems fine (2gb of LE and lots of reserves)
storage is taking a nap right now.
dxdiag looks fine.

im completly sure i forgot a lot that i tried while writing this. sry about my errors im not a native english speaker. I know IT problems well so dont worry to ask about heavier tasks to gain more data.

edit: removing the overclock does not change anything

1 Like

Player.log (51.4 KB)
added player.log

Not an EHG employee, but can try to help… got to go out shortly but here are a few things:

  1. Assume you have done a file verification through Steam?
  2. Can you post the output of a dxdiag report - seeing what you have running could help and the diagnostic section at the end may have something to work from.
  3. Are the GPU drivers running in default mode - i.e. no special settings enabled that could be overwriting or conflicting with in-game settings?
  4. Any other applications running while testing LE… there are lots of known issues with apps causing problems with Unity (the game engine) so its best to temporarily disable or not run anything (*including things like Steam Overlay etc).
  5. Have you tried different window options - Fullscreen/Borderless WIndow/Window to see if anything makes a difference - there was a problem with 3080s about a year ago where this seemed to help for some.
  6. You say LE is using 2gb of RAM? thats too low… normally its triple that…

The player.log shows no performance related issues that I can see (not EHG dev) but there are a few NullReferenceExceptions and some Dictionary key issues… These are unlikely to be performance related but they could point to something if the game is struggling to deal with these exceptions while playing.

Got to go for now… will look back here later…

  1. yes
  2. attached below
  3. yes nothing special besides G-Sync (and high performance preference)
  4. other than browser/spotify not
  5. did nothing for me its borderless window for now
  6. that was strange for me as well as i remember it normaly taking about 7-8gb
    DxDiag.txt (121.8 KB)

another small addon the performance seems fine until the first kill after that it does not recover also it seems like the 2gb ram was something strange on top now its taking 4.2gb

it seems to be back to 2gb ram mode. i have no clue why (ram is at 50% overall but im also doing stuff on the side)
i would say this is likely a major cause for my performance issue.
edit: i even saw under 1gb after writing this comment with far higher gpu.

new log after complete reinstall:Player.log (32.7 KB)

Ok…

Memory usage - you made me doubt myself so I had to check again and I am getting LE process using 5gb usage just stand in End-of-Time. If I go somewhere more active like Majeka Upper District, I get 5.2gb. and thats on 1080p, with Very Low or disabled quality settings… If I change everything to Ultra @ 1080p in Majelka, the LE process uses up almost 11gb ram… and maxes out the 3gb Vram I have on my 1060.

This is probably due to the game moving more assets to your GPU Vram (because you have more) but this should IMPROVE performance, not make it worse… This would then explain why the process is using less normal RAM but not why the performance is less.

So I doubt that this is the cause of the problem - unless there is something odd going on.

The new player.log doesnt show me any of the usual performance related errors that I would expect to see if someone was having issues - at least none that I recognise from other LE logs…

GPU usage on 40% no matter the settings could point to some sort of CPU bottleneck - LE isnt going to use your 12 cores so its possible your 3080 is bored no matter the quality setting. In fact, I would test and set LE to only use limited processors - just to see if this is indirectly messing with something - shot in the dark but hey, this is an odd problem you are having.

Gsync - I am wondering if this has something to do with it… LE has issues with Vsync sometimes and perhaps there is something going on between gsync, LEs framerate and your high Hz monitor … Not sure of a logical way to test to see if this is involved tho…

Shouldve asked for this before, but what settings are you using - post le_graphicsmanager.ini.

Just for giggles, what happens if you set the game on 1080p, 60fps framerate limited (in-game and no vsync/gsync) with all quality set to very low or disabled. You should get a flatlined 60fps at all time on your 3080. If you do, then take this up to 120fps and see - it should be flatlined at 120 too… If not then there really is something fishy happening because I can get 60fps on my old 1060.

Another thing… just as a test… disable Audio in-game and see if this makes any difference - just to see… The reason I am asking this is that you are using virtual audio devices (for the Oculus) and virtual audio links used for passing through audio for streaming etc has caused some odd issues with other people in LE… The driver is still there so testing with no audio is just an idea.

As a final check, please watch taskmanager when you launch LE and see what else is running - I know you said just the browser and spotify, but maybe there is some TSR/service running that isnt needed that you can disable to see if it makes any difference. I suggest this again because there are lots of examples of this kind of thing messing with games… For example Citrix messes up LE… Just had to solve a similar issue with Discord messing around with my kids CoD performance… So there is always a possibility something running in background is messing with things.

Cpu limit is already present from testing (limited it to the 2nd compute die so 12 threads that only LE can access. (helped a bit but still no core limit as the highest one is at about 50%)

disableing gsync and setting the monitor settings to 60hz didnt change anything.

im changing settings around a lot right now so its ultra for now as it doesnt change a thing regarding performance le_graphicsmanager.ini (476 Bytes)

on 1080p everything low i gain about 3 fps in the short blurry test (brrrrr)

disabled sound does nothing (but its quite quiet)

i killed like everything and tried starting it then but no diffrence.

it also seems to get better in higher level regions so it seems that some maps are effected diffrently.
all tests done on ruins of welryn teleport point

edit: ram just seems to be strange. it goes up and down like it wants and does not make any sense :smiley:

This makes no sense… as I said, I get better than that on an old 1060 GPU… There has to be something happening here that is causing this… Something must explain this - you should be getting anywhere from 150 to 300% faster performance than a 1060 - and thats most definitely not 3fps…

Did some googling and was surprised to see how many people are complaining of underutilisation of the 3080 GPU presenting as low / poor fps in various games … Was reading around on the Nvidia forums & elsewhere… and there are various complains similar to yours - i.e. expected performance not matching what others are getting and GPU usage % low but performance not on par with what is expected… Complaints like “low fps, but CPU & GPU usage show they are doing nothing”

I’ll quote a few here - maybe something here hits a cord with you as a possible solution? Note, I have no idea if any of these are valid or not - just copy pasting some of them that might be useful.

Solution: I uninstalled all graphics drivers and GeForce Experience - slight improvement
Disabled G-Sync and saw instant improvements
Disabled DirectX 12 and HDR in game - fixed entirely.

The 3080 is intentionally lower in performance by design of its power management partioning.
If you want higher fps, use a higher resolution or settings

Randomly try the new nvidia tuner and lower the voltage / power by just a tad to see if that helps for a reason. Seems like people are running into issues when it tries to reach for boost clock speeds that are too high. I’ve seen a report of someone with performance issues and undervolting/clocking helped stabilize

Well i found out the culprit, it wasn’t the drivers. The culprit was that the “optimized” settings that i turned on from Geforce experience turned on DirectX 12 and that caused the ridiculous 20 fps on ultra. DirectX12 is smooth on low settings though. Anyhow now i’m getting stable fps with DX11.

Check your power connectors & see if the GPU is getting sufficient power to reach the correct and expected clock speeds

Check your GPU Clock speeds - sometimes its running at well below spec - e.g. 300Mhz due to some sort of config change / auto setting. Clean driver install with defaults can help.

Double check XMP

1 Like

yeah i know about these problems. as far as i know most of them were caused by early drivers or overheating memory. i only had problems with new world (but to be honest thats to be expected with how the hardware means nothing in that game)

after running further now i noticed that its completly region dependent some regions average about 30 and i even had some at about 120 fps so i have no clue how to “troubleshoot” the bad ones and to be honest i cant think of any way a “non dev” can help here as it seems to be something deeper down the region (rabbit) hole.
another thing ive noticed is that LE draws a lot of tdp in higher performance areas (saw 350w on 60% util (that means the gpu is pulling 350W not the entire system))
edit: the 120 fps and 60% util was seen on very low preset (what is INSANE)

this is really hard as non-devs to figure out, but maybe it will help somehow by confirming to the devs what has been tried / failed etc…

my concern with the region issue is that I can go to welryn like you and I dont see the same fps issue on my 1060… I have virtually the same performance everywhere on clear maps (i.e. no mobs to affect performance)… in the past there have been specific maps / areas that caused FPS issues but those were repeatable for everyone so it was easy for the devs to deal with…

LE drawing a lot - yes, LE will attempt to max out a GPU - sometimes for no apparent reason… Just watch your GPU usage while opening your inventory & stash at the same time… Unfortunately things like no FPS limits seems to let LE run away with itself and cause freezing, stuttering and in most cases, eventual crashes… Setting a limit in-game (making sure the limit is enabled and set) helps for a lot of players - including stopping fps spikes etc - but in your case, what you are experiencing is not even getting to any limit levels for your hardware - a 3080 running at 60fps in 1080p is just silly - even considering LE is generally unoptimised…

Wish I had a silver bullet to offer but not having the hardware to mess around myself, not being a Unity Dev or any other insight its really hard to speculate much more than the ideas above…

id love to see my hardware maxed out and im not irritated seeing 350W being pulled or even the full 440W but on very low with about 120fps at most that seems brutaly high for me :smiley:

if i wouldnt know it better id say the region is just badly optimized or the file is broken, but as you said you can go there and its fine and on top ive reinstalled the game entirely and even validated my files earlier so there shouldnt be a way they are broken the same way.

also i dont have problems in other unity games (besides the ones that are known in the games) so i cant say my pc works bad with unity either. im just completely clueless.
if you have ideas to mess with the hardware just write them. i have no problem with causing my pc to be in bad states (on my 980ti i had to flash the gpu bios blindly as the card wouldnt initialize anymore)

You can try memtest to rule out errors in RAM. You can also check SMART statistics of disks or even run performance and surface test.

my storage is automaticly monitored by the raid controller (thanks amd) and there is no hint of it being a memory problem with my hardware.

manual checks didnt indicate any problem with ram or my storage

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.