Alric's Revenge Quest

Regarding the above bug. Three days too late to add to it.

This has now happened to me twice. First time I asked about it on Discord (didn’t know if it was my missing something or a bug). Forgot to check here.

Just happened again. Same exact parameters. Go into the quest after first arriving and talking to Alaric.

Usually in this area:

you fight the enemies and when they die you hear the scream of rage and the quest boss appears above in this area:

As the user in the last post on the previous report mentioned, restarting the game and doing the quest allows you to complete it.

Correction. I spoke to soon.

First time this happened last week a restart worked.

This time I restarted. Went back to Alric, did the quest, same result.

Not sure what the trigger parameters are but I also cleared the entire level just to make sure.

In my experience, running through the level killing everything to the section just below where the boss spawns (the bit that goes down the ramp to the left) is enough to get the boss to spawn.

On the second try on each attempt I cleared the entire floor. That didn’t work on the second occurrence.

I also will note that logging out to the character screen and coming in did NOT seem to fix it. I actually had to quit the game and restart.

If this is a matter of killing a certain amount of enemies, maybe a counter can be added. I actually sometimes feel the same way on those Echoes that say kill enemies to find Boss Bad Guy. But it’s not nearly as bad on those because the count needed seems to be a lot lower than what they level actually holds.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.