Wengari Battleground - can't finish quest (lvl 80 timeline)

What went wrong?

After unlocking lvl 75 timeline I’ve tried to unlock lvl 80.
I was a bit sleepy, so I went directly to ‘A brand of frost’ leader and cleared out the are (including the imperial watcher).
Then I’ve realized I’ve got to fight monsters a bit earlier before.
Did that - came back, couldn’t talk to Frost pack leader.
Cleared out lvl 75 timeline leader monsters thinking it would fix something (I didn’t unlock lvl 75 timeline in dialogue), but when I came back the lvl 80 leader was gone.
Did I kill Imperial Watcher too early and quest bugged out?
I don’t think it’s working as intended.

Screenshot https://i.imgur.com/mEurBqt.jpg
Log file: Player-prev.zip (483.0 KB)

Update: I’ve reproduced it by killing Eye of Formosus before helping Wengari’s at the start of quest / while marker is not at camp - can’t progress on quest. https://i.imgur.com/gCcDK6O.jpg

I’ve ran it third time and helped Wengari’s and then lvl 80 leader and it worked :slight_smile:
It’s not a big thing, but can be annoying. Good luck with the 1.0 release!