My Account
× My Account Forum Buy Now

Last Epoch Forums

Weapon disappeared on right click equip

In The End of Time I was at the test dummy after having the forge open, went to the dummy to test which weapon to upgrade, and when I right clicked to change to the other weapon my equipped weapon disappeared. I thought it was deleted, but when I went back to the forge it was there.

Hey there, Welcome to the forum…

Is there any chance you can repeat the process and document exactly what you did step by step so that the devs can replicate the issue internally?

e.g. I tried your description and it doesnt mess with me so perhaps there is a specific sequence you are using?

I tried to repeat it, but don’t seem to be able to now. Maybe unique to the weapons somehow or I did something I didn’t realize. I was using a glaive and a greatsword both rare quality (yellow).

  • I had been putting the two weapons into the forge to compare upgrade options

  • One was my current weapon so I re-equipped it and then tested that one first on the dummy

  • Then I pressed ctrl (or something else) + right click to swap the weapons and that’s when my weapon disappeared and I found it in the forge.

I later realized I only need to right click to equip but at the time I thought it was two keys.

Ok…thankfully this is not game breaking so there is time…

If if happens again and you remember your exact steps, please post them here…