Way, WAAAY too buggy on Linux

I’ve barely played the game so far and already encountered massive issues on Manjaro Linux. For reference, I’m running on Manjaro with KDE Plasma using and AMD GPU (i.e. extremely close to a Steam Deck setup). A number of issues, all of which have been reported months if not years ago and yet not fixed:

  1. The character creation / selection screen is covered in a thick purple fog, we can’t see the characters.
  2. The log file is spammed with errors about not finding some dll relating to the logitech RGB library. Within tens of minutes, the log file inflated to ~200MB in size. This can reduce the lifetime of SSDs, please please fix this.
  3. The button to disable the logitech RGB stuff works but doesn’t visible toggle off, meaning it will look like it’s stuck on ‘enabled’. There are bugs inside of bugs…
  4. I am required to run the game on Ultra. If I run on the game on settings that are any lower, then none of the map textures display as well as the map outline.
  5. (quite minor) I had to restart Steam after Last Epoch downloaded to get it to run. This isn’t the only Unity game to do this but it’s quite a nuisance if you don’t know about it.

Linux support is advertised but from what I can tell it is extremely barebones. After some troubleshooting it works but I’ve had to really hunt through the forums. If anything please fix #2, this really can potentially kill SSDs and is quite serious. Someone already filed a bug report for all these issues but I just wanted to highlight how hard it is to get an enjoyable experience on Linux.

Hey there,

Flavour of Linux wise, LE is only really supported on Ubuntu and its variants but you are right about certain bugs. One thing that is very important for Linux users is to find the correct combination of drivers and api versions that work - some people have better results using Vulkan, others Steam native mode etc. It is VERY specific to each setup. Even specific combinations of driver versions (even subversions) can make a huge difference to performance.

  1. Purple fog - thats a known issue only for Linux users. Hasnt been fixed yet but isnt gamebreaking.

  2. Logitech issue is a known problem and it causes huge instability on Linux if not disabled properly. Honestly, having helped out with tech support, I had hoped they would fix this in 0.9. The logfile size causes a similar problem on Windows so its very important to fix this error as once the logfile gets too big, the game can crash and do some VERY weird things.

  3. The logitech button issue is a known problem on Linux and does occassionally happen on Windows too. It is an update problem with the UI. i.e. you toggle it but the change isnt represented in the UI so you keep trying to toggle it and end up reverting the change. The trick is to change it, close and then reload and check the status on the UI again - doing this once or twice with checking the logfile is tedious but usually successful for most people.

  4. Required to run in Ultra - thats a first I have seen anyone say that on LInux. The Map outline issue happens occassionally but hasnt been linked to quality mode that I know of. Map texture issues on Linux, if I recall correctly, are very driver & api choice dependant. It may benefit you testing things other than Ultra to see if this is the case for you.

You can search through the tech support and bug forum to see Linux specific issues - unfortunately there is a larger proportion of problems on non-Ubuntu linux, but there are solutions for various items - including the logfile/logitech issue I mentioned above.

1 Like

hey, in addition to vapourfires suggestions, i think for now its just better to run the game through steams proton. there hasn’t been any linux specific fixes in years (last linux mention in patch notes is from 2020).

thanks for pointing this out, didn’t knew this.

edit: just checked proton db. Users suggest to set some launch options, so take a look there.

edit: i fired up my arch install and tried linux native and win version through proton. the funny thing is, the button to toggle logitech RGB support actually works visually with proton but skill vfx are causing frame drops. linux native ran a bit smoother performance wise.

1 Like