Vulkan renderer for Linux client


did you ever experiment with exporting the Linux client to Vulkan from Unity instead of the currently used OpenGL? Maybe even offer the possibility to switch between the two in the menu in case one works better than the other for certain GPUs? Though this would probably be a lot of overhead for small returns considering the Linux player base and diverging from options in the Windows client.
It seems most development is happening for the different vendor’s Vulkan driver on Linux (could be wrong).
Also maybe this fixes the shader issue on the character select screen.

Thank you.

1 Like

Trying out the 0.9 beta under Linux right now (Manjaro, Mesa 23.1, Latest GE-Proton and a 7900XTX). Runs fine, but I need to set Screen Space Reflections to “Medium”; anything higher than that gives me flashing textures.

Native client straight out crashes right now :confused: And yes, Vulkan would be awesome.

1 Like

May be worth trying to run the application directly instead of pressing the Play button in Steam.


Yes, running the game like that works. Thanks for the tip, still needs to be fixed though, and as the OP said, it’d be nice if Last Epoch used Vulkan instead.

1 Like

Apparently there’s a -force-vulkan command line option you can use. It fixes the character missing texture problem, but it causes other issues like other missing textures in-game. It’s fun to play around with though.

Allegedly, forcing Vulkan with -force-vulkan as a launch option works but it just crashes for me, with a Vulkan - Out of memory! error message (this seems to be a known issue with Unity and Linux). I also see loads of shader errors on the Player.log. Native client with OpenGL works well, apart from the missing character screen graphics.

Works fine here on amdgpu. Thank you. Purple login screen is fixed but item icon background in the inventory is transparent.
But other than that no issues so far using Vulkan. Runs great though I can’t say if it runs faster than OpenGL or not.

I played some more with -force-vulkan and except for the item icons having transparent background everything works fine as far as I can tell.

There are a couple “WARNING: Shader Unsupported” entries in the Player.log I attached not sure if related to the transparent icon background. If this could be fixed that would be great.

OpenGL had some issues recently (not sure if because of game updates or mesa updates) where the whole screen at first flashes black and white and eventually stays this way
so running with vulkan is a welcome alternative.

Edit: I also created a small video showing the bug running with vulkan:

Player.log (3.5 MB)

I don’t get it. This is the first game I’ve ever played in Linux that has different behavior for each player.

Many report that they play it with proton. Tried proton I get 30FPS max

I tried native (no tinkering) and I get 120-170 fps. Runs perfectly, besides the problem with character creation screen where the characters are invisible.

I tried the -force-vulkan option and I get 30 FPS max again.

So for me the best option is play it native without any tinkering command in steam properties.

My specs:

george@ryzen:~$ inxi -SPARM -GCDN -v1 -xGCRS
  Host: ryzen Kernel: 5.19.0-41-generic x86_64 bits: 64 compiler: N/A
    Desktop: Cinnamon 5.6.8 Distro: Linux Mint 21.1 Vera
    base: Ubuntu 22.04 jammy
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B350-F GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 6042
    date: 04/28/2022
  Info: 8-core model: AMD Ryzen 7 5800X3D bits: 64 type: MT MCP arch: Zen 3
    rev: 2 cache: L1: 512 KiB L2: 4 MiB L3: 96 MiB
  Speed (MHz): avg: 2199 high: 2200 min/max: 2200/4549 boost: enabled
    cores: 1: 2195 2: 2200 3: 2200 4: 2200 5: 2196 6: 2200 7: 2200 8: 2194
    9: 2200 10: 2200 11: 2200 12: 2200 13: 2200 14: 2200 15: 2200 16: 2200
    bogomips: 108599
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    vendor: Sapphire driver: amdgpu v: kernel bus-ID: 09:00.0
  Display: x11 server: X.Org v: driver: X: loaded: amdgpu,ati
    unloaded: fbdev,modesetting,radeon,vesa gpu: amdgpu resolution: 1920x1080
  OpenGL: renderer: AMD Radeon RX 5600 XT (navi10 LLVM 15.0.6 DRM 3.47
    v: 4.6 Mesa 23.1.0-devel (git-4ac56e3 2023-04-09 jammy-oibaf-ppa)
    direct render: Yes
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
    bus-ID: 09:00.1
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 0b:00.4
  Sound Server-1: ALSA v: k5.19.0-41-generic running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.99.1 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    port: e000 bus-ID: 04:00.0
  Message: No RAID data found.
  Local Storage: total: 7.28 TiB used: 1.49 TiB (20.4%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
    size: 931.51 GiB temp: 35.9 C
  ID-2: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB
  ID-3: /dev/sdb vendor: Toshiba model: HDWD130 size: 2.73 TiB
  ID-4: /dev/sdc vendor: Toshiba model: HDWD130 size: 2.73 TiB
  ID-1: / size: 313.91 GiB used: 53.05 GiB (16.9%) fs: ext4
    dev: /dev/nvme0n1p4
  ID-2: /boot/efi size: 96 MiB used: 48.5 MiB (50.6%) fs: vfat
    dev: /dev/nvme0n1p3
  Processes: 384 Uptime: 11m Memory: 31.25 GiB used: 3.06 GiB (9.8%)
  Init: systemd runlevel: 5 Compilers: gcc: 12.1.0 Packages: 3018 Shell: Bash
  v: 5.1.16 inxi: 3.3.13

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.