"Volka's Razor" passive does not work at all with shatter strike

I am using shatter strike as my attack skill, building up stacks of frostbite for dot damage. It currently costs 10 mana and I got the passive skill Volka’s Razor in the spellblade tree. This passive point is supposed to increase all melee elemental damage as well as damage from the ailments they apply like frostbite. There is no increase in damage both flat and dot from getting the passive.

Linked a quick video giving an example of what I’m talking about. (You can see slight damage fluctuations which is natural given the range of damage for the attack.) I even tried adding 150% elemental damage bonus from gear instead of the passive, and that gave me a big boost in damage, but not the 150% boost from the passive skill, which it should have.

Link to video example: Volka's Razor passive not working - bug - YouTube

Could you try taking 1 point out of Icy Flow & see if it works then?

So I took a point out of icy flow, resulting in shatter strike mana cost reading 11 on the skillbar tooltip and that fixed it. I guess when it read 10 mana cost which should work with Volka’s Razor, it must of actually been ‘9.8’ mana cost or something and just rounds up for the tooltip? Thanks for the suggestion, I can rest easy finally

Well, if you only had the 50% mana efficiency from the Icy Flow node then that would take you to 15 / (1 + 50%) = 10, so if it wasn’t working with a skill that cost exactly 10 then that would be a bug. If you had any other mana efficiency (which I think they removed a while back) then that would drop it below 10 which would prevent the proc.


Well, I guess it is bugged then cause I don’t have any other mana efficiency anywhere except for Icy Flow in the shatter strike tree

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.