Unlocking Empowered Black Sun Timeline

So I ran a few resetted it and nothing happened. On the map its still only show lvl 68 tho both fall of the out cast and ending storm show 55/100 and 80/100 respectively. Not sure what;s happening :frowning:

Do I have to complete the empowered fall of the outcast first? Since it got 55/100 I have’nt run the empowered version of it.


No, you just have to click on the “chest” thing that unlocks the empowered version. I can’t remember where that is but I do remember that someone did a short youtube video on unlocking them.

I clicked on all 3 chests surrounding Reign of Dragon Timeline. I guess those are the three chests. Are there more than this? I have been looking around for those chests but I can only find 3 and I have clicked on all of them. I got 55/100, 80/100, but not 68. Do I have to complete the lvl 90 timeline or some other timeline again?

No, there are more chests scattered around the monolith area. I’m at work at the moment so can’t go & have a look where they are. But the video online shows their locations. I think Boardman might have done it.

I only found 3 chests.

This is Vid from Boardman. He didnt get his Black Sun empowered. Only the other two.

Hey man those are the ones. All 3 crystals are lit (blue). Still no empowered black sun lol. Not sure what’s goin on haha. Feel like i’m missing something but everything is unlock. Redo the lvl 90 timeline again nothing. Maybe ill try to do the normal version of lvl 80 again instead of empowered.

Also do I need to finish the story quest (outside of monolith) maybe im missing some storyline quests that are tied to the monolith?

Nope, all you need to do is to do the monoliths to unlock the paths which give you access to the chest-things

I have done everything there is. Accessible to all the chests as per the pics you posted. Try to clicking on all 3 of them nothing happen. But I recall opening them already since all 3 chests are open and I can see the blue thingy inside the chest. Still no empowered black sun.

I completed the 2 path from the end of storm timeline (lagon) but on the empowered version. I recall only have done 1 path on the normal version of it. Maybe this is the problem? ShouldI just run the normal version of lvl 80 timeline again?

If you are 100% sure all 3 empowered chests are opened, then the only thing to do is to run the first couple of monos again in the 68 timeline, then when the “reset” button appears in the top left corner, click it and you should be able to start it empowered. I know @Llama8 already posted this, and you said youve tried that, but you might wanna try it again, as thats the only thing that could be wrong.

But the thing is that there is no Lvl 100 next to 68 e.g. 68/100. Like the other two empowered timeline show 55/100 and 80/100, while the black sun shows only 68. FYI, I have run 68 again and reset it nothing happen. I think the problem here is that only lvl 68 is shown on the map not 68/100. Sorry I’m not on my main pc right now. I think with screenshot is better to understand

Ok if youre sure the chest you clicked are the one in this picture, then it does sounds like a bug

Hi, so on the pics you just posted, there’s lvl 100 next to 68. But for me there’s only lvl 68. And yes, I’m pretty sure that chest is open on the path from ending storm to reign of dragon. I can see the blue thingy there as well (the chest looks open to me lol).

Maybe this is the problem? --> I completed the 2 path from the end of storm timeline (lagon) but on the empowered version. I recall only have done 1 path on the normal version of it. ShouldI just run the normal version of lvl 80 timeline again?

Afaik that wont make a difference, all that should matter is if that chest is opened, but it could be a bug i dont know about, so cant really help you further sry.
Maybe try PM a moderator, or write it in the bug forum.

Okey thanks anyway. Ill try posting this in bug forum

Just make sure you’ve also walked up to and clicked on the “chest” thingy. Not just open, but clicked on it (similar to the ones in the “alternate timelines” in the Temple of Eterra in the campaign).

Worth checking.

I did everything I possibly can. Clicking them also nothing happen. :frowning:

Here are some photos as well.
(1) Overall Map/Monolith Completion

(2) Reign of Dragon lvl 100 chest

(3) Harton lvl 90 chest

(4) Ending the storm lvl 80 chest

So from your first posts i assume you did run a few echoes in the lvl 68 timeline and reseted the timeline via the reset button. And that didn’t helped?

Did you already try finishing “The Black Sun” Timeline (lvl 68) regularly. (Killing the boss)
Maybe after that the new lvl 100 empowered version will appear.
Worth a try.

Yep, I ran a few and reset. That didnt work.

Ill give it a try by going all the way as you suggested.

1 Like